Incoming links not displayed

Is anyone seeing an issue where incoming links aren’t showing up in the inspector? This feature is pretty awesome but for some reason they don’t show up reliably. Some documents they do, some they don’t. I am using mainly Wikilinks in markdown documents, cross-referencing each other.

Can you provide more information on this, including screen captures, if possible?

Hello @BLUEFROG
I am encountering the same issue in DevonThink when playing with new incoming link feature in 3.6. The following are some details:

I have turned on both name and aliases and [[Brackets]] for automatic wikilinks.

Automatic Wikilink via Name and Aliases
When editing a markdown document, even after an automatic wikilink is created via name, it will not show as incoming link in the linked document.
Other format such as RTF or other plaintext like taskpaper document with Auto Wikilink via name are properly scanned. Only with markdown it does not work.

Automatic Wikilink via [[Square Bracket]]
In the same document, if I add [[square bracket]] around the same link, thus linking via square bracket instead of name and aliases mode, it will immediately be picked up by DevonThink and shown in the incoming link section of the linked document.

Hope my information is clear enough for replicating the issue. Thanks.

Do they show up in a new database? A screenshot of the document’s source and of Preferences > WikiLinks might be helpful.

Thanks Bluefrog and Chris. Just got back from work and now they are showing! I don’t understand why but working perfectly now so nothing to screen shot. I don’t know what triggered them to show. Like vit, my settings are square bracket and names and aliases checked, and the wiki links are in Markdown (mine were square bracket). The outgoing links worked fine and took to the destination but then was not seeing the previous document as a backlink in the inspector. Closing and then reopening DT3 did not help nor restarting the mac. But now without doing anything I am seeing the correct incoming back link displayed as expected. I will watch carefully and see if see again will screen shot to you. Steve

1 Like

Hi Chris and Bluefrog, actually I found another example.
Here’s the source document.

Click the double bracket link [[Address for Emerald Beach]] and go to that document:

But as you can see no incoming link is listed from the source document.

Here’s my current settings:

Let me know if this is a misunderstanding on my part or I have done something wrong.

Steve

Did you create this document right before clicking on the link?

Did you create this document right before clicking on the link?

If by that you mean create a Wikilink that doesn’t yet exist (with square brackets) then create by clicking on the link? I cannot recall if that’s the method used but just tried that method and created another document and shows the incoming link correctly, and was not able to reproduce.
I have another document in that database also not showing an incoming link by the way. If can reproduce the error in some way I will let you know.

Has your problem been solved? I also encountered a similar problem.

What version of DEVONthink and operating system are you running?

Hi Louiscard, no still an issue I am running 3.6.3. and it’s very inconsistent. I cannot rely on the link inspector to show outgoing or incoming links. I have one document open right now that shows no links in the inspector, but when I open that same md. note in DT3 (as a separate window by using cmd-O) the outgoing links are displayed in the inspector attached to that new window, but if I jump to a linked pdf, the incoming link is not displayed in the inspector from the document I just clicked on the link. So still a significant bug to track down in the link pane.

macOS Big Sur 11.2.1 Apple M1

DEVONthink 3.6.3

I’m having the same issue. My PDFs are not showing incoming links while markdown files are. I’m running DEVONthink 3.6.3 on macOS 10.15.7.

Were the incoming links created on one computer, are the items in the same database? Or does a rebuild of the database fix this?

Yes, the links were created on one computer. Original item and the item linked from it are in separate databases. I first ran rebuild on the database containing the item that was linked to. Problem still persisted. I then rebuilt the database with the original item. That fixed the problem. Any idea what the cause for the problem was?

Unfortunately not as we couldn’t reproduce this yet. Did you edit the files on other devices too?

I accessed them on DTTG 3 but I’m positive I didn’t edit them there.

Thanks for the info. Or did you move the items on iOS to different databases?

I had both the items in the same database in the beginning. I did move the linked item to a new database. There is very little chance that I did that on my iPad. It was probably done on the Mac.

I’m able to reproduce the issue, will check this.

1 Like