Incoming links not displayed

Hello @cgrunenberg

Probably the same issue I reported here

Happens still to me


The next release will fix this.

1 Like

The Problem be not fixed, here is my screen recording。

I found the documents do not work have a problem with wikilink recognition。(video :arrow_down:

I found the issue, it do not work after {>> <<}
I reproduce it.

Could you please send the relevant docs to cgrunenberg - at - plus a screenshot of Preferences > WikiLinks? Thank you!

A copy of the docs would be useful too - thanks!

Just wanted to add that I’m having the same problem. I’m trying to consistently reproduce to give devs some examples. Thanks !

I am also facing the same issue on pdf documents. Is there a way to fix it? @cgrunenberg
Using the current version of DT

As a workaround, I mentioned the link twice and then it appeared once in the PDF file. If I remove one, the link reference dissaperas again.

I am not seeing an issue in the current internal build. Stay tuned for the next release. Thanks for your patience and understanding.

1 Like

It looks like the “incoming Links” section does not display records that use one or more of the selected note’s aliases. Is this how it should work or a bug?

A screen capture of what you’re describing would be helpful.

I’m experiencing the same issue - links inspector is thoroughly unreliable, and requires us to “rebuild database” before trusting the information displayed there.

DEVONthink 3.7.2 (demo) running on Big Sur 11.5.2. No ‘extras’ installed.

  1. In brand new install of DEVONthink, make sure Preferences → WikiLinks has “Automatic”, “Square Brackets”, “All Items” and “Case-insensitive linking” selected.
  2. Create brand new database
  3. In new database, create a markdown document - let’s title it “Main Doc”. Add some dummy text to it.
  4. Create a second markdown document, and call it “Subdoc A”. Add some dummy text, and then create a wikilink to “Main Doc”.

At this point, I can see in the Document Inspector for “Subdoc A” that DEVONthink has correctly recognised the outgoing link - i.e., it’s listed in the ‘Links’ section.

  1. Now, go to “Main Doc”. We should see our link from “Subdoc A” listed in the “Incoming links” section of the inspector, but… nothing.

What makes it even more difficult to pinpoint the cause is the fact that it seems quite random. For example:

  1. Create a new markdown document, let’s call is “Subdoc B”. Add some dummy text, and again, create a wikilink to “Main Doc”. Again, we see in the Inspector that DEVONthink correctly recognised and listed the link.
  2. Go to “Main Doc”, and… see. Subdoc B appear in the “Incoming Links”.

Still no “Subdoc A”. And it doesn’t matter how many times I go and make changes to “Subdoc A” - change the link from wikilink to ‘normal’ markdown link (i.e., item link), it just won’t appear on the “Incoming Links” for “Main Doc”.

It seems this is not an issue that happens only with markdown documents, either. I tried adding documents of other types - html, rich text, images - and over the course of a day I experienced the same problem, intermittently, with all of them: some links simply don’t show in the Inspector.

Finally, regardless of what unreliable mess you might have with your links in the Inspector, if you do a File → Rebuild Database, it seems to correct itself: the links that were missing miraculously appear, and the information seems correct.

Of course, as soon as you start editing the files, and adding/removing links, the problem seems to come back again: the links we see in the Inspector are utterly unreliable, unless we’ve just done a ‘Rebuild Database’…

A copy of all documents plus a screenshot of Preferences > WikiLinks would be great, so far I couldn’t reproduce this.

I have a similar issue with the normal direct links (such as x-devonthink-item://ABCD). I don’t use WikiLinks.

Outgoing link detection always works. Incoming link detection works only in some cases.

Are there any news about this issue?

More information, including screen captures would be helpful.

I’ll try to recreate the issue in a new database with dummy documents.