Incomplete sync in DTTG3?

Installed DTTG3, accepting its offer to automatically transfer my DTTG2 stuff. Configured Dropbox, and it correctly found the sync stores for my existing databases and correctly populated a complete index.

Bookmark items work fine, and I successfully created a new Bookmark and a new RTF item.

And then I moved on to the PDFs … and discovered that all of them were listed, but none of them were downloaded. Message says “Unable to display document. The file you’re trying to access is either not a PDF file or might be corrupted.”

Uh oh.

Brought up DevonThink on the Mac, confirmed that I have the latest version and that all those sync settings are fine, which they are. Discovered that the new files I created with DTTG3 aren’t coming back to the Mac, either.

DTTG2 is still installed and still working correctly, so it doesn’t seem to be a Dropbox issue.

The iPad is running iOS 14.3 and has more than 17 GB of free space.

Any ideas?

In DEVONthink To Go 3, select Help > Contact Us to start a Support Ticket.

Did that.

What mechanism does the Contact Us option use to send? I rarely use Apple Mail on my iPad, so it may not be configured correctly.

Some seconds after you send the message, you should receive an email with a ticket number assigned to your problem. If you haven’t received, something has gone wrong.

I can confirm that it is not a DropBox issue, I use iCloud. Some of my formerly perfectly fine PDFs are now marked as size zero and deemed unreadable or corrupt by DTTG 3. No pattern discernible, yet, seems completely random to me.

Edit1: The issue is not restricted to PDFs.

Edit2: Unfortunately the issue is being synchronised even to DTTG 2; I had to shutdown DTTG 3 before it rendered vital documents unusable. Hope this is just a surface issue.

I have exactly the same experience. It works fine on my iPhone, but not in the iPad…I’ve reinstalled, restarted etc. - but the sync is broken :frowning:

Welcome @DKHNS

  • In what way is sync broken?
  • Is there anything reported in DEVONthink’s Window > Log?
  • Is there a triangle on the sync icon in DEVONthink To Go’s bottom toolbar? If so, touch it and tell me what it reports.

In DTTG3 nealy all documents - primarily pdf’s - are not downloadet into the database. In fact the first problem is that the sync settings are not transferred from DTTG2 to 3. On my iphone, everything worked smoothly and DTTG3 worked without any issues. Everything was copied into version 3.

No triangle on the sync icon.

I have the same issue, on both my iPad and iPhone. After the upgrade, most of the PDFs were inaccessible on both DTTG3 and DTTG2. I see no triangle on the sync icon.

Really strange…after the install on my iphone I went into DTTG3, and everything worked. My sync configuration was copied, all the documents worked fine…and really no problems at all. Yesterday I started the installation on my ipad, and no sync settings were transferred to DTTG3. When I tried to enter the sync settings manually, it did not work - even though the settings were correct, and the program recognised the sync store, the errors still persists…the pdf’s are still inaccessible. All records in the database are shown, but the content is not accessible.

Just discovered that in a 20 GB database with about 14.000 items (seemingly) by chance here and there some files are no longer accessible from the sync store (iCloud legacy), neither by v2 nor v3. They are set to zero kB and zero pages. Some “corrupted” files were just fine yesterday others I did not touch for months. The losses became apparent to me only today when I first used DTTG 3. No error messages whatsoever. Quite the catastrophe. Some documents are lost forever, others I might be able to restore from backups. I guess I should have waited a few days … Maybe this is just a handling problem and the files are actually fine? I am at a loss how to phrase a fitting bug report since the “spread of zeroes” seems so random. Just want to let you know; going to wallow in my misery now.

The “zeros” is also what I discovered. The actual size of the document is shown, but the number of pages is zero.

Are the files still intact in the database on a Mac?

Sorry, I cannot check, since I don’t use a Mac anymore (gone full iPad in 2019). I have to try and restore the damaged files, though, and will borrow a Mac from my former workplace but this will take a while … maybe somebody else who encountered the same problem is able to provide more insight sooner.

We cannot reproduce this issue so we’re trying to gather info. Thanks.

My ticket from yesterday has now gone through. Ticket #987376, log files attached.

I’m deinstalling DTTG3 for the time being rather than risk damage to my data.

I still have no Mac but I have been assessing the inaccessible files. After examining about thirty “zeroed” files I can say that every single one of them was added to the database through DTTG 2.x either from my iPad or my iPhone. Older files in the same database that originate from DTP uploads via Mac are all fine. I cannot say this for sure for every single file in question but at least some of them I have definitely accessed both via iPad AND iPhone. So at one point the iCloud synchronisation must have been working properly for these files, too. Maybe this has something to do with the data store preparations you did for v3?

Do you recall if version 2 was open when you migrated to version 3?
If so, I’m wondering if a sync was running in 2 and perhaps that may have contributed?

As we can’t reproduce this error, we’re just thinking about "Well, maybe…'s

Yes, it was open but I cannot tell if there was a sync going on at the time. The whole thing is quite foggy and there is more correlation than causation. I have to work through the whole database now and hopefully will find some clues as to what might have happend. This seems to be an isolated incident as far as I gather from the community.

I have had no problem at all on iPhone, iPad or Mac. The syncing is rock solid and totally reliable for me.