Indexed database of OneDrive folder has a missing reference... and won't reindex

Out of the thousands of files in this OneDrive folder, apparently one has disappeared, and I don’t need it or care. But DTPO is refusing to Update Indexed Items because it can’t find the missing file.

Can I do anything to get past this? Or do I have to scrap the entire indexed database and start over with indexing this huge OneDrive folder again?

Thanks for any help.

Did you empty the database’s Trash?

Yes, trash is emptied. There are missing files, although they aren’t actually missing on the OneDrive, they have just been moved. When I choose Update Indexed Items, DTPO hangs and never comes back. When I force quit and reopen that database, I get a message about errors, asking if I want to repair. I choose yes, and the repair never works.



There are missing files, although they aren’t actually missing on the OneDrive, they have just been moved.

Since DEVONthink uses absolute file paths, they are missing to DEVONthink.

Missing files are discussed in the Help > Documentation > Troubleshooting > Repairing a defective database > Missing Files subsection.

Also, they can’t be repaired as they need to be curated by the individual.
Missing files are listed in Window > Log.

I cleared up the missing files issue using the steps in the documentation. So now I am able to open the database without errors. However, there is at least one sub-folder that was created on OneDrive that is not being indexed in DTPO. I believe this worked in the past. I have tried Update Indexed Items and it still hangs.

Suggestions? Thanks.

Check this thread on recent changes to OneDrive; there are other threads linked from there. As you are only seeing one file affected, I am guessing that this is not going to be the issue - but I am not sure. In any case it may be worth changing the absolute paths in DEVONthink if you have not yet done so. If you do make such a change, it is essential it should be made (at the same time) on every installation of DEVONthink, insofar as they are synced. That also requires that the OneDrive client is identical on all devices.

Ugh, thanks Blanc. I honestly didn’t even notice this change. I am going to try pinning the entire top-level folder (that’s the folder that I have indexed in DTPO) and see if this helps things in the existing database, and if not, I will create a new database now that it’s pinned. I’m so glad you pointed me to this issue.

As an FYI, if I do end up needed to delete the old database, what’s the best way to do this? I obviously don’t want to delete the files on disk…

Thanks again all.

1 Like

Deleting a database of indexed files has no effect on the files in the Finder. It would only affect imported files.

So since it’s just indexed files, should I delete the database while in DTPO? Or can I just delete the database file outside of DTPO?

While the latter is possible, the former is preferable. It helps DEVONthink keep it’s record-keeping clean. :slight_smile:

Understood - thanks!

My pleasure :slight_smile: