Invalid Encryption Key iCloud (Cloudkit)

I am trying to setup DevonThink to work with DevonThink To Go (Mac <–> iPad). I am not able to get my database to sync (Not yet synchronized, upload database).

I am seeing the same error in my app.

I am unclear if I have created an incorrect password for my encryption key or set something up incorrectly.

I could use some help!

Welcome @davidrmoulton

  • What application did you set up first?
  • Did you add an encryption key whehn you first set up the sync location?
    • If so, you must use that key in the other application when setting up the same sync location.

I have had DEVONthink for awhile, added DEVONthink To Go this weekend. I am using the same key, I manage them via 1Password and use copy & paste to enter it into the fields.

I’d suggest you verify the encryption key on the Mac, not in 1Password.

  1. Do a Spotlight search for Keychain and open the Keychain Access application.
  2. In the logins section on the left, look for a key named DEVONcloudy Encryption (name of service) like DEVONcloudy Encryption (Dropbox).
  3. Double-click it and check the Show password checkbox. You will be required to enter your Administrative password. (This is the password you use to log into your machine with.)
  4. Press Allow (or Always Allow, if desired) and the password will be shown.
  5. Take note of the password, then quit Keychain Access.

The pw in Keychain Access and 1Password match.

What version of DEVONthink To Go are you running?

We haven’t seen such an issue in a long time, but you could try manually typing the key in instaed of pasting it.

Latest on all, will give that option a try.

This didn’t help.

Did you try adding an encryption key after having synced?

So, take it out, and try that?

when I take out the encryption key I am seeing my iPad file on my Mac… waiting on everything else to sync.

Odd that this is not working.

What kind of sync are you doing?

Hi! Having the same issue. Just started from scratch: deleted old databases (backup up files to an external HDD), deleted sync. Added new database, added new sync location (no iOS devices yet) - immediately DevonThink states invalid encryption key in the log. Frustrating :confused:

Did you only remove the old sync location or clean it first?

Both. To be absolutely certain, I just did it again. Cleaned location, removed the sync. Waited a minute, now have just re-added it, will update with results…

Do any other devices still use this sync location and an old & different encryption key?

Thx for your hints. I went nuclear and erased everything, now it seems to work after starting from scratch :slight_smile:

1 Like

I’ve cleaned the sync stores on iCloud (CloudKit) and still I get the “Invalid Encryption Key” on DTTG 3. I have copied the Encryption Key from Keychain Access and pasted it in the CloudKit setup on the mobile device. Each time I tap CloudKit to go into it though, I still get the Invalid Encryption Key message. What else can I do to make this work on my iPhone or iPad?

Are you running DEVONthink To Go 2 or 3?

I’m running 3 on both iPad and iPhone.