Invalid Encryption Key on Webdav

So, I think Devonthink really hates me.

After having way too many issues with DropBox, I have decided to go Webdav, and have a Synology NAS setup with a Webdav server running.

I have tried to set up a sync store, but I get two errors. One is an Invalid Encryption Key (even if I leave it blank) and the second is;

NSXML Parser Error Domain 26

This software really does not want to me to use it I think.

Any help would be a bonus. I have been trying to find a solution to DropBox for a month!


Is the WebDAV server really running? Usually this happens if only the HTTP server is running and returns an HTML document instead of the expected XML. Are you able to mount the URL of the WebDAV server in the Finder via Go > Connect To Server…?

Yep! It is. :frowning:
So the next question… If I install the WebDav app on a Mac, I wonder if I could Sync to it, but would Devonthink allow that between those two computers…

Basically this is what I need…

MacA has the DB local.
MacB is in the same network and use Bonjour
MacC is outside the network and syncs with WebDav server that is running on MacA


I would love to simply do it with a VPN, but that has been a rabbit hole I have been in for a month, so I have given up!

Do you see any messages in the log on the NAS? As @cgrunenberg said, the NSXML error is caused by HTML entities in the XML stream, which happens if the setup is broken. What happens if you do a Connect to server in the Finder, and how do you connect to the server (i.e. what server address & protocol do you enter use)?

As to your idea with a WebDAV server running on the Mac: It might be doable, but what’s the point in doing that if you already have a NAS setup?

The VPN does not help with your issues here, it just adds encryption and another layer of complexity. There’s no “simply do it” in this context :wink: In other words: If your WebDAV server is running and you can connect to it from inside and outside your LAN, you can add a VPN layer to secure the communication.

Another typical reason is that the URL is not correct.

The Webdav server appears to be running fine. I can connect to it etc.

This setup is because I am remote to my office. So I need to be able to sync DT - and have been with DropBox, but the errors and the sync drop outs are killing us. So we have to find another way.

Yes, I could run a CloudMe server, but I am leaving the devil, to hook up with a demon, if that makes sense. So time to bring it all in house.

If I can get the Webdav running on the Mac, then I can port forward on the router and it “should” just sync. I have tried the VPN thing, but the router at the host end is being problematic with OpenVPN and being able to see local assets. I can connect with PPTP, but then all data heads down the tunnel, so I would need to connect every time I want the sync to happen.

With a port forward setup, yes, it is punching a hole through the firewall, but it’s a solution, and if encrypted, who cares I guess. Am I am sure data is encrypted with DT anyway!

I was specifically asking how you connect to it. This is a NAS, it possibly has lots of services running. So the connection string is important here.
Also you didn’t say anything about messages in the NAS’s log.

There is nothing of note in the NAS logs. The only place they appear is in the FILE TRANSFER section, and that is blank currently. There is nothing else running on this NAS, as it’s only been a few weeks.

So I have just run a test on a local machine, and I can get DEVON to sync to localhost and it’s all encrypted. So technically, all I need to do is get Devon (remote) to be able to see that Mac, and it should sync perfectly. Fully encrypted, and happy!

So I just need to decide if I am happy to have a port open, or if I want to VPN in whenever I need to sycn the DATA. At least now I have an option - Finally!

So what about the error messages from the start of the thread - were they happening when you connected from outside your LAN?

Yes. The error messages were me trying to connect to the NAS from outside the LAN. I could see the shares fine in a browser - but Devon spat those errors. I was trying to setup a new sync store, but couldn’t get past those errors.

Did you try Go > Connect to Server… in the Finder using the same URL as suggested?

Yep! It worked fine.

Hopefully the testing I will do today will get results. I will post all the details here when I know it’s working.

Ok… I sort of have this working. Sort of. :frowning:

I connect no problem, and it appeared to download the DB (all 14GBN of it) but now it looks like it wants to upload the entire DB. Why??

Is there a way I can simply tell DT, that I want that DB here, without utilising the existing one I had. Basically, dragging a fresh copy down.

I thought it did that, but it now says it’s uploading the entire contents of the DB and I am not sure why. :frowning:

Now it continues to time out. ARGHH! I am about done with this crap! Seriously, I don’t know why I am bothering.

That’s what I was thinking, too. You want help but choose to ignore requests for information by those you’re asking. You don’t provide facts that others can use to help you but give mostly vague descriptions. Right now, nobody knows if you’re connecting to a Mac running a WebDAV server or to a NAS. Nobody knows if you’re doing that in your LAN or over the internet.
Like this here:

What could “here” possibly be, and what is the corresponding “there”? How do you expect anybody to help you if you don’t provide any facts and just ramble about?

That is the way it works. I don’t think it is updating all the just downloaded database but simply checking things as the sync engine works, not only for WebDAV.

but it now says it’s uploading the entire contents of the DB and I am not sure why.

Sync is bidirectional by design so there is transactional data that is passed back and forth between devices - Mac or mobile. This is to ensure the state is the same on each device.

OK… I am happy to give you a complete updated for those that are not following;

After months of battling Drop Box (you can imagine the frustration) I have been trying to find an alternative. So my initial plan was to use a VPN to get back to one of the Macs in the office that can act as the host, but getting Bonjour to work over VPN is a pain.

So next plan - Use the Synology NAS to host a Webdav server. That failed, as for whatever reason DT would simply not work. The server was fine, and I could see the share in a browser, but DT was having none of it.

So next plan - Run a Webdav Server on a Mac in the office. That plan started out rough, as DT kept timing out, and then once the DB was down, it appears to want to upload the entire contents again, and the kept timing out.

So I scrapped it, and started again, and let it run overnight. This morning it appears to have synced the DB, although a LOT of time out errors, so I am not sure how that is going to pan out.

Time will tell. Today will show whether this plan is going to work or not I guess.

getting Bonjour to work over VPN is a pain.

As noted in the Help, Bonjour cannot be used over VPN.

1 Like