Is there a limit on OCR in Devonthink Pro?

yes it is

Does removing and reentering the license make a difference?

Removing and Reentering the license didn’t make a difference on my end.

Log still says reached its maximum units when trying OCR.

That’s actually an issue of the engine, not of DEVONthink’s license. Deleting ~/Library/Application Support/ABBYY/SDK should fix this.

1 Like

Ok. Deleting the SDK worked for me. OCR is now functioning normally.

Thanks for this!
I tried deleting the SDK folder, and the OCR “limit” has been resolved too.

Any idea why this is happening?

Thanks! This worked for me too, and now the OCR is working.

Welcome @alvin

ABBYY is stating there is a permissions issue, but it’s unclear if that’s actually the case and why it would be happening (especially since the issue is sporadic).

Got it. Thanks Jim. All OCR has been working fine since. :slight_smile:

You’re welcome and thanks for the follow-up!

Had the same kind of issue here…version 3.5.1 and working last week normal and now this morning this issue… also deleted the SDK folder and OCR working again.

Feels a bit strange to delete a folder this way. How is it possible this issue all of a sudden is there ?

We are currenlty investigating some OCR issues with the developer of the framework.

Try deleting the ABBYY licence files and installation, and reinstalingl the ABBYY components. To do this…

  1. Quit DEVONthink
  2. In the Finder, select the Go menu while holding the Option key , then choose Library .
  3. Open the Application Support/DEVONthink 3/ABBYY folder.
  4. Drag the DTOCRHelper application to the trash.
  5. In the ~/Library/Application Support/ABBYY folder, remove the SDK folder.
  6. Start DEVONthink and select DEVONthink 3 > Install Add-ons and install the ABBYY Finereader resources.

@MMW you are a lifesaver. @BLUEFROG FYI–I had exact same problem.

deleting ~/Library/Application Support/ABBYY/SDK did the trick. I followed this thread from the very top, trying each suggestion in order–doh! After trying all the recommendations in order to include de-activating my license and so on, I finally got down to the SDK folder recommendation. Deleting that worked. OCR functioning normal again.


I ran into this issue this morning.

Error (including spelling errors) was: ‘Analze Pages Error, license pages remaing: 0’

I licensed the software about a week ago, after trialing it for three days. I’ve been testing the OCR feature extensively with some scanned PDF files in batches since then.

The procedure suggested by @aedwards successfully resolved the initial issue.

Later on after resuming the scanning, the process got stuck ‘Adding Document’ for more than an hour and I had start all over from the first unprocessed file.


After running OCR against a few more scanned PDFs, the same error has returned after a couple of hours:

‘Analze Pages Error, license pages remaing: 0’

I’ll have another go at the re-install procedure, but it looks like there’s some kind of limit to how many documents/pages can be processed.

If you get this error, try the following:

  • Quit DEVONthink
  • In Finder select the menu Go->Go to Folder, copy and paste the line below and press Go
    ~/Library/Application Support/ABBYY/SDK
  • Drag the folder 12 to the trash
  • Restart DEVONthink

We are waiting for a fix from ABBYY for this issue however the next update will include a workaround

1 Like


Many thanks, that seems to be working again, and is a much quicker way of resuming a batch of files.

1 Like

This is still an issue. I get about 20 large pdfs OCR’d then the error reappears and it quits OCR’ing… Even after the workaround, the license error still returns in 3.6.3


Which version of macOS are you running?

10.15.7 Catalina