Issue with database

Hi everyone,

I’ve partially mentioned the problem in another thread (Initialization–Database couldn’t be created!).

I have one database initially created in Mac and later synced to WebDav storage. I use DT on Mac and a bunch of iPhone/iPad devices. Everything worked fine until one day - the database stopped working on Mac with just “bum” sound when I tried to click on it in DT interface. When usual way was used (File -> Open database), message “Initialisation: The database cannot be created” was shown.

iPad/iPhone had access to the database without any issues.

What I did after discovering the thread Initialization–Database couldn’t be created! - as explained, renamed the DB file, mounted, removed the lock file, renamed back, tried to open in DT - got exactly the same result as before. Since it was accessible on other devices, I let it go and wait for new release.

I’ve just updated to DT v 3.5 and the problem persists - I still can’t open the DB on Mac.

Any ideas how to fix that?

Did DEVONthink crash or was there any kind of other unexpected interruption (e.g. force quit)? Only in this case removing of the lock file might help.

To the best of my recollection it happened after something crashed - was it DT or laptop OS I’m not sure

Are you able to open the database after changing the extension to .sparseimage, mounting it in the Finder and double-clicking the .dtBase2 file on the volume?

Yes, I can open database and see contents of the archive. Did it few times to kill the .lock file, it works fine

It’s possible that a crash of the computer damaged the sparse image in some way. Maybe this will work:

  1. Use Applications > Utilities > Disk to create a new HFS+ formatted and encrypted disk image
  2. Mount it in the Finder
  3. Change the extension of the encrypted database from .dtSparse to .sparseimage, mount it in the Finder too
  4. Move the .dtBase2 file from the old sparse image to the new one
  5. Unmount the volumes again
  6. Change the extension of the new sparse image to .dtsparse

Are you able to open it by double-clicking?

I played around with it during last 2 days. Here are findings.

This database was password protected. When filename changed to .sparseimage and mounted on system the password was requested. Once password is entered, the image is mounted with single .dtBase2 file inside. If I click on the file, DT opens the file with no problem. This made me think the root cause is maybe in encrypted container but not the storage itself.

I tried to follow your suggestion but stuck at #1 - my Disk Utility doesn’t seem to have option for creating HFS+ partitions:

Am I doing the right thing? I selected File -> New Image -> Blank Image. MacOS Mojave if it matters.

HFS+ is actually Mac OS Extended, hard to tell why Apple uses the abbreviation in most cases (e.g. APFS, ExFAT) but not in this case.

I see, thank you @cgrunenberg.

I’ve created new volume, copied the .dtBase2 file pulled from .sparseimage file before, unmounted it and renamed to .dtsparse as you suggested. Doubleclicked on it and got unknown format message in DT:

Additionally I tried to change extension to .dtBase2 and open it as database in DT but this one failed as well with Unable to ininitialise the database message.

The extension has to be .dtSparse, the next release should also accept .dtsparse.


Renamed the file to .dtSparse, doubleclicked - got password entry window, entered password and nothing happened.

I tried to use File -> Open Database on the file, same - password window popups and nothing happens after password is entered.

I end up using unencrypted database (extracted from the container) for the time being… Is there a way to convert it into encrypted DB later? Hopefully it will work fine after?

The above steps are actually the recommended ones. What’s the name of the .dtBase2 and of the .dtSparse files?

Personal2.dtSparse and Personal.dtBase2

Please choose Help > Report Bug while pressing the Alt modifier key and send the result to cgrunenberg - at - - thanks!

Just did so - thank you!