Keyboard shortcut for `Copy Item Link` (^⌥⌘C) doesn't work

Hi, I ran into a weird issue.

Expect Result

In DT’s Data menu, I can see the keyboard shortcut assigned to Copy Item Link is ^⌥⌘C. When I press this combination, I expect DT to copy the item link of the currently selected item. If I invoke this shortcut with the Data menu open, I expect the Copy Item Link option to be briefly highlighted, showing that DT has received it, before the Data menu is automatically dismissed.

Actual Result

When I press ^⌥⌘C with an item already selected, nothing new is written to my system clipboard. If I press the shortcut with the Data menu open, the item isn’t highlighted and the menu isn’t auto-dismissed. Apparently DT hasn’t received the keystroke at all.

Other Observations

  • The Copy Item Link command works properly when I click it in the Data menu or the contextual menu. It’s just its keyboard shortcut that doesn’t work.
  • The keyboard shortcut for Copy Page Link, ^⌥⌘⇧C, works properly.

Is this a bug or am I missing something obvious? Thanks :sweat_smile:

If you use apps like Alfred or Keyboard Maestro: could it be that you’ve assigned this shortcut there and forgot about it? Happened frequently over here until I found ShortcutDetective.


Thanks for pointing me to ShortcutDetective, gotta love those very specific utilities. You don’t often need it but when you do, it’s a lifesaver.

In my case, the keyboard shortcut is occupied by Logitech Options Daemon:

This is totally unexpected to me. Now I have to figure out why would the daemon need this shortcut and how can I take it away from the daemon and return it back to DT. Thanks again for the very helpful tip! :slight_smile:

Another possibility is to assign a different shortcut to Copy Item Link via System Preferences > Keyboard > Shortcuts.

Thank you Christian! I find the default shortcut quite handy so I would prefer keeping it :stuck_out_tongue: I opened a support ticket at Logitech’s and if I can’t change the daemon’s behavior, I’ll take the route you suggested.

In this case: The same issue had already been reported over in the German part of the forum:

maybe you could add that to your support ticket with them.

Thanks for the info!

Thanks for pointing this out — I installed Shortcut Detective and found out that Logi Options Daemon is also the reason that several shortcuts don’t work in Scrivener (cmd-opt-ctl-t/k/m etc).

What on earth is a daemon doing with shortcuts anyway? And why is there no way to stop it behaving so badly? Annoying…

1 Like

My exact same thoughts. I should also point out that the daemon occupies this keyboard shortcut but seemingly doesn’t do anything when it receives this shortcut input. Even more annoying, huh?

Also, while this is not directly related to DEVONtech products, I think I’ll post an update to this thread if Logitech customer support provides any useful info to me, in the hope that it might prove useful for other users.


That would be great!


Logitech finally resolved my support ticket (after ~110 days :man_facepalming:). Here’s the reply (cc @Axel ):

Happy Monday and I hope you had a wonderful weekend. I have some great news! We were able to get to the root cause of why this issue is happening and it will be resolved in a future update. I can’t say for certain yet which version it will be, but I will reach out to you once it is released and tested. I apologize that it took so long but it took some time to get to the root cause. I am glad that we were able to find a resolution. I’m going to set this ticket to solved for now, and follow up with you once the update is available.

Since it’s unclear when this update will be available, I will once again post an update in this thread for future reference.


Thank you for keeping at it!

1 Like

Agreed! Thanks for the follow-up @xurc

1 Like

I’ve had the same problem, and arrived here searching for a problem. Seems Logitech still have pushed an update?

Apparently it hasn’t been fixed yet.


This issue has apparently been fixed in the latest update of Logi Options, version 8.50.210. (cc @brookter @Axel @canion)

I think I received this update yesterday, but it only occurred to me minutes ago that the issue could have been fixed. I tested and now Logi Options Daemon no longer hijacks ⌃⌥⌘C from DEVONthink.

PS. I did not receive the promised update email from Logitech support. At least the issue’s solved though.


Thanks for the follow-up!

1 Like

Thanks for letting us know — I’ll check it asap.

Oh this could be helpful, because that Logitech software actually intercepts and swallows MANY shortcuts using ⌃⌥⌘+(any key)!

Indeed, as pointed out in a previous comment:

I only tested ⌃⌥⌘C, but I assume the issue has been fixed for all previously intercepted shortcuts.