macOS Monterey / Apple Mail Plugin

Hi DTP support team,

after updating three macs to macOS Monterey the apple mail plugin in apple mail extension is no longer visible. Full disk access has been set. User account with administrative rights. Plugin version 4.0.6. DTP version 3.8.2.

any suggestions?

best regards

Did you check that it’s enabled in Mail’s preferences?

Same issue here.
Plugin is enabled in Mail’s preferences, but DT did not show installed status of plugin, see screenshot.
My system:

  • macOS 12.2.1 (M1)
  • DT 3.8.2
  • Mail 15.0
    Screenshot 2022-02-17 at 21.33.29

Thanks for the report!

The plugin should be functional and this only a cosmetic issue. Are you saying that’s not the case?

So far I have no technical impact identified with regards to importing emails.

Can you please clarify what you mean. Is it working or not?

That’s a glitch of this panel on certain Monterey versions, the next release will fix this.

What I find is that each update of macOS where is somehow touched results in plugins being disabled and has nothing to do with rights.

Try the following:

  1. In launch preferences.

  2. In the General tab click on “Manage Plug-Ins…”

  1. You should see the DT3 plug in (yeah, mine says BigSur but works in Monterey)

Enable Plugins

  1. Check the box and restart mail. If you don’t see the DT3 Plugin there you will need to reinstall it through DT3.

This happens so often that it’s now SOP for me to check it on an OS update.


Edit: Typo

1 Like

As we do too :wink:

And the name of the plugin is correct, even if it looks odd. It should still work as expected when properly installed and enabled.

When dragging a mail message from Apple Mail to DevonThink (latest versions of both running on latest released version of Monterey) I get the message “Import of 1 messages failed”

I checked I have the the BigSur mail bundle checked. I uninstalled and reinstalled, just in case.

What is the the next thing to check?

Does it work using Message > Add to DEVONthink 3 in Apple Mail?

Yes. Messages are added to the global inbox.

And drag & drop still fails, e.g. to a new database? In which mailbox is the message located?

So. It is strange. After I used the menu command the email went to a mail archive database that I created years ago. I then managed to drag three emails to my new archive database. But then dragging stopped working. Even though I was testing with different emails. The menu option also stopped working.

I closed DevonThink , reopened it and tried dragging and dragging failed. I just went back to try the menu option again and it worked, but emails are going to the global inbox. I tried dragging to my new mail archive and that worked. If I drag a dupe I get a message saying it failed (as expected). If I drag to the inbox It worked. Now I have managed to drag 20 emails, to a different location and they all went through.

There is a lot more software than DEVONthink’s involved in these mail drag and drops. Could be something re-started or something…

What kind of email account is this, e.g., gmail, yahoo, private/corporate, etc.?

It is not from a free service like Yahoo or Gmail. This is email accessible by Apple Mail on Monterey. I just tried to drag 18K emails in, since I had good luck with dragging once this morning, but it failed.

Is there a log somewhere that details why the email import is failing?

Hold the Option key and choose Help > Report bug to start a support ticket.

Here is an example from DevonThink’s console log.

2022-03-10 12:01:56.927 DEVONthink 3[8580:815005] ERROR: Couldn’t retrieve message 35945 from Apple Mail: {
account = “GT@PB”;
automaticTagging = 0;
groupUUID = “E4E10093-4B01-4343-9B60-C05B66C38CE6”;
mailbox = “INBOX.Archive”;
subject = “Fwd: Arrived to Croatia”;