Macosx. Monterey Mail extension

Hello, I have just updated my mac to Monterey, and DEVONthink mail extension it doesn’t work. Do you have a plan to update the extension? Thanks

1 Like

I can’t confirm that; I’m seeing no problem using DT 3.8 with plugin version 4.0.4. Make sure you have v 3.8 installed; in DT go to Install Add-Ons and see whether an update to Apple Mail Plugin 4.0.4 is offered. Following that, you may have to reactive the plugin in Mail.

Install Add-Ons did the trick for me.

I had the same issue, incompatible mail plug-in. Installing the current version was the cure.

Oh dear. Then I really have a problem. I got the complaint about the plugin. When I open up the DT menu, I get no option to reinstall it.

I re-installed DT 3.8, which makes no difference. Closed Mail, tried again. No luck.

Any ideas please?

According to the screenshot you’re using the Standard edition which does not include/support the Mail plug-in.

Thank you. Yes, I used to use DEVONthink Pro 2.x, but then DEVON decided to make the old “PRO” version the new version 3.x “STD” version (or in other words, started charging much more for PRO). The old version 2.x plugin was left in place in Mail, until Monterey told me about it and disabled it. I have now removed the old plugin.

This seems to have caught a couple of other people too.

Just curious: which OS were you using prior to Monterey?

Big Sur 11.6

Mail then apparently accepted the plugin, but to be honest I can’t recall ever using it (not recently, anyhow).

I got a few really confusing messages, this one in particular that suggested that the version of the plugin I was using was more recent than the most recent version known to the updater:

Whoever is experiencing problems after updating to Monterey, it is worth pointing out that the plugin is not found under “Preferences → Extensions” but tucked away under “Preferences → General”.

It was only after right-clicking what was there and deleting it in the Finder and then going through the “Install Plug-Ins” routine that everything starting working again. Hope this helps.


I spoke too soon.

Even after all the hoops I cannot get the Mail plugin to work. Any ideas?

Although the conversation here Mac OS Big Sur and Mail plugin - #29 by BLUEFROG Was about a previous version of DEVONthink, gives some info about where the plug in might be stored, so you can delete and re-install the mail-addin I’m not at my Global HQ right now to check the actual location, but this a start.


Yeah it can get surprisingly confusing, thanks for that. I had muddled my way through last night.
Didn’t get too angry though since Monterey basically feels like Big Sur working more smoothly. First time I have updated and felt comfortable straight. I know have no IT friction, between DEVONthink 3, Keyboard Maestro and Apple and one or too other power apps and frankly changes don’t excite like they used to. Feels mostly like a chore now of rejigging the details or re learning some short cuts.

1 Like

I closed everything restarted and made sure the tick box in DEVONthink 3 had the right plug in. I got this message a couple of times. It has to be the most recent DEVONthink 3 plug in; as always I can’t remember the details: the ‘usual’ worked for me, close everything, restart the computer. Frankly I have often found that a short delay in opening apps helps. It is issue between me and Mrs Tudor: she doesn’t hardly give stuff time to open properly sometimes. There just is a short delay. Restart and let the indexing finish for example.

1 Like

Running DT Pro 3.8 on MacOS Monterey 12.0.1 (21A559) with Mail 15.0 (3693. on a new machine, so there is no legacy cruft (no Migration Assistant or similar). I tried the right-click and delete in Finder thing mentioned above after the first install failed, reinstalled the plugin and I’m still getting this error:

Any ideas?

I got the plug-in working by deleting and reinstalling the files mentioned earlier in the thread.

But why does the DevonThink mail plugin still indicate it’s big-sur?

I got it to work, too, thanks to this thread — and set the keyboard combo to hyper-D. nice! But it looks like the Monterey plugin framework changes mean this and other plugins need to be redeveloped in mailkit, and the existing plugins will eventually stop working.

Same here, and I can confirm that I’m using DT Pro. I was puzzled by the “Version 4.0.3 is available, you’re using version 4.0.4” notification but went ahead and clicked on Install. Big mistake–I ended up in the same loop mentioned in other posts: delete BigSur bundle, install add-on, activate in Mail, and get the ‘incompatible’ notification. The only thing that worked was moving the BigSur bundle from a backup into the Mail > Bundles folder. Now all is well, but the “Install Add-ons” is showing the same “You have 4.0.4” notification.

1 Like

Thanks for your responses. I deleted and re-installed the plugin again, exactly as last time, but it appears to have actually worked this time. I have no idea why, perhaps something was fixed in MacOS Monterey 12.1.

I’m also having this issue. In my case, DT3 shows that the plugin is installed (it previously gave me the 4.03 is available you are running 4.05 message). Now that it is installed, I go to Mail and the Message menu option but there is no Add to Devonthink. And when I go into the library and DT3 plugins, the folder is empty.

I also remember in a prior version there was a way to set up a keyboard shortcut to archive one message to DT or even archive a whole mailbox. I don’t remember where that option was for the life of me. I used to have a keyboard shortcut for adding one message to DT but can’t locate that either. Any thoughts on my particular situation?

Try in Mail: Menu-> Preferences, Tab: “General”, Button “Manage Plug-ins” are report what you see. For me there is an option to activate the DEVONthink mail plug-in (which I have done).