Mail import (Apple) taking too long (for <1000 emails?)

To whom it may concern,

I’ve successfully automated importing email now for months (>3 months) (via sikulix). And I’ve had no issues…until today.

Now when I click on a mailbox under Apple Mail I get the endless circling for a very long time (> 1 minute sometimes) which isn’t normal. Also, when I right click on the mailbox and click on the refresh menu item the whole Apple Mail structure disappears and the after > 20 seconds reappears again. This also is additional delay that wasn’t present for the past 3 months.

Any ideas for why the delays are starting to creep into the mail import process from OSX Apple Mail?

Attached is a screenshot for you reference.


Ok, so I followed these instructions (Archiving Gmail in Apple Mail Slow and Buggy) but I’m still seeing the circle (it has been about 10 minutes now…since I clicked on one of the folders to import it).

I’ll keep looking. Wow…it just finished while I was writing this post. I’ll see if the next folder takes just as long.
Thanks, J

Well, it appears to be fixed…performance must have improved. I suppose a file needed to be cleaned or re-indexed or something. Now when I click on the refresh it appears to have no performance hit.

But, when I click on Bulk–I still see about 20-40 seconds of delay…for zero new emails?

Thanks in advance for any help on eliminating these delays. J

Did you install and enable the plug-in for Apple Mail? You could also disable the option to import complete conversations (see Preferences > Email), this is usually not necessary when archiving complete mailboxes.

Yes I’m using the plugin–I reinstalled it per the above recommnedation. But, now the delay is back. Only about 3 days of emails and the import function greatly increases delay.

Problem is back. Would someone help troubleshoot this large delay for my “bulk” folder in OS X mail during import?

Did you disable conversations per @cgrunenberg’s suggestion?

I did just now…and the delay is a bit different (worse):

with conversations: (same pic as above) for 47 seconds
without conversations: (same pic as above) for 52 seconds

Hmmm…even if it were 30 seconds…I’m thinking there is another loop that is taking way too long. Thanks for the ideas.


Note: I’m not clicking “Archive Mailbox” rather “Import”

A screenshot of Preferences > Email would be great. In addition, was anything logged to Windows > Log?

Sure. Attached.

The option to import complete conversations is still enabled, disabling it should definitely improve the performance. Please note that times are only comparable after restarting the app due to internal caching. In addition, how many messages does the complete mailbox contain?

Ok. I restarted DT3 with disabled conversations. Initial load for import took a while…but now it does appear quicker. I’ll try again tomorrow to see if it still maintains performance after 1 day worth of email.

Right now Bulk has ~2030 items. I try to keep this box small.

Thanks, J

That’s actually not a huge mailbox. Is this a local mailbox or a remote one (e.g. IMAP)?

It is local onmacbulk

So it has been a couple days since I restarted with disabled conversations (and I upgraded to DT 3.5.2).

And, the bulk mailbox took less than 30 seconds to populate. This is much better. I’ll keep you updated if things change…right now, I have a workable solution. Thanks again.


Glad to hear it and thanks for the follow-up!


Ok, so the dreaded delay is back.

30 seconds on my bulk folder. Conversations aren’t enabled.

But it does have >3k messages in the folder…

Please help.

Anything logged to Windows > Log?

Which is really nothing significant. I’m really puzzled on this one. I’ll delete messages in the bulk folder of Mail and see if that helps…but I really don’t know why 3k messages causes such a slow down–especially if I’ve imported most of them already. My import script runs about 1x per day–so usually the difference is only a day’s worth of email.
Thanks for your help.