Mail plugin shortcut

I am not able to get the mail shortcut “Add to DEVONthink 3” under “Message” to work. The function works as expected, which is very grand, but the shortcut does not activate the function. I tried changing it in system preferences, but that did not do anything either.

1 Like

The shortcut should be Ctrl-Alt-Cmd-M. Does selecting the menu item work? Do you use any other Mail plugins?

Selecting the menu item work fine, it is just the keyboard shortcut that I can’t get to work. I do not use any other mail-plugins.

Maybe the shortcut is already used (by another menu item?) although that’s not the case over here. Because pressing the shortcut should be identical to selecting the menu item, both cases are identical for the plugin as macOS handles the menus.

I have looked through both mail’s menu and in system preferences if anything else is using that shortcut, but I am unable to find anything. In DEVONthink 2 I used that shortcut to create a new markdown text. But even if that somehow influenced things I have deleted it now.

Try reinstalling the plugin, just to make sure.

  1. Quit Mail.
  2. Quit Pro Office.
  3. Enable Full disk access in System Preferences > Security & Privacy for DEVONthink Pro Office
  4. In the Finder, hold the Option key and choose Go > Library .
  5. Go into the Mail/Bundles folder and delete the DEVONthink mail conduit bundle.
  6. Relaunch Pro Office and install the Mail plugin from the DEVONthink Pro Office menu item > Install Add-Ons .
  7. Relaunch Mail and enable the plugin via Apple Mail’s Preferences > General > Manage Plug-ins .
1 Like

Thank you for this. I followed all the steps. If I only press Ctrl-Alt-Cmd-M nothing happens. If I also hold the shift key, however, the shortcut works. Then the message import window appears.

Thanks. Just wanted to eliminate the variable. Are you running other utils, like Keyboard Maestro, Karabiner, etc.?

I am running Karabiner. I turned it off, however, and that did not make a difference. I have also tried on two different keyboards, one being that of my MacBook Pro, but that does not make a difference either.

Interesting. Does it persist after a machine reboot?

I just did a machine reboot. It persist. shft-ctrl-alt-cmd-m brings up the message import window, whilst ctrl-alt-cmd-m does nothing.

Same problem here. Command-Control-Option-M does nothing. I don’t see a menu selection either for importing e-mail. I’ve had to go to the import side-panel.

Did you install the plugin for Apple Mail via DEVONthink 3 > Install Add-Ons… and (!) activate it in the preferences of Apple Mail? Then there should be menu items in the Mailbox and Email menus.

don’t see a menu selection either for importing e-mail.

There isn’t one any longer. File > Import > Email has been deprecated. Email importing within DEVONthink 3 is done in the Import sidebar.

Thanks. I see that the Command-Option-M is in the Apple Mail menu (rather than the DT menu). I’m stil playing with it.

I see that the Command-Option-M is in the Apple Mail menu (rather than the DT menu)

Yes, but hopefully it’s Command-Option-Control-M in Apple Mail > Message.

Is there a way to change it to four keys: Command-Option-Control-M?

There are two hotkeys with the Mail plugin

Control-Option-Command-M is for the Message menu.
Shift-Control-Option-Command-M is for the Mailbox menu.

I have tried the steps above but it fails at step six with the error:

20:30:57: Failed

Th logged issue is not related to the Mail plugin.