Mojave syncing problem

I have synced iCloud DBs on 2 ios devices and 2 macs, both running mojave. 1 mac and 2 ios devices are in proper sync on one of the DBs. What is the recommended way to get the uncooperative DB to work? I’ve tried rebuilding the DB, no luck. Would the easiest thing to do be to copy the DB from the working mac to a thumb drive, delete it on the other machine and copy the correct one?


Were any issues logged to Windows > Log? And are you able to successfully verify the sync store, see contextual menu in Preferences > Sync?

When I verify in Preferences > Sync in the Log I get:

8:28:41: iCloud 2 items of database “****” missing or not yet available.

where **** is the database name.

The database has not been modified since yesterday morning.

Is there enough space available in both iCloud and on your startup volume?

Yes, plenty of space on both.

It’s possible that iCloud didn’t transfer all files yet. How many items (see File > Database Properties) does the database contain?

Have you done a File > Verify & Repair on the database?

Data base size: see attached figure.

Verify & Repair; yes, and then I tried Rebuild


I would try cleaning the sync location and resyncing to see if the issue persists.

In DEVONthink’s Preferences > Sync , right-click the iCloud sync location and choose Clean Location . This will clear out any sync data. After the clean is reported successfully in Window > Log, check the checkbox to sync again.

I don’t think either of these options is wise; as I read the Clean DB it will delete my entire DB (in the Cloud on local, in the cloud would be a disaster?) Clean Location says it will delete all my DBs in iCloud based on what the box that pops up says, bigger disaster. This is why I suggested on the ‘bad’ mac just deleting the database and reinstalling the good one from a thumb drive?

Is there a gentler option that does not require deleting everything in icloud as this 2 options suggests happens? Or are the commands different than suggested in the boxes?

Screen%20Shot%20on%202019-11-27%20at%2017-57-48 Screen%20Shot%20on%202019-11-27%20at%2017-59-42

DEVONthink is not a cloud-based application, therefore cleaning a sync store does neither delete your local databases nor does it affect databases on other devices.

OK, I did that (Clean Locations). Quick on the Mac, and automatically updated on the other Mac. iphone took about 90 min, syncing each db MANY times, about 30 min for the same on ipad.

Now I have 4 instances of the same database. The scorecard reads:

  1. Mac 1: 1476 files, 4 replicants, 836.7 mb
  2. Mac 2: 1476 files, 4 replicants, 836.8 mb (and number of words and other things different, but hey close enough)
  3. iphone: 1479 items, 812.6 mb
  4. ipad: 1475 items, 813.2 mb

Question: does this mean my sync is now working properly or not? To my untrained eye, counting replicants1475 + 4 = 1479 on the ipad which agrees with the iphone, but 1476 + 4 = 1480 on the macs. All 4 instances of the DB successfully verify.

A screenshot of the File > Database Properties from both Macs would be useful, thanks. Do you spot different item counts of any group on the devices?

I’ve also had some strange inconsistencies using DT3 and iCloud – iCloud seems to have been quite slow to update on my system. Evidence of this is that files in the Documents folder (which is shared between an iMac, a MacBook Pro, and two iOS devices) have either been slow to update or have had to be clicked on in Finder to cause them to download/upload. I’m not sure how this general slowness of iCloud might have interacted with DT3 – which lost various files in some databases (or at least, lost track of them) – I do not know. I began to wonder if DT3 was losing track of which was the latest version of any particular file in a database – or what was the latest state of the database. Anyway, I’m afraid I have lost confidence, and have taken DTTG off my devices and moved all my material into Finder/Files and deleted my databases (again). If I can’t keep track of where things are, I can’t use the app for the moment. I hope things will settle down in the future.

Yes, the counts for many things are very different, when I looked I would say almost everything (I remember for instance “Words” is much different). Unfortunately I can’t access one of the macs until Monday; I’ll send you screenshots then, I can only access 1 mac and the ios device now.

the Documents folder (which is shared between an iMac, a MacBook Pro, and two iOS devices)

Do you mean you’re using macOS disk management for the Desktop and Documents?

I mean that when I go to iCloud Drive Options in System Preferences (Mac), it shows that the Desktop and Documents folders (also) store their contents in iCloud Drive. This means the items kept there are accessible on iOS using Files app – and a few third party apps.

Just to be clear, I do not, and have never attempted to, put DT databases in the Documents folder. Until DT3, I put them in their own folder inside my User folder, but then moved them to the Databases folder that DT3 automatically set up. Basically a sideways move.

The point I was trying to make above was that aside from anything that might be going on with DT3, it seems to me that iCloud is being damned slow at the moment. Even Mac to iCloud to Mac sync of the Documents folder is not happening very reliably or quickly for me. And I’m finding it a bit easier to deal with things if I take DT3 out of the equation for the moment. Maybe iCloud slowness has nothing to do with the out-of-sync databases that I was getting, but I don’t have time to troubleshoot it at the moment. I just mention it in case it should help with troubleshooting – either for Devontech or another user. Cheers!

Yes, iCloud has been a mess since the Catalina betas. Apple went back and forth with substantial changes for Catalina and iOS 13, then backed out suddenly around the 5th or 6th beta, I believe. However, there are many reports of iCloud problems on both platforms, including one I read the other day about a person’s Reminders not syncing to their iOS device for three days! :flushed::roll_eyes:

Well, in a sense I’m glad it is not just me that is seeing this. I was beginning to think there was a ghost in my machine.

And I imagine it will complicate the lives of support workers no end…

Nope - definitely not just you.

Oh it certainly has cause complications… especially since it’s not a problem for everyone, all the time.

I’d rather have a hard crash going on for everyone than a sporadic issue we can’t reproduce at will. :confused: