not indexing apple mail

not indexing my mail

Here it does - OS 10.8 and it also did with OS 10.7 before.

Did you check “Messages & Chats” in Preferences > Categories? Did you update the index (Preferences > General > Update index > Update now)? Is DEVONsphere up to date (Preferences > Update)? What System?

Maybe it helps to uncheck “Messages & Chats”, update the index, checkbox “Messages & Chats” again and update the index again.

Restart DEVONsphere. Did you reboot your Mac already if nothing else has helped? Give us some infos, please.

Ah, and should you run OS 10.8: Apple Mail 6 has some bugs and in many cases problems too. Many of them were solved by rebuilding the mailboxes. (Select a mailbox > menu bar > Mailbox > rebuild.) Should you do so, please update DEVONsphere’s index afterwards again.


But there is no problem with DEVONsphere indexing mails on OS 10.8.

aarg! … you’re right

New DEVONsphere user here with the same problem on both my 10.8.3 computers. I have followed the suggestions in this thread with no success.

In the Categories window there is no number next to Messages and Chats even though the box is ticked. See Screenshot.

Any other ideas>?
Screen Shot 2013-04-13 at 13.05.28.png

After completely uninstalling and reinstalling DEVONsphere, one of my two computers is now indexing and searching Apple Mail, but the same treatment did not work on the other.

I realise as I watched the successful one index 60000 emails that it had in fact done this after the initial install, and that email search had been working. So something caused it to stop. Will be interesting to see how long it stays.

Still stuck on the other computer.

Well the answer is about an hour.

Here is a composite screen shot showing the items in each Category at 15.14.59, with 51383 in messages and chats. Then when I checked again at 16.28.26 there are no messages and chats, and searching no longer finding mail.


Check if there are any Console messages on this.
Do note that indexing 60,000 emails is not a common scenario and no trivial task (in addition to the other items it’s having to index).

Thanks, I know 60,000 is a lot but Spotlight has never had a problem, and DEVONsphere claims to be Spotlight on steroids somewhere.

There are a lot of Console messages, especially this one:

The screenshot cuts off the last part of the message which is “this may be a leak”

Does this suggest any fixes?

DEVONsphere is comparable to but does not use Spotlight processes or its index. Two totally different technologies.

Open /Applications/Utilities/, type “DEVON” in the filter field in the upper right-hand corner, and copy and paste ALL of the window’s contents into a new text document. Start a Support Ticket at our DEVONtechnologies Support Ticket System and attach the document to your reply. Thanks.

Thanks Bluefrog.

I have sent a support request yesterday but haven’t had the usual email back yet, and didn’t send the Console output, so will do that when the ticket is open.

I realise that Spotlight and DEVONsphere are completely separate. I was just commenting on your comment that I was asking a lot of DEVONsphere!

Some progress !

On the computer that wouldn’t index Apple Mail at all, I realised I had not enabled assistive devices. When I did this and reinstalled DEVONsphere, it indexed Apple Mail and so far has not “dropped” the messages and chat index after six hours.

The other computer, which initially indexed Mail and then lost the message index after an hour, the OS was installed on a Fusion Drive. Thinking it was possible that this was a factor, I did a fresh install and migrate onto a plain drive, and reinstalled DEVONsphere, where it has worked fully and not lost any index in six hours.

So on the face of it the Fusion Drive was a factor, except that the first computer (the one which initially did not have assistive devices enabled but is now working) is also a Fusion Drive!


I am a long time user of DEVONthink Pro Office. I am looking now to improve my Apple Mail searches. So I downloaded the demo of DEVONsphere. But I am not able to do any searches in my mails.

I have given autorisation access to DEVONsphere. I have checked ‘Messages & Chats’ in preferences. DEVONsphere fund about 40’000 messages, which is correct. When doing indexing, I can see that the software is spending a lot of time indexing mails.

But when doing any search with either mail title, content, attachment, … with or without wildcard, no result at all! It only finds documents in Mac folders. I have also checked display preferences, but I do no see any messages category.

What is going wrong?

Mavericks is what went wrong. We are looking for a workaround.

Thank you for the fast answer. It is appreciated.

Unfortunately I will have to wait before buying this software. :frowning:

I’m having this trouble on my mac book air, but not my imac ARRGHH!

The symptoms are easy: Spotlight DOES find emails…

The mail app and DevonSphere do not. :frowning:

Console says mds cannot open a fileport but I’m not sure that’s related (?)

This is long but maybe useful – solving the Mail issue might solve the DS issue:

Thanks, korm! I’ve done it all…

Used c0cktail for permissions, empty caches.
Then rebuilt index.
Then re indexed spotlight
Then rebuilt all mailboxes
Then rebuilt spotlight again…

In short, I’m at wit’s end … The only thing that stands out to me is that BOTH the mail app and DevonSphere cannot find mail, but spotlight can…

That tells me there is an error in the apple components that deliver mail results… I’m not sure if it’s the mds error reported above

Are you on Mavericks? I’ve found the surest way to fix Spotlight foul-ups is to boot into the Recovery HD, run Repair Disk and Repair Permissions.

Or at least add these to the list of “things I tried for no good outcome” :unamused: