OmniOutliner issues

I have recently dropped some OmniOutliner files into my trusty DTdatabase.I was dismayed to see that the DT search is not including items wihin the Outliner files.Am I missing something?

OmniOutliner 3 files are currently not readable by DT Pro/Office. We can’t at this moment promise if or when they might be taken out of the “unknown” file type category.

There is a workaround. You can, in OmniOutliner 3, press Command-P to print your document. When the Print panel appears, click on the PDF button and then select “Save to DEVONthink Pro.scpt”. Then choose the location to which the PDF file is to be located in your database. The text will now be available for searching and analysis.

Resurrecting an old thread for a new version of DT…

From a functional perspective, creating OmniOutliner documents in DT works nicely using this file creation trick (short version: click a spring-loaded folder in the Dock, which contains file templates; then just drag the outline into DEVONthink).

Unfortunately OmniOutliner document content is still not searchable with DEVONthink, even though the Quick Look plugin allows DT to view the content.

Am I missing something? Shouldn’t there be a way for Quick Look-enabled document types to be indexed, not just stored, by DEVONthink?

I can drag an OO3 document into DTPO and it appears to be indexed. This whether the document is compressed or not.

Perhaps the template trick is doing something you’re not aware of?

Best, Charles

Hmm… When I search a database, I can get results from OO files. If I try to search within an OO file, that option is greyed out. I don’t know why there is a difference. I’ve never noticed it before.

DEVONthink is able to read the text of the OO3 document, so a search will find OO3 documents that meet the query criteria.

But the display of that document in your database uses Quick Look, and Command-F searches are disregarded.

However, if you click on the little ‘Text’ icon in the navigation bar above the text panel, the view switches to rich text and you can now do a Command-F search for a term.


Thanks for your response. Unfortunately, none of what you describe is working.

Searching for words in the content of my OO documents reveals no hits. In addition, when I select the OO file with the words sidebar (concordance) open, the sidebar is blank—indicating that the file’s content is opaque to DT. (I’m not sure what icon you’re talking about re: viewing as text, so I can’t try that.)

What am I missing?


Do you have a current version of OmniOutliner installed on your computer? It should provide both Spotlight and Quick Look plugins.

I had been running OmniOutliner a dot-version behind, but after upgrading (and restarting, for good measure), DEVONthink still doesn’t recognize the contents of OmniOutliner documents.

To confirm: I’m now running DEVONthink Pro Office (2.0pb6) and OmniOutliner Pro (3.9.1)—both the latest released versions.


Open one of those OO3 documents under the current version of OO3. If OO3 has a preference allowing Preview when saved, enable it. Now make a minor edit, such as adding a space. Save (Command-S) the revised document. Is its content searchable, now? It should be.

I don’t use OO3, but I know that the release that added a Quick Look plugin produces documents that are displayed in Quick Look and are searchable for content in DT Pro pb7 – I’ve seen this work on a user’s computer.

Minor point: OO3 is at 3.9.2 beta 1 right now. To confirm, DTPO pb6 and earlier versions of OO3 supporting QuickLook work just fine here. OO3 documents can be compressed on uncompressed.


I upgraded to OO beta; still no luck. Also, I’ve confirmed that the document is searchable with Spotlight, so it seems to be indexing properly—at least by the system. Re-importing into DEVONthink doesn’t help either.

Can we approach the issue from a different direction?

Can the DEVON team speak to what standards a document needs to meet in order to be indexed and searchable in the database? (It would be nice to have a way to test a document against those standards, so I could determine whether the problem is with my OmniOutliner or DEVONthink setup. But short of that, a clear specification of requirements would be a good place to start.)

Here’s an OO3 document that works on my system:

Best, C

Did you synchronize that document in DT if it was imported already? If you have a Spotlight plugin for a specific type of document, DT should be able to index it.

So, let’s do the following on your machine: download a tool such as Onyx or Cocktail. Use it to clean your Launch Services database and other caches (including Spotlight). Restart your computer and try again either by importing or synchronizing it.

I finally found some time to run through some troubleshooting measures, so far to no avail. I reset the Launch Services database, the Spotlight database, and about a dozen other caches/DBs with Onyx, before restarting and rebuilding Spotlight. I also disabled my third-party QuickLook plugins in case there was conflict there, and repaired permissions.

No dice: DEVONthink can still view the full OmniOutliner document using Quicklook (I’m now running OO Pro 3.9.2 final), but no additional DT services are available (like Classify, Words, Keywords), and searching within the document is unsuccessful.

Has anyone successfully resolved this problem? There’s at least one other person with this issue.

Just a thought, but what is your preferences settings for ‘Import: Files’? Or more specifically, is there a file type that you have unchecked? I would expect that Markup Languages may need to be checked as OmniOutliner documents are XML docs. Beyond that, there’s not much I can offer as DTPO and OOP work well together for me.

Also, and this is related to the earlier post on file templates, in DTP pb7 you can create OOP documents directly in DTP by creating smart templates. The OOP template(s) will then appear directly in the ‘Data>New>Templates’ section of the menu.

Update: the problem seems to be resolved now, after doing all of the above and also trashing the DEVONthink preferences. Unfortunately I don’t know exactly which step resolved the problem.

In any case, some existing OmniOutliner documents were automatically recognized, and all new documents work. Those preexisting documents that still don’t work can be “fixed” by editing and re-saving them.

Here’s a quick script to make that task a little faster with OO:

tell application "OmniOutliner Professional"
	repeat while exists front document
		tell front document
				make new row at end of rows
				delete last row
			on error errormessage number errornumber
				display dialog errormessage buttons {"OK"} default button 1
			end try
		end tell
	end repeat
end tell

Note that this script modifies, saves, and closes all documents open in OmniOutliner. It shouldn’t do anything nefarious, but use at your own risk.

Usage scenario:

  1. Make a DT search folder to identify all items where Kind is Other. (This will include all the not-officially-supported documents in DT)
  2. Sort by kind to quickly identify OO docs
  3. Open those that aren’t indexed in OO (cmd-shift-O), then
  4. Run this script to update all open documents

I just noticed that I am no longer able to view OO files in DTPro.

Was able to very recently but something must have happened when I upgraded to the latest pb7.

Also bouncing back and forth between Leopard and Snow Leopard and can’t remember where my OO files were viewable. But that shouldn’t make a difference right?

Anyone sorted this out?

As mentioned above, the steps I took to resolve the issue included resetting my Spotlight database and DT preferences. I’m not sure which step it was that actually resolved the problem, but I suspect it was resetting the Spotlight database (reason: OO files weren’t immediately available after I reset all these settings, so I’m guessing it had to wait for Spotlight to reindex everything).

Thanks dbyler.

Have never worked with scripts…would like to but never have free time.

Is there anyone from DT that can address this issue as it seems very likely associated with the upgrade to pb7.