PB5- 'Already in use' errors and lock-ups

I’ve got some erratic behaviours with PB5. I keep getting messages like ‘inbox.dtBase2 already in use’. It does this with my other database also. It will also sit and hang when trying to open a database while ‘initializing and verifying’.

Even if the the databases are finally opened, the GUI is usually unresponsive. You can click around on the interface and nothing works. I have to manually force quit the application.

Restarting doesn’t help and neither does getting rid of the folders in the Sorter or quitting the Sorter.

I didn’t have this trouble with PB4 which I thought about reverting back to. However, I decided to just uninstall DTP for now and what until the final release before using it again. I don’t trust it and I also really need to get on with my writing project so I’ve moved everything back over to Scrivener.

Yes! Help. I’m going insane here. I have a 25GB dtbase2 file now that first says “inbox already in use” and then I ignore. It then says “database” in use and I ignore. It then verifies only 1/2 and freezes forever. I have to use force quit to get out of this nasty loop.

This is intolerable. This database is critical.

I uninstalled and completely reinstalled PB5. Nothing. No help.

Please help.

Force Quit used when the database is writing data can cause problems, including database locking with the “In Use” message, or even database damage.

A 25 GB database is very large, much larger than any of my databases, and if RAM becomes tight, opening the database or carrying out memory-intensive procedures can take a long time.

I manage more than 150,000 documents in DTPO databases, but they are split among a number of topical databases. Most of my searches take just a few milliseconds, and I never see pageouts in normal operation. So I don’t see spinning balls, either.

Intolerable for someone who self-volunteered to use the beta version with a critical database?

So maybe I should try rebuilding my databases manually by say transferring the old files out of the previous DTP save files into new ones? Maybe I’m at fault here for using force quit to begin with…

I’ve got that Already in Use error message a number of times too.
It’s no fun!


I also immediately had problems with the upgrade. I get database in use errors when trying to open Devonthink pro. I didn’t not do any force quitting etc. After some years of use I haven’t seen a problem like this. Are there any recommended solutions. Is it possible to downgrade?

Downgrading to b4 and repairing permissions has not helped. I no longer load the sorter through “log in items” . I still get “already in use” errors and can no longer access my db. It is about 2GB. Is there any hope?

What I finally did was uninstall DTP. Then, I moved all my databases from my desktop to my documents folder. I reinstalled DTP Pb5 and was able to open the databases having to click ‘ignore’ when I got the ‘already in use’ message. Then I ran the database rebuild script and everything seems to be working again, for the moment. DTP stills loads up everything a bit slow and there’s some lag time when I click on stuff inside the database at first.

I did finally get mine back too. I re-installed beta4 and ran fix permissions and all utility scripts with Xupport. At some point my main database apeared in “recent databases” and I was able to open it from there. I then rebuilt it just because it felt right. And backed up everything.

Wondering; is there a script for rebuilding a database you can’t open dur “already in use” messages?

Still mysterious and a little worried about beta 5 and the sorter now. Perfectly willing to admit making errors but still would like to understand what is happening with the new and future versions.

So… in brief, what am I supposed to do. The database won’t open, and the application won’t quit.
Is there a safe way of getting my database open… I need to use it 20 minutes ago.


In all fairness, DTP is ONLY available for download as a beta on DTs site. You have to contact them to get a pre-2 version. Today is 6/2/09 and I used my copy on 5/30/09 and no updates were available. Now I have to download a new copy and I can’t install it because “sorter” is in use. It would seem logical to have a autoupdater get the next beta before it expires. I’m looking for the thread where it’s posted on how to reinstall the the beta over an existing one.

They are selling a BETA product via retail, so don’t knock someone who actually uses the only product available with critical data. I needed to get into my db this morning and will wait until I get a chance this evening to use it. Should we all be using v1.5.x for now until 2.x comes out of beta? I just don’t buy that logic.

This is for the devs and others who may be experiencing the same problems. I am running DTPO on an early 2008 MB 2.4GHz with 4GB RAM and an X3100 Intel integrated graphic chip running OS X 10.5.7.

First, I want to state that when I ran DTPO 2.0pb4, I had no lockups or freezes. Since installing the pb5, DTPO will constantly freeze on me. I am able to reproduce some occurrences of the freezing. E.g., if I open DTPO and start an RTF document and then Time Machine starts a backup, my entire system will freeze up. Likewise, if I use DTPO and then open OS X Mail, my system will freeze up. I have also had it happen when I open any other program after opening DTPO. Again, this freezing has only happened since installing the pb5.

Second, I have noticed that the Sorter is slower for some reason and sometimes it does not want to respond to the tab being clicked. I saw the other thread about it, but I wanted to post both issues here because it is the same program and they may be related.

I have run permissions which did not require repair and done extensive hardware testing using TTP 5 and other software. None of my hardware has been found to be faulty. I will probably attempt to do an archive and install just to rule out any possible problem on my system, but otherwise I will be forced to uninstall DTPO until another release. I am trying to write and really wanted to use DTPO to help with taking notes, cataloging files, etc., but I have lost too much work from freezes already.

Lastly, is it possible to add an Auto-Save function to DTPO for RTF documents, perhaps akin to Scrivener’s auto-save after 2 seconds of non-use. This would be immensely helpful. I love the program, but right now it is not working for me. Please let me know if there is something I could try to do to troubleshoot further or information I could provide for you.



Actually, public beta 5 had been posted on the Download page on 5/21/09, and would have been detected and the user provided the option to have it automatically downloaded and installed, if the Check Updates feature had been invoked, either manually or automatically via Preferences > Updates.

If the installed beta has expired, however, it will be necessary to quit the Sorter before the new beta can be manually installed in the Applications folder. This can be done in several ways. For example, click on the Sorter to open it, then click on the action button (cogwheel symbol) and choose Hide (or Quit, in newer Sorter versions). The Sorter can also be quit in Activity Monitor (an Apple application in Applications > Utilities) by selecting DEVONthink Sorter and quitting it.

Perhaps those problems are related.

In another thread Annard noted that on at least some computers, problems can emerge when folders or package files are dragged into the Sorter’s (Global) Inbox, and he recommended not doing that pending a fix in the next update.

So far as my experience indicates, no problems arise if folders and/or package files are dragged into database Inboxes or groups that have been installed into empty slots in the Sorter.

In public beta 5 a new “Places” item, Inbox, is added to the left column of Finder windows. This is enabled by the ‘Global Inbox in Save Dialogs’ option in Help > Install Add-ons, if you do not already see that item in the Finder.

I have often dragged Finder folders and/or package files onto the ‘Inbox’ item under ‘Places’ in the Finder window, and have encountered no problems. The Folders/package files are properly imported into the Global Inbox.


  1. Do not drag folders or package files onto the Sorter’s (Global) Inbox, especially if you have experienced any problems from doing so, while using public beta 5.

  2. DO use one of the alternatives noted above. Drag items either onto the ‘Inbox’ item under Places on a Finder window, or drag them into a database Inbox or group that has been added to an empty Sorter slot.

Is there another setting I’m missing? This is what I have mine set to.

It actually did download an update last time I connected (within the past week), but launching it today 6/2/09 it said it was expired. Was there an update to b4 that it downloaded, and not b5? (I didn’t pay attention). I launched whatever version I had running and said it was expired. During the quit process of Sorter, it launched b5, so it must have installed somehow even though it told me it couldn’t until sorter was quit.

On a more serious note, should us as customers NOT be using v2 until it comes out of beta? To me, any data in it is critical data, or I wouldn’t be using the program. Is that the “official” stance of DevonThink? How do I go effectively go back to v1 with my current (critical) data?


That puzzles me, unless either you didn’t confirm the update to be installed (the user has choices), or you had more than one copy of your application installed in Applications. There was no mid-course update of pb4 as a ‘new’ pb4 version…

That’s of course up to the user. Personally, my DTPO2 databases have been absolutely stable (I’ve never had to resort to a backup) and I use DTPO2 exclusively for my working databases. I find so many advantages in DTPO2 compared to the 1.5.4 version that I would hate to revert to 1.5.4.

But if you wish at any time to revert to 1.5.4, in DTP/O2 select all the content of your database (e.g., in the Split view), Select All and choose File > Export > Files & Folders, then create a new folder into which to save the exported content. In DT Pro/Office 1.5.4 create a new database and choose File > Import . Files & Folders, then choose ALL the content of the folder that holds the exported material. I would suggest examining the Logs produced in the export and import procedures to see whether any files failed the procedures, and if so save the logs for reference and possible use in discovering and adding back those files.

I was just troubled by the tone of this post is all.

by sjk on Mon May 25, 2009 6:33 am

Thanks for the reassurance. I have b5 installed now and an iCal event to manually check for a new version a week before the 7/31/09 expire date.

Why, because I pointed out that someone (not you) apparently wasn’t accepting responsibility for which software they’re using with critical data?

That DEVONtechnologies is selling expiring beta software is a separate issue.

Not knowing what the “rankings” mean in this forum, I assume “God” meant an employee of DT, and you were giving official DT sanctioned word that v2 should not be used for critical data. Bill gave a satisfactory answer, and I’m comfortable using v2 with critical data.

I’m a Senior Member, but only because I posted X number of questions, that doesn’t mean I’m Senior anything. :smiley: A Senior question asker maybe.