PDF: Attempting highlight on the same line causes problems

There seems to be an issue with PDF highlighting where, if a user attempts to highlight a passage on a line that already contains highlighting, the previous highlight annotation will be deleted.
To reproduce:

  1. Open a PDF
  2. highlight a portion of a line.
  3. Highlight another portion of the same line, not contiguous with a previous highlight

Result: Previous highlight annotation is deleted.
Expected: New highlight should not delete previous highlights.

This is an issue in instances where, while highlighting, there are to distinct ideas that might need to be captured but there are words to be omitted. This could either be as a means to separate two distinct ideas that happen to share a line in the text, or if there are superfluous words within a thought that a user doesn’t want included in the highlight.

Has anyone else observed this issue? Is there a workaround? Is this an issue that DEVON staff are aware of?


I can’t recall if highlighting PDFs in DEVONthink ever worked as you suggest it should. But, OTOH, it does work your way in Preview.

I have seen this problem with certain PDFs & not others. PDFs from Apple’s Pages seem to produce the problem as an example.


I don’t think DEVONthink ever supported this behavior. I am also not sure if the PDFKit API allows for this or it’s something Apple baked into Preview on their own.

PS: I have used some PDF editors that have allowed behavior kind of like you’re suggesting and ended up with overlapping highlight that are difficult to clean up. Preview’s seems to work well because it deletes the current highlight before applying a new one.

PPS: You can still apply an underline to highlighted text as another visual separator.

One of my personal eccentricities is that I don’t deface my references.

Hence, this is an issue I wouldn’t encounter. :mrgreen:

I’m not one of the developers, nor would I want to hinder those who do mark up documents. I did some tests of a couple of PDFs that accepted multiple non-contiguous highlights in the same line of text, without loss of previous highlights in that line. As Frederiko observes, some PDFs may be different.

I don’t know about PDFKit, but the overlapping highlights feature is also supported in PDFPenPro, Acrobat DC, and Skim – in addition to Preview

Just to clarify:

  1. This occurs with every single PDF I have, the majority of which are academic journal articles from online journal databases. The problem I note in my OP is reproducible 100% of the time on 100% of PDFs (with text)
  2. This issue does not occur in Preview. In preview I can highlight segments of text on the same line as a previous highlight without the previous highlight disappearing.
  3. this is unrelated to overlapping highlighting.
  4. This is not a feature request.

It looks like there is some confusion because my steps to reproduce were slightly vague. The original highlight must span more than one line. Let me outline again the steps to reproduce.

  1. Open a PDF in DTPO.
  2. Find a paragraph of text.
  3. Select the first line and half of the second and highlight it (cmd-shift-L)
  4. Deselect that text and observe that it is now highlighted.
  5. Without switching highlight colours, select text anywhere after the highlighting from step 3 and highlight it (cmd-shift-L).
  6. Observe that while the line you just highlighted may or may not be highlighted and the first highlighted section from step 3 is no longer highlighted.

See the series of screenshots that follows:
Single highlight spanning more than one line (Step 3)

Second passage selected, beginning on the same line the previous passage ends:

Result of highlighting second passage:

You can see that in the third screenshot, the originally highlighted section is now no longer highlighted and the newly selected passage also never got highlighted.

I can reproduce this on every single PDF in my collection using DTPO. I CANNOT reproduce this on ANY PDF in Preview.

Following the steps outlined above, I can’t reproduce it on any PDF I have. Please start a Support Ticket and provide sample PDFs we can test against.

And as noted, PDFs are not all equal.

strange you were unable to reproduce it. I just tried again on 4 more PDFs and had no issues reproducing.

Anyway, support ticket submitting with sample documents and a screen recording. Thanks for all the help from everyone!

I tried this myself on a PDF that I just created from a Formatted Note. I see the exact behavior that @scottougheed describes.

Hmmm. How did you create the PDF? I printed a formatted note to PDF and do not see the behavior in that case.

Selected Print from DEVONthink, then chose Save PDF to DEVONthink Pro as the option. Just tried annotating a PDF created with Adobe PDF Library 6.0 and I see the same thing.

I also notice that the highlight shortcut Command-Shift-L is no longer working for me-perhaps related?

I am not seeing it either, Greg.

Thanks for the bug report, the next maintenance release will fix this.

Apologies for wading in late – and good to see a possible fix coming up!

But FWIW, same thing happens this side, with certain PDFs.

Latest release of DEVONthink (2.8.6) fixes this issue as promised!

Thanks DEVONtech folks!

No,issue has not been fixed yet!

issue still not fixed

Please send us a PDF plus a note describing how to reproduce this and which version of macOS/DEVONthink you’re using (as it’s usually an issue of the PDFkit - sometimes it’s possible to work around it, sometimes not). Thanks!

La Chapelle-d’Abondance _ suite à l’accident de parapente, la femme du touriste décédé souhaite davantage de contrôles du matériel - Le Messager.pdf (220.7 KB) Mac OS 10.13.6