Printing from DEVONthink changes font size

I’ve used DevonThink for many years. I’ve never been able to effectively print retaining the same font size/display as the appearance in the program. I copy the text elsewhere and print it from there. Seems impossible that others would submit to this process so hopefully you can analyze my issue.

I type up some text and attempt to print. the text is, as in this example Optima 20. It should take up two full pages. As indicated the Finder’s estimate of the output volume is barely half a page. And once printed that’s what it looks like.

Is there any way to correct this issue? Thanks.

– Gerry

You don’t say what kind of document this is, AFAICT. I’ll assume Txt. Look in Menu: Preferences → Tab: Editing → Item: Plain Text Font.

Mine is set for “Menlo Regular 11”. When I change it to, say 36 point, both the text in the editor and on printing, changes to that bigger font.

Rich text (rtf). It’s usually Optima between 12 and 18, and they never match.

Over the many past many years, I usually increase the font in the document repeatedly to a jumbo-sized font, and eventually finaggle it to print as appropriately, but the fonts never match between display and printing.

Is there a reason why the program doesn’t print as displayed as a matter of course? I keep thinking there’s some preference item that’s making it do this.


1 Like

Enabling the option to rewrap the contents should produce the desired results.

It’s a fairly useful hack! But first. it rewraps my text however it likes and that’s not optimum. I note that if I make my font 12pt and zoom my screen so it looks appropriate, without the rewrap the Finder print dialog displays it at approximately 8pt. Why 8 instead of some other random number?

Why do I have to “trick” it into “kind of” printing with the display formatting, whatever it may be, big or small? Isn’t there something buried in the preferences that would address this?

If not, what is the rationale for scrambling this normally innocuous process? I don’t get it.

– Gerry

How wide is the RTF page? I think it might be wider than the US letter format you use for printing.

I think the answer may be in the thread Jim referenced. When I open a new RTF document, the width of that document as displayed in the standard preview window is > 40 cm. If I select to print that document, the formatting represents that which I see on my screen; as the physical page is only 21 cm wide, everything is shrunk by a factor of approx. 2. Selecting to re-wrap basically chooses instead to ignore the layout on the screen and to observe the font size instead.

It’s not obvious to me that you can influence the default page width & margins in any way.


I didn’t quite get that this was a relay to another thread so didn’t follow it. Having now been encourage to do that. I find it answers my questions. I include as did the OP, that it’s just tough, figure out your own hack and do it.

For me, the work around has been to clip the desired text and pasting it into a blank document in Pages. I suppose that’s as good as it gets. DT doesn’t claim to be a all-purpose word-processor, so I can hardly complain.

Thanks for the relay.

– Gerry

1 Like

I double-click, which opens the text in TextEdit where WYSIWYG ensues (because TE has a more reasonable default page width with regard to intended printing).

1 Like