Renaming indexed iCloud group on one computer causes it to disappear on other computer

I renamed an iCloud indexed group on Macbook 1 and that went well. When I looked at it on Macbook 2, it is gone. It exists in Finder on both computers, just not visible in DT on Macbook 2.
I also:

  • Emptied the trash per other posts
  • Closed and opened the database
  • Closed and restarted DT
    All to no avail.
    Other things I’m missing?

Which version of macOS and DEVONthink do you use and what’s the path of this folder?

Monterey 12.3.1
DT 3.8.3
iCloud Drive/DEVONthinkCodeDB/Webclips - Code

The original group name was “Code Webclips”, but I renamed it to “Webclips - Code” so it would sort near bottom.

Is the offending folder set to be available offline in bit devices ?

I’m afraid I don’t know what that means, so I don’t think so. Is there a way to check?

The original folder (group) was created in DT, not in Finder or Terminal if that helps.

In your icloud settings do you have “optimise disk space” turned on?

It might just be that the database on the second computer hasn’t yet synchronised with the database on the first computer (I assume you have DEVONthink set up to sync). If you sync using iCloud, it can be very slow. Bonjour is quicker, but has its own problems.

Yes, optimize disk space is checked

I’ve been successfully syncing via iCloud for months. My setup is I have two personal macs that sync via CloudKit. The third Mac with the problems mentioned above is a work computer that I sync one database via indexed shared iCloud drive per this thread: Sync to work computer while maintaining privacy - #6 by BLUEFROG

That’s the root cause of the problem. Some of the files that DEVONthink believes are on the local disk are in fact not there.

Before doing anything, I did an ls in Terminal of ls ~/Library/Mobile\ Documents/com~apple~CloudDocs/DEVONthinkCodeDB/Webclips\ -\ Code, and the files are on disk.

Then I unchecked “Optimize Disk Space”, and tried “Update Indexed Items”, closing the database, and closing DT, and the folder still doesn’t show up.

Should I try rebooting?

To be honest, I don’t know as I have never debugged getting out of this situation. I just know that “Optimize Disk Space” and DEVONthink are not friends as DEVONthink needs indexed files and folders on the local hard disk.

I guess what I would do is move all the files now in iCloud to a non-synched (by iCloud or any other sync engine) folder on the local drive and re-index into DEVONthink. See if everything works as expected. If yes, and you have ensured “optimize disk space” is turned off, copy all the files back into iCloud where you want them and then index all of them again, but now will be in a different folder structure. Check that everything works. Then you can decide which of the two copies to keep.

Or, simpler (but I’m not sure about it!) “Update Indexed Items” since you appear to be sure the files are on the local disk. I have no idea if the ~/Library location you show is where you should be pointing to or looking for your files.

Full disclosure. These are just ideas. Think through it. I never tested.

Trying to be helpful, but new territory for me. I do not index files on iCloud, but do so successfully with Dropbox and Google drive synced files.

Others may have a better suggestion or two.

@cgrunenberg @BLUEFROG

Go into your DEVONthinkCodeDB/Webclips - Code folder in iCloud Drive. Do you see this property icon on files…

Are there any indexed items in DEVONthink’s trash?

@joeg3 for you.

DEVONthink’s trash is completely empty, and there’s no cloud download icon in Finder.

I can open the pdf files in the indexed folder by double-clicking in Finder. It’s just that the folder is not visible in DT to even try and see the file. Other folders in the same database and indexed in the same way worked fine.

For whatever reason, renaming the group on one Macbook caused the group to disappear on the other Macbook even though it still has the files on the filesystem.

Was this indexed group located in another indexed group?

No, it’s at the root level. This is what the Macbook where I changed the group name to “Webclips - Code” looks like:

Screen Shot 2022-05-01 at 6.52.55 AM

The other Macbook looks the same except it doesn’t have a “Webclips - Code” group (but the folder and it’s files exist on disk as discussed previously).

It was or still is (and which one on the screenshot in this case)?

Sorry, I hope this clarifies:

DT on Macbook 1, on which I renamed the group to “Webclips - Code”:

Screen Shot 2022-05-01 at 6.52.55 AM

DT on Macbook 2, where I discovered the group was no longer visible after the rename (but per prior posts, the files exist on filesystem):

Screen Shot 2022-05-03 at 2.01.25 PM

You renamed the folder in the Finder?