ScanSnap trouble

Hi, I just purchased the ScanSnap S510M after reading rave reviews. When it works, it is indeed a delight. But I have two problems:

  1. When I quit the software, it forgets the settings for DEVONthink (DTPO, 1.5.4).
  2. It frequently tells me: "An undefined error occurred. (0xffffdxf7)
    I trash the file “” from the preferences (as recommended somewhere), but the problem persists.

I’m at a loss here, while I realise it has nothing to do with DTPO (or at least I don’t think so). Any advice much appreciated.

Update: Reinstalling ScanSnap manager with a driver from the website makes ScanSnap remember its settings.

But it still reports “an undefined error” with the remark that “A probable cause is that the system in unstable. Reboot the system.”

ScanSnap chokes especially on articles of more than 3 pages, rarely if ever on a single page. And it does not always quit either. Any advice appreciated.

The report that the System may be unstable suggests that OS X maintenance might help. A maintenance utility such as OnyX or C*ocktail may clear up some types of problems.

Another approach would be to review the non-Apple extensions that have been installed, perhaps temporarily removing them to see if the problem goes away. Some utilities that modify the operating system may cause errors, either singly or in combination. Old utilities that have not been kept up to date may cause problems after OS X upgrades or updates – check to see if there’s a more recent version than the one installed.

Your comment that ScanSnap Manager chokes on 2 or 3 page scans leads me to this question: How much free disk space do you have? During a scan, each page is stored as a separate temporary file and each file may be quite large. Apple engineers suggest that hard drives should have at least 15% of their capacity free, so as to accommodate temporary files and operating system swap files.

Dear Bill,

Thank you for your reply. I had in fact verified and repaired the HD when I encountered these problems, but upon your post I did it once more and found, again, a minor Volume Header error which required repair (which at first DiskUtility failed to carry out, but a second time managed).

I use less than 50% of my HD (500Gb), so that is not the problem. But I did have some haxies installed and removed quite a number of them, including SizzlingKeys, MisFox and others which I, in fact, never use.

Unfortunately, after initial success in scanning, the scanner reverted to old behaviour just now. I’ll try to see if there is again a need to repair the Volume Header.

Hi Bill and smolk: Our design studio ran into an almost identical issue last October with our ScanSnap connected to a brand-new MacPro. It took us a whole weekend to figure out what was wrong. Briefly, and without having the incident notes in front of me, I recall that the situation was due to a defective keyboard that had shipped with the new computer. We told Applecare about the issue but ran out of time back then before we could alert Fujitsu or Devon.

After some Internet research we concluded that the reason the system worked with an old keyboard and not the new one is that the new keyboard was drawing too much power from the USB bus, which left all other peripherals on that bus (including the ScanSnap) with insufficient power. There’s an electrical engineering term for this effect I can’t recall offhand, but it appeared all over our Web research. On the MacPro, we could scan up to 17 pages of a 500-page document before the system would fail with an error message identical or similar to “An undefined error occurred. (0xffffdxf7)” and instructions to reboot the system.

Try unplugging or replacing, one at a time, the other mice, keyboards, scanners, printers, USB hubs, Wacom tablets, or any other USB devices you have connected along with the ScanSnap and see if the issue resolves. If you’d like me to dig up my notes or web bookmarks, let me know here or email me privately and I’ll see if I can help further.

Thanks, redacted. There are so many possible variables that it’s often hard to figure out the cause of some problems. That ScanSnap Manager error report had me puzzled. I’ve never seen any error report from my ScanSnap. (EDIT: except error reports for a paper jam.)

Hi redacted, that is most interesting. I do have a SMK keyboard (I actually wanted an old IBM-like keyboard), because it is smaller, and leaves more space for my mouse on my small keyboard tray. It has a USB 2 and USB 1.1 connection (but the latter does not work), which is plugged into the Cinema HD Display. The ScanSnap is directly plugged into the back of the MacPro - but so is the screen, a set of speakers, and at the front I have a self-powered hub plugged in for my iPod, a self-powered HD, a self-powered flatbed scanner, and sometimes a microphone as well.
I’ll experiment - I do have that old keyboard somewhere as well, but I wish to use a smaller one. Which keyboard did you end up with?

Update: I can try it out on my MacBook - main differences, no USB-peripherals, Leopard rather than Tiger, and an built-in keyboard.

Alas, on my MacBook I encountered the same problem - without any USB-peripherals and of course the MacBook’s own keyboard.

I attached my old Mac keyboard (which shipped with the MacPro in 2007, and is identical to the one that shipped with iMac G5’s, white with transparent casing) to the Cinema Display - unplugging all other peripherals - and while it works slightly better, it still quits after 26 pages with the same error report.

Is this the same keyboard as you had, redacted? And if so, how did you solve this in terms of the keyboard?

Update: Trying more documents, ScanSnap is able to deal with a more usual length. Mostly, it’s up to 12 (double) pages, and it did not fail once in my latest set-up. Except that the keyboard is terrible.

I reverted to Iris and DT rather than Finereader, because 1. Finereader is slower and 2. it makes mistakes, like having vertical instead of horizontal pages.

Hi smolk. Yes, you’re correct: The keyboard that allows us to use the ScanSnap with DTPO on the new 3.2/8GB MacPro without any limits to the number of pages we can scan is in fact the white transparent iMac G5 keyboard.

With the flat brushed aluminum standard keyboard that shipped with the MacPro, we can get up to 17 pages before the hex error message telling us to reboot.

We use the MacPro for design, production, and video editing. We only connect up the ScanSnap to it when the MacPro isn’t being used for such billable projects and we need to scan a lot of pages much more quickly than we can scan on our iMac, maybe once every couple of weeks. In those situations we still have to swap in the white keyboard because we’re very busy taking care of our clients and we haven’t had time to get the aluminum keyboard exchanged under warranty at the local Apple Store.

We use a black Kensington keyboard with the iMac because the labels on the keys are much easier to read with dim ambient lighting. Unlike the white keyboard, the Kensington keyboard has no onboard USB hub, so we supplement it with a powered hub for the other USB devices.

I’m a little confused. When you mentioned that you attached the white keyboard, did you attach it to the MacBook or to your desktop computer? And BTW, what is the configuration of the desktop? Also, you mentioned you were plugging in the keyboard to the back of the Cinema Display. What happens when you don’t go through the Cinema Display and plug the keyboard directly into the computer?

Also, here, we use all Samsung monitors instead of Cinema Displays. Doesn’t the Cinema Display have its own hub onboard like the white keyboard? You can quickly tell through the “About this Macintosh” menu item in the Apple Menu, clicking on the “More Details” button.

Hmmmm. Very curious indeed.

I connected the white transparent-cased keyboard to the Cinema HD display, which leads to the MacPro (OSX 10.4.11, 2GbRAM, 500Gb HD; with a Microsoft Intellimouse USB that I forgot to mention earlier).

This is interesting. I plugged this keyboard directly in the MacPro - to its front, that is, the cable is too short to reach its back ports. Initially it gave the error after just 6 pages, but then I realised that I had left my Harman Kardon speakers & woofer plugged into a USB-port. After unplugging, it faultlessly processed a paper of 40 pages. A second time, it gave the error after 34 pages - with only the Display, the Scansnap, the keyboard and the mouse on the USB-ports. Perhaps the mouse makes a difference, I’ll have to bring another home to see if it does (or find an Apple mouse in the attic).

The USB-connections do seem to make a difference, although quitting after 34 pages is still not entirely as it should be, nor is it ideal I have to unplug devices to make things work. Yet I rarely process more than 30 pages, so if consistent (and that is an if for now), it will do for me.

How does the Kensington keyboard work with the ScanSnap?

“USB bus stall” may be the term in use for this kind of situation. Need to check my bookmarks & records some more.

ScanSnap scanners won’t work through USB hubs. But what if you tried plugging the ScanSnap directly into one of the computer’s USB ports and as many other peripherals as possible into an external powered hub? If you don’t have an extra powered hub lying around you can buy a decent Belkin 4-port lighted hub at Target Stores for about $10.

The Kensington keyboard works great with just a couple exceptions: the Command key position is reversed, and some function keys don’t work. But since I map keyboard commands using FastScripts instead, that isn’t an issue.

Actually, all other USB-peripherals except the mouse and screen are plugged into a powered hub by default; but I now plugged the speakers and mouse into that hub too.

It’s probably the keyboard that makes a difference. I actually own another keyboard, IBM-like by Scan-computers, that wasn’t made for the Mac and has problems with the command, option and control-keys as a result.
So you do not use the Command Key, or do you redefine certain keys on that keyboard to make them work like Command, option and control?

Don’t tell my Scansnap that - it works quite happily through a powered USB hub.

I was having quite a few issues with my Mac some months ago and decided to get new USB hubs. The ones that were apparently causing the problems were Belkin ones. I bought the Kensington 7 port USB hubs. So far all has been sweetness and light. I’d suggest paying a bit more and getting the Kensington instead of the Belkin.

Hmm, my hub is a 7-port Belkin one… How did you find this was the cause of problems, and what sort of problems?

My iPod would suddenly disappear from iTunes and no amount of plugging, unplugging would renew it. A reboot would make it reappear but only for a short time. USB pen drives would also suffer the same problem, as would other peripherals connected via the hub. I seem to recall having trouble with my ScanSnap too - which might have been what finally prompted me to get new hubs.

This wasn’t with just one Belkin hub, but with a replacement one too. Took an absolute age to determine that the hubs were the problem and not software, or some other variable.

I only bought the Belkins originally because I couldn’t get the Kensington ones, which are more expensive, but it really does appear that you get what you pay for.

I’m sorry, I should have been more clear. On the Kensington keyboard, the command, control, alt and shift keys work fine. Some of the F1 through F12 keys in the top row don’t seem to function, at least not out-of-the-box.

I use FastScripts key combinations tied to Applescripts to speed up naming documents in DTPO.

Via System profiler, I find the following differences in Bus power demand:

Apple Pro Keyboard:

Version: 4.20
Bus Power (mA): 250
Speed: Up to 12 Mb/sec
Manufacturer: Mitsumi Electric
Product ID: 0x020c
Vendor ID: 0x05ac (Apple Computer, Inc.)


Version: 1.03
Bus Power (mA): 500
Speed: Up to 1.5 Mb/sec
Product ID: 0x9472
Vendor ID: 0x058f

So I guess I need to check that before I buy! Thanks for all the help. I’ll keep on experimenting, once I find something meaningful I’ll report back.

i don’t mean to highjack this scansnap thread.
but i do wish to report that fujitsu has updated scansnap manager software today. it is a free upgrade.
i hope this addresses your scanner problem.

I don’t see the upgrade posted, at least not on the U.S. site at this page: … s/mac.html

Can you provide a link please? … V22L11.dmg

or… … V22L11.dmg