Screen Flashing

Has anyone had problems with the screen “flashing” in DevonThink? I have had this happen about twice in other things since upgrading to Catalina, but I’ve found a situation in DT where I can make it happen every time.

Here’s a link to a 10 second video showing what I’m seeing:!AtUezSyoJXKTg7IOUmChLqVGaY2ySQ?e=UlUkgi


Which version of macOS do you use, does a reboot fix this?

Same here, since today. Catalina (Yes, I know ;-), DVT 3.0.1

I noticed such issues during early betas of Catalina but not recently anymore. What kind of documents cause this?

I see screen flashing when closing all databases; on my iMac I see one single flash, on my MacBook I see several flashes. I haven’t yet noticed any other activity causing flashes. I’m on DT 3.0.1 and 10.15 final.

[Interestingly, on my MacBook when scrolling through (raw) photos in Photos the thumbnails briefly become checkered. That doesn’t happen on the iMac (however, the MacBook might not have finished downloading all photos).]

New installation of Catalina, latest version of DT 3.

Reboot doesn’t fix it.


ps: I can send you the 4 files if you’d like to try to replicate it.

Ok, great - at least I know I’m not going crazy :slight_smile:

1 Like

Or, of course, you might both be :face_with_hand_over_mouth:

(probably not, though :stuck_out_tongue_winking_eye:)

Oh, at this point it’s highly possible! :slight_smile:

1 Like

Flickering also when showing a JPG (Catalina).

I just installed DT3 and this is happening for me as well when selecting JPEG files

Seems that Apple has reintroduced a bug of earlier betas of Catalina - I noticed the same flashing after selecting images in the first betas but then one beta fixed it. Sigh.

1 Like

Me too – exact same behavior as the video from the original post. Might be a Catalina bug but it only happens in Devonthink. I’m on 10.15.1 on a 2017 MBP, DT3 Pro (3.0.1). Hope a fix comes soon!

Found this thread and wanted to report another “me too”. Selecting different images causes the entire app to flash, and so far I’ve tried JPEGs and PNGs. This running DT 3.0.3 and macOS 10.15.2.

This behavior does not exist on my Mojave Mac (running 10.14.6).

I too would love to see a fix for this coming soon. My eyes are going nuts!


Same here. macOS 10.15.2.

Has anyone who has this problem figured out a solution? It’s only happening in DT for me…
I have sensitivity to flashing lights and can’t use the app bc of this

This is an issue with Catalina’s ImagKit framework and under investigation. Thanks for your patience and understanding.

1 Like

The next maintenance release will fix this.


Fixed in latest release! thank you