shortcut for print pdf to DTPO?

I enjoy using the reader view in Safari and printing a page to DTPO. I have a shortcut (cmd-P) that pulls up the print pdf menu and – thanks to David Sparks – a shortcut (a second cmd-P) that will print the pdf using my printer. But to print the pdf to DTPO I still must use the cursor to pull down the options and select print to DTPO, and I haven’t figured out how to create a shortcut for that last step.

Does anyone here have a shortcut to do this? Or can someone suggest the steps I could take to create that shortcut?

We covered the same tip in our blog at some point. Just hit Command-P twice in a row. No need to mouse for anything.

I tried this, but it didn’t work. What am I missing?

The behavior changed in High Sierra. David Sparks has a blog post on how to fix it here:

Well, that’s helpful. At least it gets me back to being sable to print to pdf and choosing a location.

But it still doesn’t help with saving as pdf to DTPO without using the drop down menu.

Saving directly to DTPO is crucial for me because it preserves the reference back to the source – which I’ll need if I ever use the material in my writing.

This is turning out to be really frustrating.

I already had installed the add-ons and therefore had access to the drop-down menu.

Using David Sparks fine tip I can use cmd-P to get to the print page. And I can click on the pdf button and then on the save pdf to DEVONthink.

But what I looking for, hoping for, is a shortcut that takes care of those last two steps without having to click on buttons or options.

A fast way is to use the cmd P, then option cmd P. The first pulls down the print menu. The second triggers the “Save PDF to DEVONthink Pro” command in the sub menu. Set up option cmd P in the keyboard shortcut like you did cmd P. Very fast way to put things into devonthink inbox.

I’m on High Sierra and the shortcut is working exactly as expected.
Here’s the simple screen cap of the setup (with no need for a separate shortcut)…

Command-P, Command-P without a pause and it’s working just fine here.


Here also (old-fashioned Sierra)