Some folders not syncing between Macs

Two Macs on macOS 12, syncing by Bonjour only. All files indexed. Referenced files on Dropbox.

One database (out of four) on the Bonjour client Mac failed verification with “missing file” .

Tried “updating indexed files” which usually works but didn’t this time.

So I turned off sync on the the problem database on Client Mac, and deleted the problem database.

Then I turned on Sync and imported a fresh copy of the problem Database.

This passes verification, but has several folders dimmed and with a cloud+arrow symbol, which I think means not sync’d

I have repeated the delete/reimport twice and same thing happens, with the same affected folders.

Any help appreciated.


First check that you have set for these Dropbox folders to be local. see How to use Dropbox Smart Sync to save space | Dropbox Help

Thanks for quick reply. Good suggestion but I should have said that I have done that.

Hmmm…I am suspicious of Dropbox. The link you gave doesn’t apply because my Dropbox Folder has been relocated to ~/Library/CloudStorage/Dropbox, as in this thread. Smart Sync is no more, instead you right-click on files and folders and select “make available off line” or “make on-line only”.

I had already done “make available offline” for the top level folders of my databases, but the reason I am suspicious of Dropbox is that I drilled down to one of the dimmed/unsyn’cd folders and did right-click/make available off line and DT3 immediately stopped showing it as dimmed/unsync’d.

However this has not worked for the other dimmed folders.

Another oddity is that in any DT3 dimmed folder none of the contents at file level have an unsync’d icon next to them …only the folder containing them.

This may be a Dropbox beta issue.

Repeated use of “Make available Offline” has made all folders show as sync’d in DT, except one. As before this only seems to affect the folder not the files inside. Files added to the affected folder are correctly sync’d between computers in Dropbox and DEVONthink.

The cloud with arrow symbol only appears in DT3 not Dropbox, where all files and folders are correctly indicated as online only or available off line. But obviously there is something about some folders which can make DT think is is online only.

Does a toolbar search for item:pending in DEVONthink show only the group or any of its contents?

Does a toolbar search for item:pending in DEVONthink show only the group or any of its contents?

Item:pending search shows only the group, not the contents.

Surprisingly it also shows five other groups (no contents) which are dimmed/unsync’d symbol which I had missed previously because they are a few levels down.

A week further on and two new Dropbox betas. Five of my six marked-by-DT-as-unsyncd-but-working groups have now corrected themselves, but one has not.

For want of anything better to try I made a duplicate of this problem group in Finder. The duplicate folder automatically appeared in DT as “Foldername copy”. This showed as unsync’d, BUT the original group “Foldername” now did not show as unsync’d.

After checking that everything was syncing to other devices, I deleted “Foldername copy” leaving only “Foldername”, now not showing the unsync’d symbol and correct on all devices.

Does that make any sense?!

Obviously the Dropbox change to restore online only files for 12.3 is still flaky, but I am persisting and keeping a close watch.

In my experience with indexed items in clouds, only selecting the offending folder in the search box or in a smart folder/rule makes it as not pending if it is a real folder. This happens to me so and then when I update a file or a folder in a different DT mac of the original indexing file/folder.

Sometimes so and then DT takes some time to mark the folder or file as synchronized in smart folder/rule.

And finally, selecting the offending files/folders and pressing “Update Indexed Items” should do the job.

1 Like

Thank rfog. Perhaps it was DT sorting itself out as you say, but I hadn’t experienced the same behaviour before the Dropbox change to ~/Library/CloudStorage location.

Before the change item: pending was quite common and often sorted out in a short period, and frequent “updated indexed items” was also a good practice which helped.

But before the change I never saw the unsync’d symbol next to folders like I did after the change.

Can I ask if you are using the Dropbox beta and if you have ~/Library/CloudStorage/ Dropbox?

The “new” macOS API for third party clouds seems it is a little bit buggy. OneDrive causes problems as well, and Dropbox has some-kind-of-removed files on demand in Monterey.

I’m reading a lot of complaints about “the new way” Apple has implemented cloud, not only here for DT but for a lot of other programs.

For example here (ignore “solved”, Dropbox is joining a lot of complains in one thread only): Solved: Dropbox support for macOS 12.3 - Dropbox Community (

1 Like

Yes I am quite active in the Dropbox forum (as Michael B.10) but the Dropbox Community is so fragmented there are multiple parallel discussions going on, with nearly no input from Dropbox staff.

Have you seen this thread here in the DT forums.

Yes, saw it and fast-read it, as I’m always interested in sync issues with indexed files, as mine are indexed because I need access to them from Windows and Android.