Sticky Zoom, Setting Default Zoom... for bad eyes

Perhaps this should be in the suggestions area, but I notice that DT does not remember my zoom level when I go to the next item or return to something I’ve been viewing. I personally find the zoom level too small for my aging eyes on a laptop screen. Having to hit the zoom keys for every item seems annoying. Can’t a default zoom level be specified for all items viewed. I’m thinking of the way Scrivener does this. You specify your zoom level and it sticks for all items you open. Seems pretty essential. If this isn’t possible, perhaps my post can be moved to the suggestions category. Thanx for reading.

This is not yet possible but will be added to one of the next releases.

Thanx for the update on this feature. Appreciate it.

Hi philosopher_dog: Thanks for your post. For the time being, consider using Adobe Reader 9, which offers a persistent zoom level, for most of your PDF work with DTPO. I have it set as my external PDF application because, as I think I explained in more detail in a previous post, it offers better zoom preferences, a great navigation viewer, and clearer text rendering than applications which rely on Apple’s PDFkit.

If you’re another DTPO enthusiast or power user, your mouse hand will start to badly hurt–like mine did for several days–if you keep triple-clicking on the zoom button in DTPO’s default PDF viewer every time you need to review a PDF. Save yourself a trip to your doctor for a pain control prescription or an orthopedic surgery evaluation by letting Reader 9 do the work for you.

Is there a default zoom level for viewing .pdfs? Or for viewing any files?

Please tell me this isn’t still the case in 2017, and if not, how I can set default zoom. It seems that every time I leave a document (other than an RTF) and return to it, its zoom level has been reset.

How do you zoom?

I tried the preferences, and the font sizes all seem to be for the sidebars, not the documents themselves.

I don’t see anything in the menu on how to zoom.

How do you zoom in, e.g. on a Word document or PDF you have in DEVONthink Pro?

The default size is too small for me to read, yet, it only fills half the width of the document window.

See the attached screenshot. The areas in red are unused - the document is in the middle and the screen width is wasted due to lack of zoom function.

For PDFs, use the View menu, Zoom In, Zoom Out, Zoom To Fit, Zoom To Width. Right-clicking in a document window will give you the same options. You can also pinch in/out to change the zoom in a window. The Zoom is also covered well in the DEVONthink manual.

Word documents may behave differently. I don’t have Word installed, so I’m limited to the Quick Look viewer supplied by macOS. I can pinch in/out to change the text size, but I cannot zoom to fill the view pane in DEVONthink. I have to use the text alternative option to fill the pane. Pages.app documents don’t have that same limitation for me, so Word documents may behave differently for you if you have Word installed.

It’s almost 2020, and I couldn’t figure out how to set default zoom level for PDFs. Is it possible?

Welcome @sashk

There is no default zoom level for PDFs.
See this…