Sync error due to pending files.

A perfectly syncing database stopped syncing do to pending files, right after upgrading IOS to 2.0.2. Just don’t know how to resolve that problem. Throwing away the last couple of entries I created since the the upgrade and emptying the trash wouldn’t help. Now I’m stuck, any suggestions?

I hit this same exact error immediacy after upgrading. The database won’t sync anymore. Help?

Same Problem for me with 2.0.2

I have the same problem after upgrading to 2.0.2:
2 macs and 2 iOS Devices syncing via Dropbox
Same error on both iOS devices
I found pending files in 1 DB on Mac 1 but not on Mac. That DB was not set up to sync in the ios Devices or the macs but had ben previous to 2.0.2. The only way I could to resolve the pending files was to delete them on Mac 1. Don’t know why pending files on a DB that was not set up to sync would affect syncing.

Deleted the DBs on the iOS devices and the set them all up again on the ios devices and macs so 2 DBs with no pending files set up sync to both macs and both iOS devices.
Still get the error message on ios and the ios devices show the spinning gear icon in the stop left of the screen next to the wifi icon.

DT folks must have their hands full with the syncing issues and when it works - it is wonderful. And I sure they will figure it out.

I had tons of issues with 2.0 and 2.0.1 syncing with webdav on synology. Syncing with dropbox just worked (yeh !! ) until 2.0.2 . I have deleted, re-loaded, re-built, re-synced more ties than I remember over the last 3 weeks and tried too many permutations of redo /sequencing of the rebuilds and syncs between the 2 macs and the 2 ios Devices.

I have submitted support tickets and received replies with questions for more details but no solutions, no answers to questions, and no reply to follow up email. I assumed submitting support tickets would mean getting responses and help like they did in the past. Maybe I will spread some chicken entrails around, do an ancestral dance, and sing incantations… :smiling_imp: couldn’t hurt…

The same Problem. In German it is shown:

07:28:42: DevonDrop.dtCloud Kann Datenbank wegen ausstehender Inhalte nicht hochladen.

Devonthink Pro Office 2.9.4
Mobilversion 2.0.1
AND Mobilversion 2.0.2

Looks like people are seeing the same problem over in this thread too: "Migrating data model" after 2.0.2 install

IMG_0347.jpgSame this is happening with me. I’ve re-downloaded my databases (DropBox/ single sync store) but I’m still getting the sync error.

I’m having this sync problem too, after having to wait about 10 minutes for the Migrating Data Model screen.

Same here. NEw installation of app does not help.

Here also. For now, I’m syncing only by local network. I plan to trash my sync stores on the desktop and start over again.

Seems there is a fix on the way in 2.0.3 (just submitted to the App Store for review), but seeing as it is a long weekend in the U.S. on Monday it may be a while before we see the update itself.

Blog post:


Both my iOS devices showed that sync problem. Using DevonThink desktop app on my mac I could create the smart group, found and deleted one file, emptied trash. Then both iOS devices synced fine.

I wouldn’t make that assumption.

Here’s hoping Apple fast-tracks the approval and we see it Tuesday. Fingers crossed.

You and us both. I’m hoping for sooner than Tuesday.

Ugh. 5 GB of local data, and on iPad my first launch of the .2 version simply gives error - Database store damaged beyond repair - followed by instructions to delete/reload. Such a lengthy process to redo and re-index

Update: indexing freshly-sync’ed databases is now much faster than prior versions. Makes doing a full restore much less painful.

Wow, that was quick for 2.0.3.

Apple must use DEVONThink :laughing:

My issue with pending uploads seems to have been solved with 2.0.3.

Thanks to the team, and great that Apple rushed through the approval.

”Generally” bugfixes get through more quickly, but yeah - this was especially good on Apple’s part. Apple Reviewers FTW! :smiley:

The update corrected the spending file sync I was experiencing. Working very fast !

New issue arose of multiple “manifest files” are missing errors when syncing:
Did some work on iPad while away and on a slow public wifi. Now all the other devices show a sync error for the same 8 missing “manifest files”. See attached.

Forced syncing does not correct.
Is there a way to resolve without loosing the changes made on the iOS device?
What causes theses missing files - meaning there a way to avoid them?