Sync - Not authenticating with WebDav Server

Mac Powerbook Pro OSX 11.6
Synology Server DS212+ running DSM 6.0.2-8451
Devonthink pro Office

Yesterday I managed to sync to my local WebDav running on the Synology server. This morning I’m now getting an “Authentication Failed” error when I try to run sync. After I upgraded to 2.9.3 but no difference.
Tried deleting the file on the server and restarting the sync … same error

Using my mac, I can access the WebDAV using the URL (copied from the sync preferences) and using the same ID and password. Would suggest issue is with DevonThink.



1 Like

I’m having the exact same issue. I updated this morning, and since them have been getting the failed to authenticate alert regularly. I made sure the login and password were correct, but I continue to get the alert.

Try setting the https:// port to 443.

Same problem here. Sync against a WebDAV sync store worked just fine before. Upgraded to DTPO 2.9.3, now the sync fails.

DTPO reports “Authentication failed”.

Apache reports: [Fri Sep 02 06:31:06.016955 2016] [auth_basic:error] [pid 2150] [client MY_IP:49657] AH01617: user MY_LOGIN: authentication failure for “/path/to/store.dtCloud”: Password Mismatch

On a second computer I am still on DTPO 2.9.2 and it continues to sync without issue.

I tried re-entering the password in the sync store preferences. Didn’t help. I tried adding the explicit port to the sync URL. Didn’t help.

What are you running the WebDAV server on and have you tried standard WebDAV ports?

Hi Jim, This is standard Apache 2.4.6 as shipped with CentOS 7.2 and fully up-to-date. Apache is listening on HTTPS/443. Can’t get more standard than that.

I don’t see how the port would be relevant here since DTPO is clearly reaching Apache just fine.

Version 2.9.4 will be available later today and will fix this.

Thanks and great work for the quick turnaround on this issue!

I’m getting the same issue. Worked fine yesterday before the update.

Which version do you use?

New update appears to have fixed the problem.

Thanks for the fast support.


I am trying to get Devonthink to use my Synology WedDav server and I cannot figure out why it is not working.

I’ve updated to the latest Devonthink (just now).

I have the following settings (on an internal network):

UserName: webdavuser
Password: (password given to user)
SyncStoreName: AccountingShare
encryption: (provided)

When I try this I get "Error while setting up location ‘AccountingShare.dtCloud’ … "Could not connect to the server. (NSURLErrorDomain-1004).

Does anyone have any tips for me?

Thanks - – Randy

1 Like

-1004 is “Cannot connect to host”.
Make sure you have a complete path for the URL.
Also, if you are using encryption, you should be specifying https://, not http://

The update did the trick. Thanks for the quick response.

I would note that I still had issues until I not only updated, but also rebooted my macbook. Now it all works again. :smiley:

Upgraded from DTPO 2.9.2 to 2.9.4
Sync with Magenta Cloud worked just fine with 2.9.2
After upgrade I get the following error:
Fehler bei der Initialisierung des Speicherortes
Authentication failed

Even if I try a new Sync Store, I get the same error.
Same problem on iPad and iPhone using 2.0.3

Any idea?

I have upgraded to DTPO 2.9.4.

I am noticing a behavior where I am able to sync via WebDAV utilizing a Synology diskstation on a remote network. However, when I attempt to perform a sync on my local network, I receive the following message:

Could not connect to the server (NSURLErrorDomain -1004)

Any thoughts or others experiencing similar?

Please start a Support Ticket.

Were you able to get things operational? I’m having the same issue on my end and can’t figure out how to resolve it

A connect to host error is network or server related.

With the URL you’re trying to use, see if you can connect in the Finder via Go > Connect to Server

Just a thought (because I’ve tripped over this a few times) - there server address has to include the relevant folder in which the sync database will sit.