Sync stuck at `1 items left to be uploaded`

I do same with iOS device, relatively frequently as I’m always reading stuff, esp. “on the go”. I put into the Global Inbox and eventually it reaches my DEVONthink (desktop) at Global HQ–if I happen to be on the internet right away, or when returned to Global HQ. Then DEVONthink Rules do their magic putting stuff where I want.

1 Like

So, an update from my earlier post, and it’s is pretty funny. :popcorn:

The item:pending found one file, and guess what? It’s related to the OneDrive changes that Microsoft made recently. :man_facepalming:

I decided to delete the file from the DB, but it didn’t work. I still have to do what I promised: remove the stores and start a fresh/clean sync (not sure I’m using the correct terminology here). This will have to wait until I’m back home because the WiFi here sucks.

Fun times ahead and confirming I don’t believe it’s a DT problem, just the joys of computing. :flushed:


Not to step on your stubbed toe but thanks for sharing that :stuck_out_tongue:

What happened when yoou tried to delete the file in DEVONthink?

Unfortunately deleting the file did not fix the issue. I had to clean the entire sync store to stop the error messages. I tried cleaning one DB at a time and tried to do it in the reverse order that they were added/enabled for syncing but no luck.

My next step is to re-enable the sync and see if the error returns. :popcorn:

I also had the same problem
“1 items left to be uploaded.”
i cleared the recycle bin and it resolved

1 Like

Just to share my own experience of what others already shared.
I had the same message since my upgrade of DT.
Following this message thread and the answers from DT team I found the root cause (for me)
Actually I had in my indexed files some which were not anymore there and then in my list of PDF file in my Database when I clicked on them I have a message saying “file not found” and I had also near the title a cloud icon indicating the the file needs to be uploaded
When I put these “files” in my trash and empty it no more message anymore when my database run the sync
hope this help some of you



Welcome @donny_1

Thanks for sharing your experience. Glad to have you here :slight_smile:

And thanks to you, @bkantique, as well :wink:

1 Like

Oooh, I wish I’d found this thread before I started tinkering. DTTG on two different devices are uploading Items to iCloud, DT is also uploading but churning out “missing file” errors for indexed files on an iCloud Drive, 2 files cannot be uploaded (apparently) but “item:pending” returns 144 items not downloaded. All because a single item in the Global Inbox wasn’t syncing to DTTG. Sigh.

What did you tinker with?

I did a “verify location quickly” and a “clean”, and then re-ticked all the individual boxes for iCloud (CloudKit) sync for Local databases, and also started forcing iCloud to download directories with missing files.

I emptied the trash (as per above), and still can’t identify the 2 files that couldn’t be uploaded, and given that some of these databases are 25-40 GB, nothing is happening quickly…

then re-ticked all the individual boxes for iCloud (CloudKit) sync for Local databases

With CloudKit, you should not enable multiple databases to sync. You should sync one at a time for the initial upload/download.

also started forcing iCloud to download directories with missing files.

Are you indexing files that aren’t locally available? That is not a good thing to do.

Well, the multiple database ship has sailed, so we’ll see where that ends up. They’ve been syncing fine since the update moved over to CloudKit, and until just now, forgot the issues that arose then.

The files were all there when they were first indexed, but I have iCloud on optimize, so clearly some of them have left in the interim. Although I think I have space on a local drive for the files now, that wasn’t the case previously. Also, the duplication of size locally was an issue (keeping multiple GBs of PDF files synced across multiple devices using both and iCloud, and then DT so I could search/sort/do exciting DT things with those files).

Years of mixing indexed/in-database files has worked perfectly, but I fear things may not continue to do so.

Having a hybrid database, a mix of imported and indexed files, is not an issue. However, indexing files that aren’t locally available isn’t a good idea. This is especially true if they’re being offloaded behind the scenes, leaving you with unexpectedly missing files.

Fair, though, the iCloud optimize for space feature is something I rely on to manage limited space. Which has now all gone rather wrong, and I’m seeing that my local HD is 95% full, which is obviously not ideal. Trying to resolve my DT sync issues, I have unexpectedly present files (or, more accurately, I started forcing downloads without thinking through why I had left iCloud on optimize in the first place).

Tomorrow, I imagine first I’ll figure out how to balance the local files, then address the ghost indexed files in DT’s databases, and then delete DTTG everywhere and re-install and then re-sort sync Sigh. Not how I wanted to spend the day, but so it all goes.

Thanks for the prompt response - I rely on DT, and you, as a company, have never made me doubt that reliance.

I use Keyboard Maestro and the script below. Be sure to change to where you want the backups to go. I send them to a Cryptomator folder that encrypts the backups to iCloud. Sorry, I don’t recall where I found the script.

tell application id "DNtp"
		repeat with this_database in databases
			set this_date to do shell script "date +%y-%m-%d"
			set this_path to path of this_database
			set {od, AppleScript's text item delimiters} to {AppleScript's text item delimiters, "/"}
			set this_name to the last text item of this_path
			set AppleScript's text item delimiters to ""
			if this_name ends with ".dtBase2" then set this_name to (characters 1 thru -9 of this_name) as string
			set this_archive to "<DESTINATION>" & this_name & " " & this_date & ""
			set AppleScript's text item delimiters to od
			show progress indicator "Daily Backup Archive" steps 3
			with timeout of 1200 seconds
				step progress indicator "Verifying..."
				if (verify database this_database) is not 0 then error "Database is damaged."
				step progress indicator "Optimizing..."
				if not (optimize database this_database) then error "Optimization of database failed."
				step progress indicator "Zipping..."
				if not (compress database this_database to this_archive) then error "Backup failed."
			end timeout
			hide progress indicator
		end repeat
	on error error_message number error_number
		hide progress indicator
		if the error_number is not -128 then display alert "DEVONthink Pro" message error_message as warning
	end try
end tell
1 Like

I have the same problem, DT won’t sync (via Dropbox) of course…
item:pending no file
any help?

Did you also verify the database?


And no missing files reported either? Meaning that all databases were successfully verified and a toolbar search for item:pending in all databases doesn’t return anything?

exactly, verified also file integrity but it doesn’t sync any more