TaskPaper oddity

Cannot get DT 3.8.5 (on 12.5.1) consistently to recognize TaskPaper documents for what they are.

It opens them in MindNode - despite their .taskpaper extension and despite setting them to open in TaskPaper in the Finder before importing!

It works for a day or two (I know, this sounds ridiculous) - then reverts to opening them with MindNode.

I have done all the usual things (set Open with in the Finder before importing etc); and as discussed here.

I’m using the routine, File > Share > Add to DEVONthink 3, to import rather than dragging the TaskPaper files.

The extension is .taskpaper to begin with is being changed (surely not by DT) to .mindnode! I do have MindNode files elsewhere in DT; could that be causing this?

DT’s own Context > Open with usually works. But I know I shouldn’t have to open them this way :slight_smile: .

I have a suspicion that moving the TaskPaper files into the Reading List may be causing this? Just a hunch.

TaskPaper docs do always open with Taskpaper from the filesystem (not in DT), BTW…

Known bug?

Nope - not known.

  • What operating system are you running?

  • When you select the Taskpaper file in DEVONthink, what is the top option in Data > Open With?

  • I imported a Taskpaper file into DEVONthink and it retains its extension and file type.

Just curious why you’re using the Share menu for this.



For the first few hours (!) it’s “TaskPaper (Default)”; but after a restart?/relaunch of DT?/adding it to Reading List? it changes to MindNode - apparently ‘by itself’ :slight_smile: .

I’ve tried all the ways of importing TaskPaper files that I know:

  • dragging into the appropriate Group
  • the Share menu in TaskPaper itself
  • the “Add to DEVONthink 3” service

just to see whether it made a difference… it appears that there is no difference; so my apologies for adding what looks like an irrelevant piece of information.

Does DT do any post-import processing to associate filetypes with apps? I believe not: DT doe use - and can only use - the macOS (Finder)'s launchdb, doesn’t it?

Which is what makes it so strange.

I am 99% sure that - even though I set TaskPaper as the app to use to open TaskPaper files in the Finder - they are imported and retain that association (for a few hours???) then get changed to MindNode after a few launches. I’m 100% sure that this is only happening within DT. And that TaskPaper files are the only type exhibiting this in nearly a year’s (very happy!) use of DT.

Crazy, isn’t it!

No. Files are imported intact, in their native format, just as happens with the Finder.

It is strange indeed.

Mindnode is indeed Taskpaper aware, so perhaps it’s errantly taking over the association. DEVONthink just gets the information from the operating system’s file associations. Have you reported this to the Mindnode developer?

Thanks, Jim!

The really strange thing is that TaskPaper files (I currently have two of them in DT) consistently open with TaskPaper, as they should and because of the association I have/had set for each of them (although I have not checked ‘Change all’), for a few hours/for a few DT sessions.

Then - I swear, without my doing anything to them (except adding each to the DT Reading List) - they steadfastly start launching MindNode.

As if there were some sort of spidering or indexing taking place that changes their association.

If I locate and reveal them in the Finder (from within DT; they are imported, not indexed, BTW) the association (Cmnd+I) has also changed to MindNode (that is, at the filesystem level)!

I started a thread on the TaskPaper forum, where - as I expected, and as I know to be true, and as I know DT works - all associations (must) follow the operating system assignment!

I looked at A Better Finder Attributes to see if it could keep track of when such metadata has been changed. Nothing immediately obvious. Maybe allow Onyx to rebuild my launchdb?

Also relevant, I would’ve thought: TaskPaper docs always open with TaskPaper outside of DT :frowning: .

Three hours have passed since I wrote the above.

Attached a screengrab (right click > Show in Finder then Cmnd+I) of what has happened - with no intervention from me:

As can be seen, the default application for my two TaskPaper docs has changed itself from TaskPaper to MindNode!

I did not launch or use DT in the intervening three hours.

Something, somehow, somewhere has changed such that files which previously opened in DT with TaskPaper, as they are supposed to do, will now only open with MindNode.

Is there some DT process that is re-scanning, or re-indexing these TaskPaper files and causing their parent application to change, please?

If not, how can we escalate this to see if it can be diagnosed and fixed, please?

By no means the end of the world, but I rely so heavily on DT; it’d be really great to have it work as it does with every other file I have. Thanks so much!

DEVONthink doesn’t change any default applications, it’s using the same ones as the Finder.

Did you contact the Mindnode developer about this?

Yes, Jim, thanks; just now.

The critical (and potentially most telling) thing seems to me that TaskPaper files initially work (sometimes for up to 12 hours) as they should in DT.

Then they get changed. I am not touching them!

How can this happen?

Thanks, @cgrunenberg; that’s what I thought.

What on earth could be changing the associations?

As I say, the two TaskPaper files were successfully imported into DT. They worked as expected for a few hours - opening in/with TaskPaper maybe half a dozen times. Then the filetype association changed - by itself - to that for MindNode.

So does this mean that the Finder is changing the associated parent file?

I guess that’s more a question for Apple.

@cgrunenberg, thanks - except that this only happens with TaskPaper files and it only happens in DT.

By that I mean that all my TaskPaper files outside DT always open with TaskPaper (as do MindNode’s).

The Finder does not change anything when I create, save, store and launch TaskPaper files running them from the filesystem.

I would like to be clear, though, please: this is not a complaint at all :slight_smile: I am a big fan of DT and rely on it all the time. I would just like to be able to include TaskPaper files in DT.

Could this be anything to do with the fact that DT is MindNode-aware, please?

Does it also happen if you use “Change all”?

Absolutely nothing that DEVONthink does should affect the Finder’s file associations. At least as long the file extension remains the same (and according to your screenshot it’s still .taskpaper).

Did you already try to set the default application explicitly to TaskPaper for all TaskPaper files?

@pete31 and @cgrunenberg - thanks again!

This is what I have done:

  1. exported each TaskPaper file to the desktop from DT
  2. at the filesystem level (in the Finder) each had set itself to MindNode again, although the extension for each remains/remained “.taskpaper”
  3. moved each file to DT’s trash and emptied the trash
  4. in the Finder set the filetype (back) to TaskPaper
  5. for each of the two files, I also “Changed all” to TaskPaper
  6. re-imported each separately into DT

What I have not done (yet - although I’d like to be able to):

  • added either to the DT reading list

because that seems (I may be wrong) to cause the wrong association to happen… after all, it’s the only operation I have been performing on these files!

(My thinking here is that - because previously I had not “Changed all” for fear of complicating things - DT somehow treats files in its ‘Reading list’ as new/separate/different, doesn’t know what to do with the ‘.taskpaper’ extension etc and so - quite understandably - assigns them to MindNode.)

I’ll report back here if anything now changes.

Much appreciated :slight_smile:

Is MindNode open all the time or are you periodically relaunching it during that 12 hours?

The Reading List is a set of bookmarks, nothing more.

Thanks for your perseverance here, Jim :slight_smile:

I haven’t once launched MindNode - not, probably, in the last month or so!

It’s only been opened when clicking on a TaskPaper file in DT. Also, perhaps significantly, launching a TaskPaper file in the Finder has never launched MindNode!

Thanks for the clarification re Reading List. Odd, isn’t it!

Very strange indeed!

Do you see the same behavior in a new macOS user account?


Three days now, and it’s behaving itself :slight_smile:

The only change I made (on 2 September) was at @pete31’s and @cgrunenberg’s suggestion (thanks): I set ‘Change all’ in the Finder to associate all such (TaskPaper) files to open (only and always) with TaskPaper.

No reversal to MindNode in my DT database (so far).

I remain puzzled as to why it appears necessary to do this, though: either setting a (single, particular) file to open with a specified app applies or it does not apply.

It should surely not be necessary to set all the others of that type for the settings for the one, first file to stick.

That made me wonder whether - since the phenomenon does not manifest itself outside DT - there is some kind of post-import process which either copies, indexes or modifies the TaskPaper files which I have imported such that they lose the launch association - because the association has only been set for the file as it was when it was imported?

I should like to repeat, please, though that I am a huge fan of DEVONthink and DEVON Technologies and that I started this thread not to complain but in the hopes of discovering something that may help other DT <> TaskPaper users, as well as me :slight_smile: !

1 Like

I’ve now heard back from the very helpful folks at MindNode.

Their engineer says (paraphrasing):

Changing ‘Open with…’ for only a single file causes a special attribute to be written to that file (as can be seen using xattr -p com.apple.LaunchServices.OpenWith /path/to/file.

But changing it for all files changes a database in the system

… as @pete31 and @cgrunenberg both said, thanks.

I can understand that. But why the ‘parent’ application of TaskPaper files changes after a few hours in DT still puzzles me. The only explanation that I can come up with is that such TaskPaper files must lose their settings for that attribute somehow.

And so can only retain or regain it if that attribute is set in the system-wide database.

Because they have essentially become different ‘versions’ of themselves and so the single setting is no longer valid?

And then this happens (quoting from MindNode again):

Regardless, MindNode simply declares that it can open TaskPaper files. It never tries to actively set itself as the default application for them or something like that. The decision about which application opens a particular file is made by macOS and MindNode does not try to interfere in that at all.

Is that possible?