Totally Frustrated by Sync

OK, HOW do I easily get my entire database synced to DTTG?

I set up some folders in the sync group, several layers of them, then replicated the individual folders and files, or at least I thought I did.

Later added more files to the main folders on DTPO and the new files are not being reflected in my sync!

Tried to re-replicate the files and lost a bunch of notes. Old ones got deleted new ones not saved a total disaster.

PLEASE FIX the sync, it need to be simple, easy and foolproof and we need an easy way to say sync entire databases or folders no matter what happens in the underlying structure!

I just want a sync this entire database button that actually works!

Version 1.0.2 does not fix the syncproblem.

It works randomly and suddenly it doesn’t work at all.
Sometimes the iPad sync but not the iPhone. Sometimes it see the network sometimes not. Just now it doesn’t work all all. All on the same basic network where everything els works just fine to sync.

Everything have a limit where you can’t use it anymore. DTTG is to me very, very close to that limit.

The most scary thing is if you think the problem is solved, but I can tell you it’s not.

I notice that DTTG’s success in connecting to the desktop is sketchy in 1.0.2. There is a very long pause in DTTG before the desktop machine appears in the synchronization list – a longer pause than in 1.0.1 (overhere, there was no delay in 1.0.0). Sometimes the machine just never appears. A restart (or two) of DTTG clears that up. Perhaps there is some sort of background Bonjour management or validation added to 1.0.2 that is overly conservative?

I don’t notice this effect in 1Password, TextExpander, or other iPad apps that use Bonjour. Perhaps a little offline developer-to-developer chat might convey some lessons learned without breaching confidences.

The whole sync issue has more or less put me off DTTG. I was really chuffed when it showed up in the store, now I hardly use it.

Me too!

DTTG 1.02 still fails to sync on my iPad.

Sync on my iPhone occasionally fails, but sync on my iPad almost always fails.

Symptoms are similar to those described above by Korn:

• a long pause before the desktop machine appears in the sync list
• more frequently it doesn’t appear at all
• after several re-starts the desktop machine eventually re-appears
• but frustratingly this desktop machine button is usually totally unresponsive!

I have never had wi-fi problems with any other application.

Everything about DTTG so far has been a huge disappointment to me.

The exact opposite of what I expected from DEVON-technologies!

I too have abandoned DTTG on my iPhone and iPad out of frustration. There are several apps I have that sync perfectly - Simplenote, Elements, Omnifocus, VoodooPad, Auditorium, 1Password, etc. Most, if not all of these provide several options for sync’ing, with my personal favorite being Dropbox, but I have Omnifocus and VoodooPad successfully sync’ing to MobileMe. Obviously it’s possible to get a sync system working, but it seems to be problematic for DT. I’m currently using Simplenote documents to create notes on the go, which I then transfer to DTPro on my Mac when I get home. Stupid that I have to use a free app to work around issues with a $15 app.

We have made improvements to the Bonjour code in 1.0.2, none of which should result in the behavior described in this thread (nor did we see this behavior in our testing). That is not to discount any of the issues mentioned by posters to this thread - we want to get this working for every one of our customers. At this point, I would recommend deleting the application from your iOS device and then syncing with iTunes to get a fresh copy (of 1.0.2) installed on your device. Please let us know if this improves the situation for you.
We are continuing to improve the Bonjour discovery code and rewrite the sync code itself for version 1.0.3. This version will have better feedback (via the UI) as the performs this process so you will have better information about what the app is doing. These changes will not only make for a better user experience, but will also help us better determine the cause of issues our customers are encountering on their particular WiFi connection.

I have just tried deleting the application from my iPad, and syncing with iTunes to get a fresh copy of 1.0.2.

I’m sorry to say that there is no improvement, and all the symptoms I described earlier remain exactly as before.

I am very sorry to hear that this did not resolve your issues with syncing. Believe me, this is as frustrating on this side as it is on yours. While most users are finding that sync works well “out of the box,” a small but critical mass of users are reporting issues as noted on the Forums. We will continue to work this issue as a high priority with each new release. That said, I believe the ultimate solution is to offer additional mechanisms for syncing iOS devices, and that effort will bear fruit in the first half of 2011.

Looking at reviews for other iOS applications that offer over-the-air syncing, this problem is not unique to DTTG. A number of these apps work fine for me and many others, but some users do not seem to be able to get them to work at all. I know these other developers are struggling to understand the underlying cause(s) of these issues, and we are listening/sharing data with others as new information come to light. I would encourage everyone with sync-related issues to file a bug report (if they haven’t already) so we can deal with you in a more direct manner. To those who have (or will) file bug reports, rest assured that they are not going into the “circular file” and we will keep you updated as we learn more about these problems.

I deleted the app from the iPad, installed it again. Same sync behavior and same problem.

Is it really so that the sync works for a lot of people?

I have not have any problem with sync on the iPad with any other program that the first versions of Things.

I really hope for a solution of this before the first half of 2011.

Deleting and reinstalling the app improved performance here, somewhat.

However, it’s not the normal and expected model for iOS apps to remove and reinstall an app just to make an update stick and operable. (Otherwise, what’s the point of the updating process via the app store?)

Especially in the case of those users who synchronize very large databases to DTTG - removal and reinstall is an annoyance.

I would agree that the delete/reinstall suggestion is not usual or customary. DTTG 1.0.1 resolved a very reproducible bug related to search. Unfortunately, our testing did not turn up the issue currently being reported here. FWIW, I would like to thank the users who did try the delete/reinstall suggestion as it has provided a wealth of information concerning the root cause of this bug. Based on your assistance we will deliver a fix as soon as our next release is submitted to Apple.

While most users are finding that sync works well “out of the box,” a small but critical mass of users are reporting issues as noted on the Forums.

I assume the ones that dont have problems are the ones that are curious, download, try it here and theree a little bit. The “more geeky” ones of us (or lets call them “professionals”) that try to use or do use the ipad for their daily work have much higher requirements/expectiations and might use the app in a different way.
Many times in the last years I had problems with software because I used it in a heavier way or because I used it in different configurations/combinations with other software. For me the normal way is to buy software (yes, I have to admit, I look at the UI, read the description, check the features and then buy it often without even using the trial period), try it out and very quickly get a “feeling” whether the software might play a role in my professional daily life. And it usually doesnt matter whether there are a few bugs or not as long as the whole appearance signals me: ‘this is a good choice’.
What surprises me is that all these users here struggle with the DTTG app instead of just kicking it from their ipad. They must - like me - be very loyal customers… In my case, today I tried to use the app again and again I was disappointed. Even with the latest update my DTTG crashed after returning from the search-mode to the home screen.
And even much much worse I just couldnt find some of the files I had I know that were there before my last sync. And no, I did not change anything in the sync group or elsewhere. Just synched and lost (hopefully just on the ipad!).
I can confirm what OogieM wrote in the beginning of this thread.
It is much too complicated to sync. It is just not intuitive and I have lost a lot of files due to this sync issue. Not everyone is familiar with copying vs. replicating. And even if someone is, still one can never be sure one does not loose files caused by app errors or bugs. I have a job in Bahrain in January and I already know that I wont rely on DTTG when it comes to taking my important files with me… It’s a pity.

To be honest, occasionally I am looking for alternatives. But I am lazy and I dont have enough time for intensive research. But if there is another app I could use that has a counterpart on the several macs I (have to) use and that works with my ScanSnap, I will certainly give it a try as soon as I find it…!
There are some other apps in the itunes store that are famous and nice and pretty and have superb user interfaces. But since their developer cant manage to get the OTA running their loosing existing customers and worth of mouth gives the rest to them. So in the end a successful product fails completely…

And yes, you should soon start with the OTA-sync feature! Hurry up and dont hope for people’s lazyness! :slight_smile:

This is interesting.

I have large and small databases. I sync two of them with DTTG: one is small and contains only 500-600 files at any one time and the other around 9000 files. The initial sync of the large database is a pain and take multiple times to sync completely. However since then, it work perfectly. I found that as long as I do not sync more than 1200-1500 files in one shot, everything work normally.

I bought DTTG as part of a general evalution of replacing my current (simple but functional) Simplenote/Notational Velocity note taking solution with a DT. I love the functionality of DT - esp the cross-referencing (although I wish the memory footprint wasn’t so huge). However I have found that the iOS solution is unusable in its current state.

Bonjour-based syncing is a poor solution in the first instance. Just ask all the Things users who are making their way over to Omnifocus; Asynchronous cloud-based OTA is the only way to go.

But beyond that, my experience with the syncing solution is that it doesn’t work more often than not anyway. I click on sync from my iPad or iPhone & then click on my computer & nothing happens.

One time that it did work it duplicated the document I was editing.

I am looking forward to these issues being addressed. In the meantime the lack of a viable iOS syncing solution means that DT is not usable for my own purposes.

Strongly disagree with this. If Bonjour sync goes away I will find another solution for my database and note taking needs on the iPod. I use Bonjour sync with Omnifocus and I will not use a third party cloud based service at all.

What OF does that I like is automatic sync to the mobile if I am in the same wifi network. I would say that copying how Omnifocus provides sync options would be great but DO NOT get rid of bonjour sync just to add MobileMe or similar services.

Same problem here. All my other syncing iPad-apps sync fine with my Mac. I don’t care why. I don’t care how. They work! Your apps do NOT work!!!

I think it’s a shame, that a company like Devon-Technologies which sell their products for money (and we don’t talk about just a few dollars), should release fine working software. I spent almost 62 $ for the two apps and they are worthless. I should have invested my money in Evernote! And all I get to hear from support is: ‘We are working on that’. Same thing here in the forum in various boards. You schould not WORK on that, you should SOLVE THE PROBLEM!!!
:angry: :angry: :angry: :angry: :angry: :angry: :angry: :angry: :angry: :angry: :angry: :angry: :angry: :angry: :angry: :angry: :angry: :angry: :angry: :angry: :angry: :angry: :angry:

I would like to add that I, too, have been experiencing a complete breakdown of syncing between DTTG and Devonthink Pro on my Mac. DTTG has become entirely unusable for me.

Has it ever worked for you? And what is happening now? What exactly does not work and did, maybe, a reset of the DEVONthink To Go database help?

Please apologize these questions. Vague “sync problems” are really, really hard to track down.

I’d like to add that DTTG is not the only app that many user have problems with regarding syncing. Just visit other software forums for iPad/iPod/iPhone apps that use wifi syncing, you’ll find problems all over.

Having said that, some suggestions in other forums that solve the sync problems are to totally shut down the iPad/iTouch/iPhone and start it up again. That has worked for me with a number of other apps that did not sync. Another suggestion is to click on “Create Network…” under the wifi icon on the OS/X menu bar. Be sure to then define the iDevice’s wifi as the newly created network that is managed by your mac. (No wifi modem is involved, except for the Mac’s.) I have to do that at work, since their wifi modems do not support Bonjour. Some other modems, like Belkin (some models), also do not support Bonjour and that definitely kills syncing with my apps.