Treat cloud indexed folders as removable drives

Do you have smart groups running, espeically on this database?

Default global ones that come with the installation of DT, plus:

  • Item is Pending
  • Extension is ePub
  • Kind is PDF and WordCount is 0 and Tag is not no_ocr

All 3 global ones set in “Search in” Databases.

Nothing specifically linked to the Global Inbox or to the indexed folder.

  • Item is Pending
  • Extension is ePub
  • Kind is PDF and WordCount is 0 and Tag is not no_ocr

Please post a screen capture of the rule you’re referring to.

And the standard ones.

And in case you wanted to know my custom Smart rules,

I have an indexed folder in “Paperwork” database that OCR, and move to Inbox:

And another, manually fired, that converts and move to Inbox the formatted notes or pdf I generate in my RSS feeds database:

Perhaps it is worth checking if this is unticked in all sync stores:

And if you don’t have bonjour active (and sourcing the same database) on more than one machine.

Side Note: You should not uncheck this if you are running DEVONthink To Go, unless you are using a separate sync location with the contents just for it.

Yes, you told me about that in other threads, and I tested it. It lowered the amount of issues, but not completely, but then it forced me to have switched on my iMac always, even on weekends, when I use my MBP, for example. And as @BLUEFROG says, I use DTTG.

Perhaps you have a mac mini always on, but it is not my case and I don’t want to waste more money in more hardware with price of unicorn milk… I’m seriously evaluating not purchase more unicorn Apple technology anymore.

My next steps will be activate the hidden option to not automatically update indexed items to see if that resolves this, but the real thing is they must resolve this kind of issues. Yesterday another guy created a new thread here asking for a variation of my problem (in this case, in iCloud Drive). I remember DT2 didn’t had so many issues with indexed items.

1 Like

Does this still happen after disabling the sync in DEVONthink To Go for a while?

I haven’t tested that. I will do and will back here when tested.

What could be better, set the Schedule to Manual or disable the location in DTTG?

Disabling the location would ensure that it’s never synchronized, not even manually.

Ok, thanks.

I’ve done in my iPhone just now and will do later at home in my two iPads.

Ok, frist day, it happened one more time.

Scenario: from empty scraps folder, this morning I added 8 PDF from my Windows machine via Dropbox. Some time later, I went to my office MacBook Pro and files were indexed without any issue. Now I’ve arrived home, unlocked my iMac, and…

Upper image is after a couple of minutes iMac has been unlocked. DT3 was closed but in memory (closed this morning early via CMD-W).

After a call to “Update Indexed Items”:

After delete and empty recycle bin of one of each duplicate:

Now I open my 3rd Mac, at home. Dropbox synchronizes with some messages about “intelligent synchronization”, open DT3 and…

Afer both “Update Indexed Items” and “Synchronice” (and review each PDF to see if it what says it is:

Going back to my iMac, nothing has changed. I still have right PDFs without any duplicate. And this is why I said in other messages in other threads with my problem that I need to cycle across all DT installations to clean the mess.

Tomorrow I will repeat the same steps, but instead of clean the mess at home, I will left all untouched and check on Monday if work MacBook Pro shows any duplicates or whatever.

Forgot to say that all my 3 iOS devices have the databases disconnected.

In your Dropbox account online, in Settings > General, do you have this enabled?

If so, may I ask why?
And do you see the issue if this is disabled?

I was not aware of that option. It was disabled. And it is.

Cool. Thanks.

PS: I would suggest leaving it disabled as it definitely has the potential to lead to issues. iCloud has a similar function and I had a support ticket from someone who had issues with item links not working because iCloud decided to evict the local file for no apparent reason.

Fine. I even didn’t knew that option was available.

(BTW, I lost a lot of files in iCloud because iCloud removed them without my permission as well, and was the reason I’ve completely stopped using is, as, well, it deleted all my blog and writings history, published articles, novels… I got restored from a physical security copy, but not from iCloud).

This is killing me, really killing.

Ok, now I took my HP Spectre, went to the sofa, read all PDF in scrap and delete all but two. Returned to my iMAC, Dropbox had deleted those files in iMAC but DT didn’t updated them. Is still showed the 8 files.

I made a manual sync and DT cleared all and left only 1 file… The second one appeared in Trash folder (as DT does really don’t delete synchronized files until you empty it, it still was in scrap folder. I moved the file to Scrap folder one more time.

After that I went to my MacBook Pro, waited until DT synchronized and… generated a duplicate of the file that was deleted in the iMAC…

Today experiment. I did a little bit different today. I captured PDF via Safari Reading View, Print, Send to DEVONThink, once captured all files in Global Inbox, and marked all as read, I moved into Scraps folder. Dropbox uploaded the files successfully.

I arrived at home, activated my iMac, waited a couple of minutes with DT suspended (CMD-W from this morning), and then activated it. Result:

Then I opened the MacBook Pro, waited some time while DT was still open in my iMAC, and:

And now I have more duplicates, not having touched anything, in my iMac:

With this I finish my experiments. I don’t have more time to lose with this.