Unable to complete Bonjour sync between iPad and iPhone

I am using ‘DevonThink to go’ 3.04 on my iPad, and I set the iPad up as a server since I want to transfer a database to my iPhone.
(on the iPad: 1. I enabled incoming connections, 2. I specified a password, 3. ‘Devonthink to go’ assigned a port number)

I was able to set up the sync location on my iPhone but when I started the sync process, only the database showed up on my iPhone, but no file or group was downloaded.

The cloud icon on my phone app always has a small blue circle. If I start the sync process, the blue circle goes away, but then it comes back shortly after.
If I long-press the cloud icon on my phone app, It says: No synchronization In progress.

Still, no files or groups appear in the database on the phone.

Any idea what am I doing wrong?


Welcome @josh2782

  1. ‘Devonthink to go’ assigned a port number)

What do you mean here?

In the bonjour options, there are three settings. One of them is a checkbox to enable incoming connections, the second one is a text box to specify a port number for the connection, and the third one is a text box to Set a password.

I enabled the incoming connections to allow my iPhone to connect to the iPad, I specified a password, and I left the port number textbox blank to let the app specify the adequate port number.

Ahh, got it.

only the database showed up on my iPhone

  • The database from the iPad showed up?
    • Is it the Global Inbox?

Yes, the database showed up on my iPhone.
No, it is not the global inbox.

Did you flip the switch to import the database to the iPhone?

I’ve never used an iPad in the mode of “accepting incoming” for Bonjour; but, routinely use Bonjour with my iMac providing this role. But I’ll pass on a few suggestions.

  • on the iPhone’s Settings page, ensure Bonjour is “off”.

  • on the iPhone’s Settings page, press on “Locations”. Press the “Edit” button at top. Should see one active location back to iPad. Press the pencil icon for that location. Check how you set “Download” files.

  • On iPhone Settings page, press on “Locations” and you should see one location back to iPad. Ensure the “on” switch (blue) is on.

  • Then press on the name of that location on the iPad. You should see a list of all the databases at on the iPad. Turn on (blue switch) all those of interest.

Yes, I did.
I found that switch inside the location configuration in the iPhone app

On That screen where I flipped the switch to enable the database sync on my iphone, the message next to the database name says:
‘Not yet synced.’

Yes, I noticed the most common setup is to set a mac as the server.

I did all you are suggesting. However, after starting the sync process, only the database showed up on my iPhone, but with zero items in it.

Final idea … please post a screen shots of the 1.“main” page in DEVONthink ToGo from both iPad and iPhone, and 2. from both iPad and iPhone press on the database name on that page and screen shot of the contents of the database.

And … consider just removing the sync location on iPhone and trying it all again.

Edit: Also reboot all devices (incase a flakey WiFi or other is interferring).

Here are the screen shots

I have already deleted the location on the iPhone several times.
I even created a new database on the iPad with one file in it and tried syncing it to the iPhone, but I get the same result. The database shows up in the iPhone, but no files are in it.

Finally, finally: are both the iPad and iPhone turned on and active? DEVONthink not in the background on either device while the sync is being performed?

Yes, both applications are active.

I noticed that if the iPad’s app is not active, the iPhone location can’t connect.

Still, no luck.

Yes, both apps have to be active to work the sync (as they communicate and they don’t communicate in background, AFAIK). I’m out of ideas. DEVONthink support @BLUEFROG will surely pick this up.

Thank you, I appreciate all your suggestions.

In DEVONthink To Go, select Help > Contact Us to start a Support Ticket. Thanks!

I just started the support ticket. Thank you.

I just did. Thank you