Unable to edit DTTG 3 PDF in PDF Expert - SOLVED

Unfortunately I am unable to edit external PDFs in DTTG 3 using PDF Expert.

I can open the PDF in PDF Expert using the DTTG Files add on, and am able to highlight the document like normal. However, my changes are not recorded in DTTG. In addition, if I close the PDF in PDF expert and try to reload it, my edits are deleted.

Any advice would be appreciated as this workflow worked well in the previous version of DTTG. I am also using the new CloudKit Sync.


This is a known issue. Please see the release notes and other threads here in the forum.


Apologies - thanks.

Note: Acrobat on iOS seems to handle the Open In well, with the edits being applied to the original file as expected.


I tried this.

It did apply the edits to the original, but I also got a second copy through the share process. So I must be doing something wrong.

Plus, the annotating capabilities in Acrobat on iOS are nowhere near as good, flexible or easy to use as iannotate or PDF Expert.

1 Like

No these things can happen when editing PDFs in other apps, depending on how these apps handle it. PDF Expert is good, we know. We reached out for Readdle for exploring why it works for other apps but not for PDF Expert but never got hold of a developer.


I’m sure you know this already, but I think annotations made when file opened in pdf expert are being saved back to the filed in DTTG3 but can’t be seen in DTTG3. When I tried it the other day, I made an annotation in pdf expert closed and opened in DTTG3 and couldn’t see the annotation, but when I reopened in pdf expert the annotation could be seen.

Yes, we know. The PDF engine we’re using adheres closely to Adobe’s PDF standard and does not not show some annotations made by third-party apps that are non-standard. These annotations made in PDF Expert, do you see them in DEVONthink on the Mac?

I tried this following Jmac’s post.

When I share the PDF to PDF Expert from DTTG again, the annotations are in fact showing in PDF Expert still.

When I open the same PDF in Devonthink 3 on the Mac, the annotations made in PDF Expert do not show up.

I exported the PDF from Devonthink 3 to the Desktop and then opened in PDF Expert on the Mac. However, the annotations made in PDF Expert on my iPad were not visible.

As an additional experiment, I also tried opening the same PDF from DTTG 3 to (a) Acrobat on iOS and (b) iannotate.

The annotations made in PDF Expert on IOS were not visible.

I am wondering if PDF Expert is caching the annotations locally for use when you load the file in their app instead of actually writing them to the file.

FWIW DTTG v2.x worked with PDF Expert via opening file inside PDF Expert, annotations saved and visible in DTTG. But doesn’t work with DTTG V3 anymore; PDF Pen does work with DTTG v3 from brief test I did but prefer PDF Expert. Having said that, v3 annotations works much better compared to v2.x.

I am not seeing any better behavior in 2.7.9 and PDF Expert has been known to misbehave in this way for some time now.

Strange, I could open and annotate via opening files from PDF expert (even this week before upgrading to v3) and changes would be displayed in v2 and can’t do the same now after upgrading to v3. Something must have changed. For the meantime, will stick with annotating on DTTG v3.

Yes, we have made some changes to make open-in work for more als which in turn broke it for PDF Expert. Hmm.

Ah, well luckily don’t need to sign via iPad for now and DTTG annotations have improved. Wish you guys well fixing the issue.

I have exactly the same issue. I was editing a pdf on my ipad for 3 hours straight. I opened up DTTG 3 to sync with icloud. Didn’t see any changes in DTTG3. I opened up pdf expert again but the app just froze. Finally got it working again and all my annotations were gone. It even said the pdf i tried to open was broken for a while. It works on my mac when I annotate with pdf expert. Hopefully this will be fixed soon. For now, I make a copy of a PDF on my ipad, annotate it with pdf expert, send it to my mac and upload it to devonthink on my mac.

1 Like

Anyone who has it working? There have been some updates with DTTG and PDF Expert for ipad but it still doesn’t sync. If I annotate a PDF with PDF expert that is locally stored on my ipad through DTTG, it doesn’t show any annotation when I open the file through DTTG or when I open and close the file in PDF Expert. Since the last update, PDF Expert isn’t crashing anymore after trying to annotate a PDF through DTTG.

No, there have been no changes in regarding this situation.

I really wished you had flagged the fact that DTTG3 broke the ability to open ddtg files from within pdf expert with annotations saving back to ddtg . That was an absolute central part of my workflow. I’m not a happy customer …

1 Like