Very Large DT3 Application support files in Library


My Macbook Pro was running out of HD space so I ran a scan and it turns out that the largest file is 24 GB of Application Support Files for DT in the Library section of the Hard Disk.
This is in addition to the 22 GB taken up by the DT databases in the Documents folder.
Is this normal?

@cgrunenberg or @BLUEFROG can probably answer this with more certainty, but my first guess would be this is space taken up by a cache for iCloud.

Do you happen to use that to sync your files?

What’s the exact path of the files and how do you sync your databases?

Thank you for your replies. I use Bonjour to sync DTG and DT3 as well as to sync DT3 on my Macbook Pro and iMac. Don’t use any cloud options.

And do you remember the path of the large files or folders?

I just took a look:

Inbox.dtBase2 is 16.8 GB, Cloudy is 6.32 GB, and Abby is 1.02 GB. Cloudy shows ‘Download’ as its main content. I suspect Cloudy is from a website I had downloaded to DT3 - I had moved all the files to an externally hosted database but perhaps these are backups automatically stored on the system. Abby shows DTOCRHelper as its content.

The folder Cloudy contains data required by the sync, the Downloads folder is a cache but should usually be empty. Is the size of the Downloads folder the same after synchronizing again? Is anything logged to Windows > Log?

No - nothing seems to be connected. Log just shows my RSS feeds which were updated in the last 1 day. Can I manually empty the Downloads folder?
Also what seems strange is that my actually inbox in DT3 only has about 300 files - a quick estimation of total size would be 300-400 MB. But the Inbox.dtBase2 is 16.8 GB

Yes, this shouldn’t cause any harm.

Is a verification of the inbox (see File > Verify & Repair Database…) successful?

Thank you. Yes the repair was successful till about 90% - then I had to abort as it was really slowing down my system. Will try and few things and update. Again thank you for all your help!

I’m having a similar problem. I emptied the Application Support/Cloudy/Downloads folder yesterday. Today it’s back up to 32GB and has again maxed out my hard drive space.

I ran Verify & Repair on all my six open databases. Four were successful. One had an orphaned file that could not be found. One had 1053 missings, that could not be found (1053 errors remained).

… I now also have a couple of databases spontaneously re-opening a few seconds after I close them. And I see several large numbers of items (5000+, 15000+) trying to download or upload in the lower left of the DT window.

  • What version of DEVONthink and macOS are you running?
  • Have you rebooted your machine?
  • What kind of sync are you doing?

Ah, I appear to also be in the same proverbial boat; the DaisyDisk storage analysis app says that the Devonthink sync section of my ~Library folder is currently 262.2 gigs wide.

My setup is current rev DT3 on an M1 Mini running Big Sur & current DT3TG on an iPad Pro on (I know, I know…) the iOS 15 PB. The files are 10 databases of mostly PDFs and images totaling 283 gigs locally hosted, synced on demand, via CloudKit.

This had been a pretty smooth ride until I (again) tried to tame the wild proliferation of blank tags in my databases. A few regrettable choices along these lines led to 24 gigs of PDFs and files suddenly scattered across various inboxes and trash folders by an errant sync. Good times, that.

Fixing this took several days, and I suspect that trying to get the sync to my iPad reset led to my library cache becoming quite bloated. How do I fix this? I’ve verified and repaired all 10 databases, found one with missing files that it could download (from the library, I assume), rebuilt and then replaced that one, but I have been hedging against doing more rebuild operations without cause. Is that all should do to clear the caches properly?

oh, and I have tried rebooting. heh


the Devonthink sync section of my ~Library folder is currently 262.2 gigs wide.

What is the path you are actually looking at?

Also, in DEVONthink’s Preferences > Sync, right-click the sync location, hold the Option key and choose Verify Location Thoroughly.
The results will appear in Window > Log.

The base path reported inDD is ~\Users(My User Account Name)/Library/Mobile Documents/DEVONthink Sync/DEVONthink/ which breaks further into 8 larger and a few small sub folders with randomized names. \Mobile Documents\ is the iCloud sync alias so the actual data is in iCloud, yes? Big Sur is extra persnickity about letting me open that particular folder in Finder (probably for good reason) to suss it out further. My iCloud storage has been noticeably low as well, but I hadn’t taken up that particular windmill just yet.

I’ve set the Verify Location Thoroughly option to run and will report back; this operation was in the documentation, but I’d forgotten about it. Thank you again for your support and your work. And patience.

You’re welcome and thanks for the kind words!

~/Library/Mobile Documents/DEVONthink Sync/DEVONthink/

Unless @cgrunenberg is aware of a difference in location, this isn’t the location for Legacy sync data. The location used by DEVONthink for iCloud then iCloud (Legacy) is ~/library/mobile documents/iCloud~679S2QUWR8~com~devon-technologies~sync.

While trying to get sync up n running again, I’m pretty sure I flipped on Legacy sync at some point, though only for one or two databases for test purposes. It’s off now. In ~/Mobile Documents/ there is only /DEVONthink Sync/ and /iCloud Drive/, which at a guess is everything else in iCloud?

The Thorough Location Verify is still running, and probably will be doing so for a good while. I’m hopeful. Thanks again

In days of old, when DEVONthink just used iCloud Drive, there was a DEVONthink Packet Sync folder. That hasn’t been operational in a long time.

The location of the sync data for a DEVONthink sync isn’t casually accessible in a Finder window. In fact, if you were to access it via some Terminal trickery, this is what you’d see…

If you were to root around in the location, you’d find a DEVONthink subdirectory with a directory for each database in it…

iCloud~679S2QUWR8~com~devon-technologies~sync % ls $PWD; cd DEV*; ls -l
DEVONthink	Documents
total 0
drwxr-xr-x@ 5 tritonx  staff  160 Apr  6 14:14 562151e5b288f4e1b8340e7801490a4590503b172037d084053e2f255ce802f8
drwxr-xr-x@ 5 tritonx  staff  160 Apr  6 14:14 b687c10071e4acfe23040a624a6b02b5500be94c64979b8ab9ae58bd1744b38e

And I am hopeful as well :slight_smile:

I remember transferring that folder between Macs during migrations, but as you say: long ago and far, far away. I never found a good use for DT back then, but as for now.

Now, well.
DT crashed out during the thorough verify the first time, when I tried updating info on a file in the foreground. I restarted it and left it to run,

Somewhat foolishly, I set to repair something from my bad tag edits- some 1000 files had been transferred from one database group structure into the inbox of an alternate database. I spent hours parsing them out, regrouping them, and then putting them back in place. All well in good, til today when I went to look up something and found that the repaired database had been eviscerated- groups are missing or empty, while the remaining groups are missing files. The missing files appear to have been thrown into tags- I can search for them, and they show up at locations like (Database Name) > Tags > misc tag > misc tag > etc. I don’t use nested tags for the most part, or at least I try not to. Meantime, the only entry in the Log says iCloud (Cloudkit) had 1 failed downloads, 0 invalid checksums.

The Devonthink portion of the Mobile Applications is still 265 gigs more or less. Nothing yet appears lost, but its scrambled very very badly, by the beta CloudKit sync and/or my own clumsy machinations. Are there ways to safely recover files that have disappeared into the Tag structure?