What is "Indexing geolocations"

Has someone had the indexing of geolocations getting stuck, even after all location services are turned off (on all devices)? The indexing of geolocations for items in the Global Inbox gets stuck and the Global Inbox stops syncing. With restarting, reinstallation of apps, I can get it sync once but DT on the Mac gets the indexing of geolocation started again and hangs itself up again. Has anyone the same experience, … and found a way to solve it?

Development is looking into possibilities but I haven’t seen it here personally.

I had time ago this issue, before current version or even in previous ones, but “softcore” version: when stuck, pressing the cross in the progress area it closed, and DT synchronized after that. Worst case, pressing the cross didn’t stop the operation, but then a DT restart did the trick. There is some time it does not happen to me anymore.

1 Like

I did cancel the indexing of geolocations, with some dialog (which I cannot remember) and then the problems started. Stopping the indexing does however not work for me and earlier today it was not even possible to stop it. Only the Global Inbox is affected.

At this time, if you are having an issue with geolocations being indexed and stalling in the process, do this…

  1. Quit DEVONthink.
  2. In the Finder, select the ​Go ​menu while holding the ​Option key​, then choose ​Library​.
  3. Go into the Application Support/DEVONthink 3 directory.
  4. Move the Pending directory to the system Trash.
  5. Relaunch DEVONthink and see if the indexing persists.
1 Like

I did this before, with only brief success. I will try again when I am back from traveling.

Offtopic: Before “Indexing geolocation” was introduced I seldom had problems with bonjour sync. Now it sometimes takes several restarts of DEVONthink and DTTG (and sometimes also restarting the mac and iPhone) until sync succeeds. But sometimes even that doesn’t work.

A few minutes ago I was in this situation again and finally tried to force quit DEVONthink. Afterwards sync succeeded.

I then remembered that I also added a “Force quit DEVONthink” action in Alfred Remote.app - I probably did this because in the past sync succeeded after force quitting DEVONthink.

No idea how that bonjour stuff works, but could it be that DEVONthink doesn’t “close” the bonjour “channel” even when the app was quit (not force quit)?

Edit: Forgot to mention that I also used Verify & Repair on mac and iPhone before I tried force quit. DTTG showed 10.000 Parents updated. I also used Verify & Repair in the past before sync succeeded but don’t know whether that’s the cause of the sync problems.

Actually this exists since the first public betas of DEVONthink 3.0. I wonder whether the issue is related to recent macOS updates and/or Apple’s servers as the indexing has been the same all the time.

Problems occurred on Monterey and Ventura.

Bonjour doesn’t use Apple’s servers (or do you mean that they’ve changed something in how bonjour works?)

Forgot another thing: I also disabled AdGuard’s DNS (which creates a pseudo VPN on iPhone) before I tried force quit. But that’s probably not the cause because I used it for years and sync worked. But maybe AdGuard changed something.

The issue is not caused by the sync, it only affects the sync.

Morning. I’m having issues with this which I finally decided to look at today, but I’ve noticed a slightly different issue possibly to that reported here (not sure!). Location services for DT is already disabled for me on iPad and Mac. But I have previously noticed that when I Print to PDF in Safari on iPad, which I do frequently, it’s sometimes trying to geolocate the file (I see the map appear in the info on DTTG. Obviously I do that Print to PDF function from the iPad share sheet, and I don’t know if that’s what’s causing the issue? I don’t know how I’d disable that since it’s a iPad issue, and obviously I want my iPad to know where it is, I just don’t care about that for any files in DT/DTTG. (And actually I’m running a VPN, so the location going into these PDF files on iPad is wrong anyway.)

Aside from finding a way to disable this function, I would also like a way to “nuke” any geolocation data that my databases are already holding (all my files are imported). The data is completely meaningless and I don’t want DT storing it.

You can disable Location Services on s per-application basis in both macOS and iOS.

Aside from finding a way to disable this function, I would also like a way to “nuke” any geolocation data that my databases are already holding (all my files are imported). The data is completely meaningless and I don’t want DT storing it.

At this time, the geolocation property is read-only in DEVONthink, so it can be changed via scripting. @cgrunenberg would have to comment on any other potential options.

Scripting is the only one.

But how when this is the current state…

See latitude & longitude properties.

1 Like

Based on Criss’ suggestion, this is possible via…

tell application id "DNtp" to set latitude of (contents of (current database)) to ""

This would remove the geolocation data displayed for the files in a database since it can’t be resolved without both the latitude and longitude.

For a cleaner approach, you can use…

tell application id "DNtp"
	tell current database
		with timeout of 3600 seconds -- just as a safety measure, but likely unnecessary
			set latitude of contents to ""
			set longitude of contents to ""
		end timeout
		return geolocation of contents
		--> {}		
	end tell
end tell
1 Like

I haven’t implemented your fix yet, but in the meantime I have noticed a weird behaviour, and I have learnt how to screen record on iOS, so that’s fun!

How do I upload a a video on here? I have recorded the behaviour, which I thought was very clever, but I don’t know how to share it :joy:

The behaviour is, when I open the “info” menu in DTTG, for files that have geolocation (that the iPad has applied - I still think the iPad is the root cause of my geo indexing issue, it’s the iPad that is going rogue and trying to add this data), the geolocation text field is flickering. These two screenshots are from the same file, it’s flickering this location info rapidly.

If I sit watching this for maybe a minute, DTTG freezes and I have to hard close. (I don’t know if that’s related but it seems likely.)

On DEVONthink To Go’s databases screen, select ? > Contact Us to start a support ticket. Thanks!

With DEVONthink 3.9.1 Bonjour sync works reliably again :slight_smile: