Where does the focus go when navigating to a formatted note

I’m confused about the following behavior. Is it a bug?

If a group contains a formatted note, then navigating to it does something weird with the focus.

  1. Find a group with some markdown notes and a formatted note.
  2. Click on one markdown note so that it is selected in the list view and the preview/editor is shown below.
  3. Use cursor keys to navigate between different markdown notes and see their previews / content.
  4. Use cursor keys to navigate to the formatted note.
  5. Focus goes somewhere/nowhere. You cannot use cursor keys anymore to navigate the list. Typing any letter key makes some OS sound. This is already problematic, but it continues:
  6. Click on the formatted note in the list to put the focus on it. This does not work. Instead, it opens the ‘rename’ function. One needs to press ESC again to come to focus the formatted note.

What happened? Is it a bug or some feature?

1 Like

I see the same thing, and note that if you click on the icon for the grayed-out formatted note, it acquires the focus. If you click the name, it goes into rename mode.

If I understand correctly, a formatted note is HTML with the added feature of preserving the state of input fields. Maybe the focus shift has something to do with restoring the state of the document. Wild guess.

Happy New Year, that’s a guess, too. Better New Year is a more certain bet.

Best wishes, in any case.

I’m not seeing this behavior here.

  • What is in the content of the formatted note?
  • What operating system are you running?

I’m running MacOS 11.1, DT 3.6.1 on an Intel iMac, Retina 5k, 27 inch, late 2015.

Forgot - the content of the note doesn’t seem to matter. An empty note will display the focus phenomena.

Strange… I’m not seeing any issue here on Big Sur.
Does this persst after rebooting the machine?

Curiously, rebooting temporarily clears the problem. Then, if I add a character to the formatted note (probably if I edit it in any way), the problem recurs.

There is a preferences option I’ve never understood. What does “keyboard navigation” under general do?

I am also on macOS 11.1. I have this problem on both of my two macs (both on 11.1), it is instantly reproducible and persists across reboots. (Also, what would rebooting have to do with this…)

There is a preferences option I’ve never understood. What does “keyboard navigation” under general do?

Allows you to use the keyboard in the Navigate sidebar, which is why it’s under the **Sidebar ** section in the General prefs.

The state of a machine is not static. You have apps and processes and connections, etc. going on all the time. In the case of unusual behavior, a reboot can often eliminate any rogue process, etc. We advocate rebooting devices once a week.

A screen capture or screencast could be helpful.

Here’s what I see, if I can figure out how to attach a video here.

The documents you see like “hacking bank” are not plans for felonies. I’m writing a short book about how to safeguard an organization against crooked treasurers. I’m an honest treasurer, horrified by how much abuse that position seems to attract.

Anyway, the screencast. I clicked on the document called o’henry and then hit the up arrow to go to “test note”. Test note is highlighted briefly, then turns gray.

Screen Recording 2021-01-01 at 12.05.49 PM.zip (3.9 MB)

Sorry, but this sounds absurd to me. It just comes across as rude (“have you tried switching it off and on”) to people who know a bit about computers. What you say is right, but I think it is not relevant here. You have two users confirming the behavior on several machines. What kind of rogue process should this be…? For me this kind of reply makes me want to not use this forum anymore.

In any case, here is my screencast (I also had to first zip the mov before upload – nice security theater).
DT3-Focus-Bug.mov.zip (3.4 MB)

Haha! No worries :slight_smile:

  1. Rebooting a machine is not some idea we came up with to avoid troubleshooting. It is a well known thing to try and is often successful.
  2. We have no idea about the level of anyone’s computer knowledge unless they share that or we’ve known them over time. But regardless, one’s knowledge of computers does not mitigiate the potential efficacy of the suggested method.

Thanks for the screencast.

When the loss of focus occurs, run this script in Script Editor…

tell application id "DNtp"
	set {windowName, windowIndex} to {name, index} of window 1
end tell

What is reported?

The result is {"Inboxes — \"formatted\"", 1} (and formatted is the name of the formatted note.

I can also confirm that this does not occur when DT3 is first started. If I quit and restart the application, the focus works as expected. If I edit the plain text notes (in my screencast) it still works afterwards. If I edit the formatted note, it then breaks and behaves as in the screencast.

Interesting. Thanks for the info.

I’m new to DT and seeing the exact same thing. Running macOS 11.1 with DT 3.6.1.

If there is a list of items that are all PDF’s the focus remains on the list. As soon as you hit a ‘Formatted Note’ the focus switches to the message contents.

I see the same result from the script as @tomka (bar the difference in names).

1 Like

Welcome @harveyd

Thanks for the input.

Bug is still present in 3.6.2.

This wasn’t on the list of fixes for 3.6.2.