Which PDF apps are confirmed working with "open-in-place"?


The PDF editor in DTTG doesn’t address all of my use cases (e.g. missing overview of Annotations), so I’m looking for a third-party app that works with the “open-in-place” functionality. The only one I found that works flawlessly on iPad with DTTG 3.0.6 is Highlights.

Goodreader gives an error saying that the file is invalid because it has been edited from another location. PDF Expert also doesn’t work, as discussed in this thread.

Would appreciate any other app suggestions next to Highlights that work as of today.


We hope that the next release of DEVONthink To Go addresses the error shown by GoodReader. Please let us know if it doesn’t for you. And we’re still in close contact with Readdle about why it doesn’t work on PDF Expert. So far they say it’s something in PDF Expert and they are planning to address it eventually. We also have another idea that we’d like to try to make editing more reliable with third-parties.

1 Like

Thanks for the update, your efforts are much appreciated! I will await the next release in suspense :slight_smile:

There was an update to PDF Expert recently that claimed to fix some backend items. Personally I still cannot edit-in-place DTTG PDFs with PDF Expert. Such a bummer as this was literally the first thing I wanted to do with DTTG after purchasing both it and DT3. Hope to see some good news soon!

1 Like

I just purchased DT3 and DTTG and had this same problem as well :confused: I couldn’t even open PDF files in DTTG with PDF Expert via the Files app. Hopefully this gets fixed soon.

Welcome @egao

You couldn’t open them … why?
Please clarify what the situation is, like messages you be seeing.

I have a 4th gen (2020) 12.9" iPad Pro running iPadOS 14.4.2. I created an encrypted database on my Mac and synced it to my iPad via local connection (Bonjour), with no iCloud backups, so the files are stored locally I presume. In the Info options for the database, I set it to Download files “Always” instead of “On demand”, and made sure all the files were synced. I can open the PDFs offline in DTTG, and I could even see a preview of the PDFs in the File app. But when I press “Open in PDF Expert” from the Files app, it would open PDF expert, show the splash screen for a few seconds, and then crash (close PDF Expert). No error messages are shown.

This problem cannot be consistently reproduced. Earlier today I tried opening a few files and none of them would open. I tried quitting DTTG, PDF Expert, and tried again but it didn’t help. Just now I tried again and it sometimes crashes, sometimes not. I thought it was because I had the same file open simultaneously in DTTG and PDF Expert, so I tried doing that but it didn’t reproduce the problem either.

1 Like

So PDF Expert is crashing?

Yeah it seems like for some reason PDF Expert crashes sometimes when opening files in the DTTG section of the Files app. I haven’t had PDF Expert crash from opening a file before. However it does seem like more of a problem on PDF Expert’s end than DTTG…

1 Like

Yes, a crash of PDF Expert would be a Readdle issue.

You could try PDF Viewer from PSPDFkit. It is free for almost all features but some that require subscription.

And should work fine with DTTG.

Thanks for the suggestion, @rfog!

I can confirm that PDF Viewer seems to be working. Using open-in-place with DevonThink/PDF Viewer accessing the same document, changes made in either app are instantly displayed in the other.

So both Highlights and PDF Viewer can provide an annotation overview and editing functionality. Great start!

PDF Expert would be my preferred option, since it has built-in text to speech and it’s possible to start it from anywhere


since it has built-in text to speech


Well, that’s a start but not quite what I’m looking for. This is what I want to do:

I have my iPhone in the pocket and it reads an entire PDF out loud (via headphones) while I’m on the go. Sometimes the speech output is stopped to add a highlight or notes. Afterwards, it should ideally be possible to continue from that point on the page and again have the PDF read without interruption until the end.

This is possible in PDF Expert and Goodreader, but I much prefer the PDF Expert interface.

My current workaround is to copy the PDF to an app called VoiceDream (great for TTS but no open-in-place available), while making annotations in DevonThink. It’s actually less of a hassle than it sounds, since it’s quick to copy a passage, switch to DT and find it.

Maybe Shortcuts could be a solution?

Yes, it might be. I’ll look into creating a shortcut to automatically find selected text in DevonThink. Thanks

1 Like

Following up on this, @eboehnisch

I’m able to use Shortcuts to copy selected text in the third-party app to the clipboard and open DevonThink. However, it seems like there is no Devonthink action to search for text within the displayed document. Or perhaps I’m missing something?

No, there are no Shortcut actions for in-document searching.
Also, the only file type that currently supports in-document searching is PDF and that search function is not exposed to Shortcuts.

1 Like

Thanks for clarifying @BLUEFROG.

Something for the wishlist, although I fully understand it may not be top priority :wink:

No problem and thanks for the understanding.