WikiLinks not working within formatted notes

Hey everybody! I am new to DEVONthink and just imported my whole evernote database. All my notes are now formatted notes within devonthink. The Wikilinks feature, which brought me over for the most part, does not seem to work with formatted notes though. I have the wikilinks set to automatic and “names and aliasses” If I convert any of the notes to RTF, its text is interpreted as a WikiLink when appropriate so it seems to be a question of the format. I could not find anything with regard to such a file type limitation in the docs. So I don’t know if this is considered a bug or not.

From page 154 of the free e-book Take Control of DEVONthink 3 (1.5) available here (and a must-have):

Tip: WikiLinks work with rich text documents. Plain text and Mark-down documents are also supported if you enable automatic Wiki-Links, described a few paragraphs ahead.

I do not think that limitation is mentioned in the built-in help.

1 Like

Welcome @PaulAmosKreiner

@rpallred is correct with the documentation reference. WikiLinks aren’t supported in formatted notes.

1 Like

Thanks! I figured a technical thing like this should be in the docs, although I have the book PDF and am using it: When I look for something technical, I usually look in the docs.

So the question becomes how I would transform all of my formatted notes to RTF. I will open a new thread for that to make things more clean. Asked that here: Import Evernote as RTF / Mass-Convert Evernote-Imported Formatted Notes to RTF

I figured a technical thing like this should be in the docs

I didn’t put the formats that don’t support it. I put the formats that do.

sorry if i am missing something but the quote from above was from the book – the docs themself don’t state anything with regards to supported formats, at least not on the page “Preferences: WikiLinks” (and i did not find any other relevant page). that is what i meant. (maybe, the book is just considered de-facto-doc.)

I was referring to Help > Documentation > Documents > Document Linking

I’ll add some clarification to the Preferences section. Thanks!