Bonjour location offline

I have followed to the letter the instructions for setting up a Bonjour sync between my MacBook, acting as the server, and my iPhone as client. But when I go to Settings/Locations in DEVONthink To Go and turn on the Bonjour location it shows “Local Network (Offline)” and the WiFi logo and MacBook server name are greyed out. Both MacBook and iPhone are sitting next to each other, and connected to the same network. I have Incoming Connections: Available showing in DEVONthink prefs on the MacBook, and the firewall is turned off in System Prefs.

Any thoughts about what the problem is
Cheers, Kevan

Kevan, when it happens to me, it normally gets fixed by quitting both DT3 and DTTG and restarting. Did you do this?

Yep. Rebooted phone, rebooted computer. Still no connection.

Meanwhile, by the way, I can happily use AirDrop between the two devices—so they can obviously see each other on the network.

And did you try a reboot of the router too?

When something similar happens to me it is because my iPad is connected through mobile data, whilst my Macbook is through wifi.

Yes, I have rebooted the router. And I turned mobile data off on the phone.

So basically I’ve done everything that has been suggested. Still there is no Bonjour connection between the devices.

I am beginning to wonder if the fact that I am synching the devices with a Dropbox sync location that this is somehow inhibiting a Bonjour sync. (Though the DEVONthink user manual does state that you can use both methods in parallel.)

Sync locations don’t affect each other. Is there only one WLAN or are there multiple ones that could be used by your devices?

In this day and age it is a rare device that cannot detect more than one WiFi network at any one time. But the first thing I checked—and have continued to check—is that both my devices in question are on the same network (my default home network).

Which port do you use for incoming connections on the Mac? See Preferences > Sync > Bonjour Options.

56806

As per the instructions, I let the app make the selection. I didn’t set it myself

Did you enable Bonjour in DEVONthink To Go as well? If so, disable it, then relaunch DEVONthink and DEVONthink To Go.

That’s the problem BLUEFROG. I can’t enable Bonjour in DEVONthink To Go! As I wrote in my original post:

I have shut down and reopened both apps on both devices. I have shut down and rebooted both devices. And the router. There is no firewall activated. And both devices are on the same network.

From scratch, here’s what I’ve done:

  1. I click on the Bonjour Options… button in DT3. In the resulting dialogue I check ‘Enable incoming connections’ and ‘Open databases automatically’. I leave the Port field empty (though the app subsequently enters the port as 56806. I enter a Password. (Is this what I’m doing wrong? Should this be a specific password—but in which case, to what?)

  2. In DTTG Settings on my phone, in the SYNC section, I try and set up a new location. (Dropbox is already set up as one location). In the Locations dialogue I can see the network icon, and the name of my account and computer, and the slider is set to on, but the icon and name remain greyed out, with the the description 'Local Network (Offline)"

  3. Back to SYNC settings, the Bonjour section, this shows as ‘Off’. If I click on the right arrow to see the Bonjour options, I have the Enable incoming connections slide set to off (as instructed). I leave the port number empty (though I have also tried manually entering the same number as DT3 provides on my Mac, 56806). I enter the same password as I used in DT3.

In a way I hope I’m doing something wrong—then it would explain why I can’t get a Bonjour connection. But I can’t begin to imagine what.

Do not enable Bonjour in DEVONthink To Go unless you are intending to serve its own databases. This is possible, but unusual when a Mac is involved as the Mac generally acts as the server.

Also, you should not re-use a Port number. This is akin to having two people with the same address of telephone number. Again, disable Bonjour in DEVONthink To Go on either device if the Mac is supposed to act as the Bonjour server.

Here are the simple instructions for setting up a Bonjour sync between Mac and mobile…

On the Mac…

In DEVONthink…

  1. Preferences > Sync > Bonjour Options
    • Check Enable Incoming Connections.
    • Leave the Port blank unless you have a known port to assign.
    • Enter a mandatory Password. You will use this when connecting on the other devices.
  2. Leave DEVONthink running.
On mobile…

In DEVONthink To Go…

  1. Go into Settings > Sync: Locations
  2. You should see a sync location for the Mac. Click the green plus button next to it.
  3. Set the options per your choice and touch Save.
  4. Enter the password you entered on the Mac.
  5. When it has connected, touch the sync location to show the databases list and flip the switch next to databases you want to import.

And just to clarify… Bonjour can be used to Sync between devices, IF:

  1. The devices are on the same network
  2. The network is private or one that allows Bonjour connections or non-standard ports. (Public and corporate WiFi sometimes disallow these.)
  3. Your firewall or an application like Little Snitch is Off or has exceptions added for DEVONthink’s traffic.
  4. Both devices are On and running DEVONthink / DEVONthink To Go 2 (and DTTG2 must be active, regardless of the Sync method).

Finally! I found the problem. I hadn’t tried to delete the existing Bonjour location in DTTG. I did that, then created a new location, as you describe. And it worked!

But now I have another issue: when I slide the switch to select the database I want to sync I get a warning: “This database has not been downloaded completely to this device. Uploading it to a new sync location will cause problems because some items will be missing.”

Surely if the database is still downloading from another sync location (Dropbox) it will eventually upload all the items to the new sync location as they are downloaded from Dropbox?

I wish I could get my head round this whole syncing business!

Thanks for all your help

I haven’t been able to get anything expect the global in box with my iPhone, iPad and MacBook. I decided to not use bonjour since I’m not as familiar with it vs iCloud But since iCloud isn’t working maybe I should try it. The question is do I need to be on the same WiFi for bonjour? The advantage of iCloud I thought is being anywhere to have everything in synch…

Ughhh just bought DEVONthink go, DEVONthink pro, Devonagent, and DEVONSphere but not feeling so good about my purchase yet with this non synch issue!!!

Yes, you need to be on the same network for Bonjour to work, just as I noted above.

Since you are connecting to a location that contains the contents, i.e., the Mac, you can press Proceed.

Ok, great. Thanks for your help. Can’t help think that a more user-friendly interface and/or instructions would have helped avoid this whole episode. I’m not exactly a computer novice, but the procedure and language managed to defeat me.

and/or instructions

You mean outside the instructions I gave you and this from Help > Documentation > In & Out > Sync ?

Your instructions were helpful, and helped me arrive at the solution.

But the first thing you stated was:

Do not enable Bonjour in DEVONthink To Go

Here’s what the help documentation says, after explaining about enabling Bonjour on the Mac:

The Mac with Bonjour enabled should now be visible as a sync location to other devices on your local network. On the other devices, enable it, enter the password, and you can import databases or sync existing databases directly with it.

“On the other devices, enable it…” seems to my small brain to be exactly the opposite of what you, correctly, stated. If you want to set up a Bonjour sync to my mind it seems completely unintuitive to see an item under SYNC in the settings that says, and indeed apparently should say “OFF”.

I think it’s a classic case of people who are really familiar with an interface or a procedure not fully understanding what is going through the mind of an ignorant user—even one that is half intelligent

Anyway, thanks again