Chrome extension, issue with permission box coming up each time

I have 2 Macs both running Catalina 10.15.4 and the DT3.5.

Whenever I am using the Chrome extension to capture something into DT3, the two machines behave very differently.

On the MacMini I get a window which I do NOT get on the MacBook Pro, each time I fire up the extension:
Open DEVONthink 3 window

If I click “Open DEVONTHINK 3“ things work fine, but how come I do NOT have to do it on the other machine?

So I went on the Security preferences, and under Automation I found something quite interesting.

This is the MacMini, where I have the issue:

This is the MacBook Pro, where I do NOT have the issue:

Why in one case I have the Finder and NOT Google Chrome, and in the other I have Google Chrome and NOT the Finder?

Is there a way to force “registering“ an app on the Automation Privacy page?

I have done more than one search on the topic but nothing interesting was discovered.

I noticed on this forum an earlier thread about something similar, but this was a while back when Catalina was just published, and no real answer to the issue was discussed:

Any help is greatly appreciated.

Bye, Luca

Do both computers use the same Chrome versions & preferences? This is a security warning of Chrome, not one of macOS and therefore system preferences do not matter in this case.

One workaround could be to active the Clip to DEVONthink tab of the Sorter and choose Chrome instead of using the extension (or to use the hotkey, see Preferences > Sorter).

1 Like

Do both computers use the same Chrome versions & preferences? This is a security warning of Chrome, not one of macOS and therefore system preferences do not matter in this case.

thanks for giving me a hint to go and look in the right spot, for some reason I thought it was a Catalina security setting, but it really is a Chrome issue.

I found some links pointing to this piece of doc:

and the issue surfaced sometimes in the last few months, and maybe I had not used this feature on the second machine so I did not notice until today. Still, I don’t have the issue on the other, so go figure!

The fix is a simple terminal command changing a default policy:

defaults write com.google.Chrome ExternalProtocolDialogShowAlwaysOpenCheckbox -bool true

and after restarting Chrome, now we will see the checkmark on the page so that the new default will be remembered, like so:

New Chrome option

This Reddit discussion gave me some clues

then I found the corresponding bug:
https://bugs.chromium.org/p/chromium/issues/detail?id=982341

and this discussion on SuperUser provided the answer:

and now the issue is fixed.

It would be nice to understand why I don’t have the issue on the other Chrome installation, same OS and same Chrome version, but I think I will pass and just enjoy the result!

Thanks and bye, Luca

1 Like

Excellent investigation and tip, @lucaberta!

This also appears to work for other Chromium-based browsers (like Maiar, which I use).


That checkbox did not appear until I ran the Terminal command…

defaults write com.maiar.Browser ExternalProtocolDialogShowAlwaysOpenCheckbox -bool true

:smiley:

1 Like

Excellent investigation and tip, @lucaberta!

wow! Happy to have provided some input to @BLUEFROG! Honored to have helped you this time, Jim!

The balance is still very much in your favor, though, as your messages have helped me countless times! :smiley:

Bye, Luca

1 Like

I’ve searched all over but can’t seem to find a solution for this solution, meaning that checking the box only keeps it from popping up again on that particular domain. That helps only a little – I’m clipping things to DT3 from all manner of sites and having to click the box AND the Allow button each time I clip from a new one is unnerving.

Has anyone discovered a way to give Chrome universal permission to open DT3 calls?

Welcome @hamboneftw

No. It’s a Chrome change, so you’d could contact them about it.

(PS: Outside of necessary support, we don’t use Chrome.)

Hi again @BLUEFROG,

Looks like the folks at Chrome have made things even more complicated for us all one more time.

I wonder if you are seeing the same issue with Maian? Have they caught up with the change in the upstream Chromium branch yet?

This is really annoying, and instills a false sense of security for NO good reason…

Bye, Luca

Howdy!

No I am not seeing this new behavior in Maiar.

I just found success resolving that prompt in Chrome by applying the following enterprise policy setting in Terminal. (Credit to Best Mac Tips… DevonThink - Best Mac Tips):

defaults write com.google.Chrome URLAllowlist -array-add ‘x-devonthink://*’

1 Like