Invalid Encryption Key


since dropbox isn’t working for me anymore , i had to switch to iCloud Drive

However i get an error message : Invalid Encryption Key.

Odd thing is , that it’s Syncronising amongst 2 computers.

Any clue what it could be ?

Did you enter exactly the same encryption key on all computers?

No , only on 1 Computer. But on that one i can add and change stuff and it’s syncronised as it should

You have to enter the same encryption key in the Sync setup for each device Syncing with this location.

I did that. Both Passwords are the same on both computers.

Please start a Support Ticket.


In have a very similar issue. The encryption key is 10000% the same on both ends (mac and ipad), one database is syncing, one is not and the error “Invalid Encryption Key” is shown…
How do I:

  1. get rid of this incorrect error message
  2. get the last database to sync…

If necessary I’m willing to reset the iCloud. How do I do this?


I’m now running into same issue. Passwords are same and on iPhone app it says invalid encryption key. I have tried copy pasting as well as manually typing but same results.

Finally I get the problem. The interface have two field i.e. primary field to provide password and then the second field to enter password again.

The UI is bad for this as the font color is white and it blends with backgorund. It does not appear that second field even exist.

If you zoom into key field in picture I have attached, you will find they are two input fields but just by looking at it you can not make out.

DT you guys need to fix this UI issue. I spent 2 hours searching and later found out this stupid issue.

Now, this is working for me but now I have landed into another issue (Icloud Sync problem on iPad).


Glad I came upon this post because I could not understand why the key did not match then realized I had only entered it once. HOWEVER, I now have another problem. When I set up iCloud sync I get a message that I cannot create a database folder because the path already exists. Not sure what this means. I did come across another post advising the deletion of the data from iCloud on DTTG. I have done this and still not working. Not sure if this is same problem, but I feel like I have tried everything

Does it work after rebooting the computer? Which macOS version do you use?

Have you tried to control+click on sync location and then select “Clean,” wait for process to finish (can take awhile depending on size of old database), click again and select remove location, and then tried to set up iCloud sync?


First kudos to coolgoose for even finding this. Although I too have spent a couple of hours on this I could be spending a lot more if I didn’t fall onto this post.

Second, opposite of kudos to DTP team for just explaining why and not solving. I do like the politically correct word of artifact to replace the word issue or error. If you supply people with an app then the support of that app should exist.

Dont get me wrong, your app and support for the most is very good and I am happy with that but a response of this position [not necessarily the writer/messenger bluefrog :)] gets under my skin.

1 Like

You mean not adding dark mode support on day one? Please note that we’re a small software company and had the largest release in our company history going while Apple pushed this behind our back.