"items left to be uploaded" log

Hi,

In 3.8.3 it seems there is new behavior that logs about every 90 seconds that I have a database on my local machine that I am not syncing. This is desired on my part - I have indexed a directory for better search capabilities, and I don’t want or need to sync it. But now, unless I uncheck “Show log automatically”, it keeps the Log window open rather disruptively.

I can see that this /could/ be helpful information for someone who was thinking they had everything sync’d, but it’s definitely not helpful for my use case. One idea might be, if you believe it’s really providing significant value to your users, to have it just log once per session, instead of every time it automatically syncs?

- Eric

According to the log this or another database is actually synchronized. A screenshot of your sync preferences would be useful.

Here’s a screenshot. All open dbs are sync’d to “ebowman-sync”, except “Books”. No open database is sync’d to ebowman-archive. (Is this what you were wishing to see?)

I’ve just noticed this same behaviour but with iCloud:

I’ve no idea what items aren’t uploaded. Also didn’t notice this before 3.8.3. I have 5 databases that are synced via iCloud and 1 that is not.

Please verify your database(s) and also search for item:pending via the toolbar search.

1 Like

Ok, I had some “pending”, clicking on most of them downloaded ok, 2 did not. I deleted those two (happily not so important, though that particular bug is super annoying!). Doing so did not stop the behavior. Then I ran the “Verify & Optimize Databases” script, which was successful. After I did THAT, I got the warning one more time, and now it has stopped. So it seems fixed. Thanks!

Hi - I am getting this same message in my log every two minutes after updating to 3.8.3. I have tried verify and repair on all of the databases, but I still get it.

Mine says “1 items left to be uploaded”

I searched item:pending and there were three results returned which are items I can’t open because they won’t download. I deleted two of them, but the remaining one I would prefer not to delete. It says “File not yet available”

Welcome @timgleason
Did you empty your database’s Trash?

yes

I have deleted the last item and emptied trash again and I think the problem may have stopped.

Thanks Jim.

Thanks. Let us know if you see otherwise.

Sorry to re-open this up but… I am also seeing the constant ‘iCloud (CloudKit) | 1 items left to be uploaded’ message in Log on v3.8.3.

I searched for ‘item:pending’ and found four files, which I deleted. Then I emptied the trash on all three of databases. For good measure (superstition) I also ran Verify & Repair, Check File Integrity, Optimise Database, and finally Synchronise Database on all three databases as well.

Does anyone have any other ideas to fix please? :pray:

@BLUEFROG and it isn’t my NFTs that aren’t uploading!

Thanks to @BLUEFROG for solving this offline.

You’re very welcome :slight_smile:

Just wondering - was the solution highly specific to you, or complicated, or would it be worth posting here for others who may be experiencing similar problems?

The answer was that the files which were continually failing to upload to CloudKit were all indexed files which I had renamed at source and which it transpired that DTT couldn’t find.

I’m convinced that when I had only one CloudKit issue the “Validate and Repair” function which I was running didn’t report a problem. However, when I ran it today it popped up four issues which could be traced to these renamed files. I deleted all four indexed references in DTT and the problem went away.

I hesitated to mention all this because (in embarrassed mumble) I imagine this is all covered in the manual. I only recently started indexing a few iCloud Drive folders and I had incorrectly assumed it was more of a live synchronisation of folder contents. I also didn’t realise that broken references to indexed files would also report the same CloudKit error as for actul files imported into DTT.

3 Likes

Hello,

I am having the same issue and not sure/understand what the fix is. I can not see which files are the 2 that is not uploaded. When I option to click on the files in the log, they are greyed out. Also, when I try to see the list of files using item pending, the list is longer than two files. What do I do with the list of “items pending”? In OneDrive all those files are showing as downloaded and synced but has the cloud icon in DT3.

All my files are (have been since I set up the database) on OneDrive.

Any advice?
Thanks

  • Did you empty DEVONthink’s trash?
  • Have you done a File > Verify & Repair on your databases?

Yes to both.

Did you search for pending items in your database?