OCR leads to larger page format (A4 -> 43,94 x 62,04 cm)


if one run OCR (since DTPO v3.5.1), the results are output as a format with the size 43.94 x 62.04 cm. Original file is DIN-A4.

Does anyone have the same issue?


Same here . Just updated to the new version, DEVONthink 3.5.1 and when digitizing, pages come out in mixed sizes , either tiny or huge.

Using Scansnap ix500, snapscan home 1.7.0(8).

Mac OS 10.15.5

Only change was the Devon update.

Tried rebooting computer, rebooting scanner to no avail.

Is this a bug in the new update?

I am seeing something similar.

I had already updated to 3.5.1 and didn’t notice a problem with page size until today. Doesn’t mean there wasn’t one.

Today, I just deleted ScanSnap Manager and then installed ScanSnap Home in anticipation of a move from Mojave to Catalina.

Now, if I choose “no action” as the option for OCR in DT3, then the file size is correct - US letter ~ 8.5 x 11 inches.

However, If I choose “to searchable PDF” instead (turn on OCR) then the page size reports as 17 x 22 inches.

The file sizes are essentially the same.

I have the same Problem, as i mentioned in my earlier post (OCR Problems after Update 3.51).

This is due to an issue with the ABBYY PDF exporter. Each page in a PDF is extracted at same size as the original (the dpi may be different) and the ABBYY exporter determines the size in the OCR’d PDF file.

Is there a workaround to fix that?

I received feedback from support that the last Abbyy update has a bug.

The error can be remedied by restoring the OCRHelper in (~ / Library / Application Support / DEVONthink 3 / Abbyy / DTOCRHelper.app) from the (TimeMachine) backup to the latest version (1.1.0). Don’t forget to disable the Abbyy extension update.

thanks guys. That fixed my problem.

When will we know it is ok to update the ABBYY FineReader OCR, i.e., when will the bug be squashed?

For those who are not that savvy on the process like me. Here are the steps I took to accomplish this: ( if anyone sees a mistake with this let me know and I will amend )

  1. Quit Devonthink 3
  2. Before you go to time machine, open a new finder window ( Finder, File, “new finder window”), click “view” and pick “as columns”
  3. In the Finder window, click “Go”, click " Go to Folder" , in the window that opens, type or cut and paste what is between the quotes: “~/Library/Application Support/DEVONthink 3/Abbyy/DTOCRHelper.app” , then click Go
  4. Now, go to the time machine icon upper right and click “Enter time machine”
  5. You will see that the helper app you have is not 1.1.0 ( I think it was 1.1.2 or 1.2.0 – can’t remember which ). page back through the time machine finder windows until you see Version listed as 1.1.0, click the DTOCRHelper.app, then click restore in the bottom of the window. I saved it to the documents folder. Then I closed out of time machine.
  6. I then dragged the 1.1.0 version of DTOCRHelper into the Abbyy folder and checked “replace with older version”
  7. I then restarted Devonthink 3.
  8. Tested and the problem was resolved.


I’m having the same problem with larger page format after doing the OCR from within DevonThink. I’m almost afraid to ask, but is there a way get my hands on the last “working” version from the DTOCRHelper.app file when the Application Support folder and system files in general are not part of my regular backup?


when the Application Support folder and system files in general are not part of my regular backup?

Why are you excluding the Application Support folder?

You can:

  1. Quit DEVONthink.
  2. Open /Applications/Utilities/Terminal.app
  3. Copy and paste:
cd ~/Library/Application\ Support/DEVONthink\ 3/Abbyy/; mv DTOCRHelper.app __DTOCRHelper.app; curl -O https://download.devontechnologies.com/applicationsupport/post-install/ocr/fre11/DTOCRHelper.zip; xattr -c DTOCRHelper.zip; unzip DTOCRHelper.zip; rm DTOCRHelper.zip
  1. Press Return.
    Note: Depending on your internet speed it can take several minutes for this to download and extract the OCR application.
  2. After Terminal goes to the next line, type: exit , press Return, and quit Terminal.
  3. Relaunch DEVONthink and attempt OCR again.
1 Like

Thank you very much! That did the trick. This way, I don’t have to change my workflow entirely until a fix from Abbyy arrives. As to your question

Why are you excluding the Application Support folder?

I don’t have a good answer to that. Until now, I only did regular backups from the files I was actually working with, so DevonThink databases and/or documents in in regular folders etc. in finder.
However, I took this situation as a starting point for doing additional backups using TimeMachine.
Thanks again! I really appreciate your support, even in situation where I could easily have solved the problem by myself with a proper backup strategy.

Thanks for the workaround @BLUEFROG, worked right away.

It installed a 1.0.26 version of the OCR code, but I presume it’s a safe one to use meanwhile, until ABBYY fixes their mess!

Bye, Luca

You’re welcome.
Yes, the older build should be safe to use. We have some changes coming in the next maintenance release. Thanks for your patience and understanding.

Thanks for the nice work-around. Helped me a lot.

We have some changes coming in the next maintenance release.

Just to be sure: You are saying it is safe to install the next maintenance release because this bug will be fixed with it?

Best wishes

Yes, it should be fixed now.