Saves from Safari Don't Save Properly

Over the last few days every time I save a bookmark, PDF, or something it saves it a 0 bytes and won’t upload it properly. When I open DT on the desktop I see the things I saved in the inbox but they’re still 0 bytes or will say “Temporary Document” on DTTG.

Anyone have a solution that may fix it?

I’ve tried power cycling the device, I’ve tried multiple networks in case one was weak, just let me know if there are other things I should try.

Welcome @zacattac

  • What version of DEVONthink To Go and OS are you running?

  • What app are you trying to clip from?

  • What URL?

And this is happening on iPad only as well, not sure if that variable matters.

  1. DT 3.8 it looks like. And iPadOS 17.2
  2. I am trying to clip from the native Safari app

I just tried this URL saving markdown and pdf, but neither worked.

  • Clutter-free on the PDF?

  • Are you on your own network?

  • Do you have custom settings on your router, like different DNS servers specified?

Saving that url as Markdown (cluttered) works ok for me on iPad (same versions).

1 Like
  1. yes to clutter free (just tried non-clutter-free and same result)
  2. I am
  3. I don’t think I have any custom settings that would be specific to the iPad connection. Same setup as iOS in terms of automatic DNS settings and automatic ‘configure IP’ settings. I have had everything dialed in with the mesh network for a few years and never had a problem until recently.

It’s working well on iPhone and Mac with the same link from above. And everything ‘syncs’ in terms of deleting on iPhone/Mac/iPad.

Would deleting and re-adding the app be a smart move?

Reinstallation is not an early troubleshooting technique, but you’re more than welcome to try it if you’d like.

1 Like

It may be something I am doing wrong, but I also can’t get share to DTTG on IOS to work correctly from safari on IOS. I can share a bookmark (works OK), but if I choose any other option like PDF or webarchive I end up with a blank ‘temporary file’ in DTTG like @zacattac and that is all. (file I was trying to save was from the Devonthink forum)

DTTG 3.8
IOS 17.1.2
Example page trying to save (say as PDF): DEVONtechnologies | How to Create a Database Template.

I have loads of memory so it is not that. Stumped.

Deleting app, power cycling iPad, reinstalling app worked for me.

Opened it and resynced with Dropbox and after the sync was complete I was able to save things again.

That allows for two explanations:

  • The app was not buggy (why else would a reinstallation of the same version make the bug disappear?)
  • The app was buggy – but why would the bug then disappear by reinstalling the same code?
    So, perhaps simply restarting the iPad would have done the trick?

Power cycling did not work. I did attempt that a few times over the days leading up asking on here.

Very possible it was a bug on the iPad of course. Wouldn’t doubt that for a second, just thought I’d ask in here in case it was a setting or something else.

Clutter-free or not?

Not clutter free. I find clutter free occasionally removes too much.

I will try clutter free and see if I get the same behaviour.

Damn. I retested and all options are working now. It may have been that the original ‘share’ was from Reeder (via safari) than directly from within safari.

Thanks for your response. If I can repeat it in the future I will write down what I did. :grinning:

…and Happy Christmas :christmas_tree:

Glad to hear it! And remember there are intervening networks, servers, etc. at play. Lots of variables.

We wish you and yours a safe, relaxing, Christmas season too :heart: :smiling_face:

Reinstalling isn’t necessary. Sharing to DTTG app isn’t as stable as one would like.

What works for me (most of the time) is to open DTTG directly after saving / sharing to the app, so the grabbed item can load (including thumbnail). After that I open the item so the (web archive) loads and renders as expected.

I also use convert to (one page) pdf or html page, because the web archive contains a lot of crap and also often has to (re)load images.

Furthermore, when an item doesn’t load as expected in the first place (opening results in corresponding error message) it sometimes does show up after a couple of hours or after reopening the app. To me it seems a web service isn’t available.

Besides that, sharing from mobile Firefox is a no go. It only works from Safari or in-app Safari browser.

1 Like

That may be your experience but it is not accurate for everyone…

Clutter-free webarchive from mobile Firefox just now…

Not on two iPhones and one iPad Pro… so yes, maybe my experience. But a consistent one, and no update did fix it. Same goes for storing an pdf from a (secured section of a) website, it does work in Safari but not from Firefox.

After a few days…I 100% think it’s Reeder. I think I opened some in the native Safari app, but now that I think about it, I don’t think I was always exiting the Reeder browser version before saving. Maybe I thought I was.

So yeah, that’s probably what it is.

I’ve been making the same observation (I have 0 bytes documents since May 2023) when sharing/saving web pages from Safari typically as cluttered PDFs or web archives.
DEVONthink To Go 3.8
iOS 16.7.2
Just today reproduced with: Passport – Stratechery by Ben Thompson and GitHub - zenangst/KeyboardCowboy: ⌨ The missing keyboard shortcut utility for macOS
I was able to reproduce this several days apart and via different networks: at home, via 5G, or as a guest on another network.
In one test, DEVONthink To Go created a temporary document (instead of a cluttered web archive) with 0 bytes, with document type = blank, and with a Finder comment, but just minutes later, iCab mobile easily saved the same web page as a web archive on the same iPhone and via the same network.
Analogous with DEVONthink To Go 3.8 on iOS 16.7.2 versus DEVONthink 3.9.3 on macOS 14.1 Intel but via the same network as the iPhone - see the newest four entries in the screenshot.

Where to start with troubleshooting?