Syncing issue CloudKit

I have an issue with syncing 2 Macs and my iPad via CloudKit. My iPad shows the whole time the triangle attached to the little cloud image in the lower left corner of the display. When I also noticed that new files were not synced and I was not able to fix the problem I decided to start from scratch and deleted DTTG 3 completely from my iPad and installed it again. After that it looks like new files are getting synced but the triangle has not disappeared. And the log shows one error message after the other every two minutes which says that a file with a name containing a random combination of 50 or more numbers and letters ending in .manifest. Does somebody know what is going on?

Is a verification of the sync store (see contextual menu in Preferences > Sync) successful?

Mainbase is ok but there seems to be a problem with the Inbox: “Broken or not yet complete data structure of Database …”

On both Macs please choose Help > Report Bug while pressing the Alt modifier key and send the result to cgrunenberg - at - devon-technologies.com On iOS, please tap the ? button, choose Contact Us and send the email to the same address - thanks!

I have the same problem. What was the solution to adddressing the message “Broken or not yet complete data structure of Database …” (Global Inbox)?

Thanks, Olaf

Is a verification of the sync store successful?

I solved my problems by deleting the DTTG apps, deleting all DTTG files on iCloud from within DT, then starting all over with the upload to iCloud, reinstall the DTTG apps, and then syncing one db after another.

The classical solution, told in the following joke:

A computer scientist, physicist and chemist are on a roadtrip when the car breaks down. “I smelled something and suspects its something to do with the petrol.”. To which the physicist says “I heard a noise from the engine and suggest we look at it.” Says the computer scientist: “No worries guys, let us just all get out of the car and get back in.”

2 Likes

I’m seeing the same problem with syncing. I noticed this after annotating a PDF on my iPad. The document didn’t sync, this .manifest error appeared and, unfortunately, the PDF document (and all my annotations) cannot be displayed.

I’ll try uninstalling and reinstalling DTG and hope that might help but I’d like to find out what’s causing this so I can be confident that I’m not going to lose a lot of document annotations again.

This is what I had as well. I solved the problem with a reinstallation of DTTG, following the instructions by @BLUEFROG :wink:

(Before that, in DT on the Mac, Preferences, Sync, I ticked off the databases so that they no longer automatically sync) … and then:

  1. Delete DEVONthink To Go, reinstall it, but do not set up the sync location yet.
  2. On the Mac, go into System Preferences > iCloud and click the Manage button. Select DEVONthink To Go then click the Delete documents and data button.
    This preference doesn’t give a realtime view of the deletion process, so close and return to the Manage section occasionally to check the process. Once iCloud has removed the data from Apple’s server, the DEVONthink To Go entry will disappear.
  3. In DEVONthink’s Preferences > Sync, right-click the CloudKit sync location and choose Clean Location. This will clear out any sync data. You can now add, modify, or remove an encryption key for the sync location, but it must be done before you sync a database. This key would have to be entered in the sync location on other devices syncing with this location.
    If you want to add/modify/remove the encryption key, you can now right-click the sync location and choose Show Info. Make the modification to the encryption key fields, the click outside the Info popup.
  4. Then hold the Option key, control-click the CloudKit sync location and choose Verify Location Thoroughly. The results will be shown in Window > Log.
  5. After these things are done, check the checkbox next to a database in the Databases pane on the right to sync to the location again.
  6. After a successful sync on the Mac, set up the CloudKit location in DEVONthink To Go, using the same encryption key, if you specified one.
  7. Then touch the sync location and import the database.
  8. Repeat syncing and import, one database at a time, as needed.

… took me half a day but so far, so good.

Thank you for taking the time to write out those steps so clearly. I’ve followed that process. As you say, it’s time consuming but I hope that it’s worked. So far, so good.

As you say, it is very much like getting out of the car, shutting the doors and then getting back in again. Let’s hope the motor runs more smoothly now. :wink:

1 Like

Do you still have that PDF that’s reported as corrupted ?

Yes, I have that PDF and it’s no longer corrupted. I’ve lost my previous annotations but I’ve added new annotations to test and the document appears to have synced correctly.

Are you able to say why the .manifest file was causing a problem? Is there something I can do to prevent it happening again?

If you get a PDF that shows that again, please open a support ticket and send it to me.

.manifest files are transactional sync data. It could be an unreliable connection or server issue. It’s really not possible to tell for sure off-hand.

Sure, will do.

I’m feeling a little tentative about making too many annotations in DTTG. Do you have any suggestions for how I might protect annotated files before they sync, just in case I see that issue again?

It’s not a known issue. I had someone report something that sounds similar but I have no corroboration yet and it’s not something I’ve been able to reproduce at will.

It’s known to me :wink:

I just wonder if there’s a process I could adopt to ensure that any important annotated files remain intact. Would you recommend duplicating files or is there a preference setting I should attend to? Any suggestions to try and prevent future problems rather than crossing fingers and waiting to see if it happens again?

There’s nothing specifically built-in for this. And it’s unclear how it occurred or if it’s a small, sporadic issue.

OK. Thanks. I’ll let you know if I see the same behaviour again.