Unable to set Take Note Hotkey to shift-control-cmd-m

For years, using DEVONthink on macOS pre-11, I’ve used m to invoke the Take Note Hotkey globally. I’ve been fortunate enough to received a new Mac laptop recently, and along with that have had to switch to macOS Ventura and recreate some configurations. Now, inexplicably, trying to set DEVONthink keyboard shortcuts, I get this error:

This is confusing because Tools ▹ Filter ▹ Multimedia actually does not use this keyboard combination. Regardless, is there anything that might modulate these shortcut settings?

I looked at the list of hidden preferences but none seemed applicable. I looked for past discussions about this issue and @Cassady reported essentially the same problem last year but there was no solution at the time. I use Keyboard Maestro, but that keyboard sequence does not conflict with anything I set in KM. (Besides, the error message implies it’s coming from DEVONthink itself, or possibly macOS, and not another program.) I’m using DEVONthink version 3.9.

@cgrunenberg or @aedwards would need to weigh in on this.

1 Like

The issue appears to be with a 3rd party library which validates the key combinations. Combinations which include Shift + ^ seem to be more prone to falsely reporting that the key combination is in use. Whilst we investigate this further alternative combinations of either ^ +⌥ + ⌘ or Shift + ⌥ + ⌘ appear to be accepted.

1 Like

Thanks for that info. I’ve ended up switching to / and am in the process of retraining muscle memory. It is going better than usual and that key combo is pretty easy for me to type.

I’ve used Control-Option-N for years. :slight_smile:

I have the same problem as well, but the combination is different: ⌃⌥⌘N (and not Shift + ^).

This is incorrect, since the shortcut I assigned to Data → New→Markdown Text is ⌃⌥N: