Web clipper in Firefox not working with DT3

The web clipper does not work for me in Firefox with DT3. Neither the bookmarklet nor the Firefox extension work.

When I try to clip a website while DT3 is running, the DT3 window becomes active but nothing happens. When I clip the same website while DT2 is running, the clipper works as usual.

Do I need a different web clipper for DT3? Is the current web clipper supposed to work with DT3?

Firefox Clip to DEVONthink bookmarklet works for me on most websites but fails on some: e.g. it doesn’t work on https://discourse.devontechnologies.com/.
I don’t use the browser extension b/c I don’t like that it reloads the page upon saving.
Though the new way of capturing webpages through the sorter fails to work with my Firefox: upon capturing get pop-up error
Unable to click from Firefox. Check DEVONthink has rights to access the web browser and that the active tab has a URL.
I remember allowing access to Firefox, how to fix that?

Have you granted rights for DEVONthink to access Firefox? Check in the System Preferences, Security & Privacy, Privacy Tab. Under “Automation” check that Firefox is listed under the DEVONthink 3 application.

1 Like

Firefox is not listed under Devonthink 3. Finder and Mail are listed though. How can I tell DT3 to ask for permission?


I figured out how to give DT3 permission to use Firefox:

Start new sorter, open it, click the rightmost tab where you can now get clips from browsers, click on the FIrefox symbol. Now you will be asked for permission to use Firefox and Firefox appears under Devonthink 3 in System Preferences -> Security & Privacy -> Privacy Tab.

Does the Web clipper now work with Firefox?

I failed to mention that, now it works as expected.

Thanks for your help!

I also use Firefox and DevonThink3. I can clip sometimes but many times I only get a partial page of what I want to clip. I am using the single page PDF and the output format.

Clipping with DevonThink2 works fine.


URLs to test would be helpful.


Hmm… not seeing any issue with that URL (and it’s a good one :slight_smile: )

This is PDF (Single Page) from Firefox 66.0.3 in macOS Mojave 10.14.4.

Here is what I’m getting.

I have tried clearing the caches of both Firefox and Devonthink and done the capture several times. I am on the same versions of Firefox and Devonthink.

Did you enable the clutter-free option?


I like this formatting better anyway.

Thanks for the help!

BTW, DevonThink2 is great but v3 is even better!

It could have been a hiccup in the deilvery. It works both ways for me.

I have the same problem but the proposed solutions do not work:

  • The clipper does not clip if I click on its Firefox icon (which is gray, I don’t know if that matters). If I do that DT3 show the message that about access rights to the browser
  • Clipping with the sorter with the “URL on clipboard” works fine
  • in System preferences, I have Devonthink 3 allowed to control firefox (I see no option for the clipper to control firefox)
  • I can clip from DT3 via “capture” -> “Clip to DEVONthink…”
  • A service I could call from firefox would be nice BTW.

i have the same problem as Antoine — DT3 is enabled in security & Privacy

however, selecting a grey Firefox icon brings pop-up saying “no rights to access web browser”

further – “URL on clipnboard” is greyed out

What version of DEVONthink are you running?