DEVONsave shortcut works only once in iOS 14

Bump. Just ended up here. Installed DTTG over the weekend, DEVONsave yesterday. Worked once yesterday, now today–nothing…

It needs DTTG3, which is still in beta AFAIK.

2 Likes

Correct. It is still in beta.

2 Likes

I’ve updated the shortcut and provided instructions here:

2 Likes

Great! I downloaded it and I am using it (I even used this shortcut on your blogpost😅) You have a bug in your shortcut, the final shortcut refer to 2nd(devonsave by type) but you are using different name when referring to it, and Devonsave cannot find it

Thanks, tracking the same bug over on the MacPowerUsers forum discussion too. It should be right, but something funny is going on.

Were you able to select the right shortcut and get it to work?

Yes I edited it without problem.

Do you plan to build more shortcuts for DTTG?

I indexed my Obsidian notes in DT, I would like to build a shortcut to open them from DT in external markdown editor and save in place, but currently, I have very limited experience with Shortcuts :wink:

Shortcuts is pretty easy to just play with and figure things out. That said, what you’re describing shouldn’t need shortcuts—I think most apps should do that from the share sheet as is. Depends on how they support iOS Files though.

The shortcut stopped working - when I used it on another page it asked me something , but I misclicked and now nothing happens when I try to use it, l also reinstalled it but this changed nothing , maybe I will try restart

Restart will work. Let me know if it happens again!

Poking around in the DEVONsave shortcut, I ran into this…

It doesn’t appear necessary when clipping from Safari, but I also don’t see it referenced or downloadable from the page on your site.

Thanks. I really don’t understand why this happens. The correct shortcut is “DEVONsave by type”, which is one of the three downloadable from the blog post. The version of the DEVONsave shortcut I use uses “DEVONsave by Type.” Yet, no matter how many times I recreate the iCloud link, it switches it to “identify type.”

If you switch that Run Shortcut action to the “by Type” option, it’ll work!

No problem. Thanks.