DTTG 3.0.5 Won't Sync via Bonjour

Since installing DTTG 3.0.5 yesterday, I have been unable to sync my iPad to my laptop. The sync worked fine and mostly flawlessly prior to the update.

Both the iPad and the laptop are on the same wifi network (my home network); neither is running a VPN; Each attempt to sync databases results in a “Starting synchronization” status (via a long press on the sync icon) followed eventually by a “Connection to server timed out” error log message on both devices. Interestingly, those same messages appeared even when I restarted the iPad, turned off its Wifi and Bluetooth, connected the iPad directly to the laptop with a USB cable (i.e., not via a hub), launched DTTG and tried to sync.

Prior to those timeouts, I received a raft of preview-could-not-be-created messages, like those described in this thread.

Any suggestions?

BTW, the iPad is running iPadOS 14.4.2, and the laptop is running DT 3.6.3 on macOS 10.15.7. And even fully loaded with the databases I’m trying to sync, the iPad has more than 700GB of free space, and the laptop has more than 2.5TB free. In other words, I don’t think space is an issue.

edit: I should also add that only the laptop is designated as the server accepting connections. The iPad has never been set up to accept connections.


Hi @travieso

I was having the same problem yesterday as well.

Like you, I sync with a USB and Local Network connection.

@cgrunenberg kindly came back to me suggesting it could be a server issue, but the problem was persisting this morning.

I deleted the sync location from Settings - Locations section on my iPad and set up the sync again and (so far) it seems to be syncing ok again (it seems slower than before, but so far ok).

Hope this helps.

Rgds SW


Thanks for letting me know I’m not the only one @stephenjw.

I actually did the something similar before posting: I completely deleted DTTG from my iPad, reinstalled it, and then added the databases with the USB cable, It took about four hours for me to get them all back on (definitely not speedy). When I wrote earlier, though, I was having the exact same problem that led me to delete everything this morning. In other words, deleting helped me to repopulate the iPad but it hasn’t resolved the synchronization issues.

This was probably the first time in a long time I immediately updated rather than waited a few days. I guess I’m going to have to return to waiting…

1 Like

Thanks, @travieso. I won’t try deleting everything then. Like you say, the downside of being an early updater. S

Please tap the ? button on i(Pad)OS, choose Contact Us and send us the email to start a support ticket, thanks!

Open the iPad Setting, search for “DEVON” and check wether you enabled “Local Network”:

I am not sure about macOS.

If you want to connect your iPad, check DTTG wether Bonjour is enabled is enabled in DTTG settings.
If you want the iPad to connect the Laptop, Bonjour needs to be enabled there (also not sure about the details)

At me, both are disabled, as I do not Sync locally.

Detals for Bonjour synching are fully covered in the terrific “Help” and the DEVONthink Manual (both same text and organisation).

Further, as described in these documents, Bonjour “accept incoming connections” should be turned “on” on only one device.

1 Like

Noticed the same issue since the update. I sync using WiFi. Have tried removing and re-adding the Bonjour sync location–still won’t sync. I don’t want to remove everything since I do have items added while I was remote.

  • Is there anything reported in DEVONthink’s Window > Log?
  • Is there a triangle on the sync icon in DEVONthink To Go’s bottom toolbar? If so, touch it and tell me what it reports.


7:41:39 AM mobile@robert-allred-iPhone-x.local
Connection to server timed out.
7:44:18 AM mobile@robert-allred-iPhone-x.local
Connection to server timed out.
7:46:56 AM mobile@robert-allred-iPhone-x.local
Connection to server timed out.


allredfamily@allredfamilymacbookpro.[redacted].local: connection to server timed out.
7:46 AM

Have you quit and relaunched DEVONthink and DEVONthink To Go?

Yes. But just quit and restarted both again to be certain–same behavior, same errors.

from the Mac does a “ping” to the iphone work to confirm network connectivity? can get the IP address of the phone in its network settings. can run the ping command from a terminal box.

You can try this handy, free app to check the status of Bonjour connections (of all kinds)

Look for _devoncloudy._tcp.


Downloaded and installed Discovery. I can see _devoncloudy._tcp active.

Successfully pinged iPhone from terminal with no packet loss.

Thanks @BLUEFROG, @cgrunenberg et al for your responses. Sync seems to be working for me since deleting the sync location and re-setting up on my iPad (Discovery shows _devoncloudy._tcp active for me, too), but sync is much slower than it was before updating (eg I created a 21 byte test file, pulled down on the left pane in ios to sync, it spent 35 s on “Starting synchronisation” and another 25 s to sync the file). But it is otherwise currently working for me for now.

Has anyone found a persistent workable solution? So far it seems, no one “at the home office” has been able to replicate the issues described above.

The laptop location shows up on the iPad (with Bonjour enabled only on the laptop), but syncing never happens. The best I can do (which clearly isn’t syncing) is to entirely delete the application and its data from the iPad and then reinstall it and each database. Deleting individual databases and trying to add them back has not been a consistently successful strategy, and even if it were, that still wouldn’t be syncing.

Although I appreciate the posters who tried to describe how to set up syncing, I should say again that the original issue was that syncing had been working before the update and stopped working afterwards. In other words, syncing was set up and functioning and then stopped functioning. Redoing the settings sometimes works, but it seems something else is at work (or not at work)…


1 Like

No we can’t reproduce the issue at this time but are going back through any recent sync updates (none Bonjour specific), to see if there’s anything that could contribute to an issue. However, it’s also curious we (and many others) haven’t seen any effects.

1 Like

Travis, is it possible that the timing was a coincidence? Did anything else update in the same timeframe, so maybe router firmware, a firewall or something of that ilk?

@BLUEFROG @Blanc My best guess for now is that somehow, somewhere, my installation or settings got corrupted.

Always thinking that operator error might still be a problem to rule out, I tried after that last message to be even more methodical, and it seems to have worked. I deleted DTTG and its data. Restarted the device. Installed DTTG. Launched it, made my basic settings (careful this time not to enable preview creation, which seemed to be where the issues initially started), and then restarted the device again. Then, one by one, I started adding databases back, and, to my great surprise, after each new addition all the previous ones would synchronize. I’m astonished. I don’t know what changed, but I’m glad that things seem to be back to normal. I’m only about a third of the way through reinstallation, but it’s looking good. I’ll keep my fingers crossed …

edit: but as @stephenjw observed, the subsequent syncs are slow, even when no changes have been made.