General CFsocket error / AsyncSocketErrorDomain -1

Dear all,

I am new here and I am sorry to open a thread again with this permanent topic:

I get the above error message when syncing between MacBook (DEVONthink 3.5.1 Pro) and iPhone (DTTG) via Bonjour.

After setting up Bonjour for the first time, the sync worked fine for a few days until it stopped working at some point - I don’t know what caused this.

A new setup according to the manual leads to the above message. I am at a loss. Can you help?

Thanks in advance.

Stephan

Welcome @Smett

Do you have Bonjour enabled in DEVONthink To Go ?

1 Like

Yes, it is activated. Tried with and without port entry. Compared the port numbers and aligned. It worked some days ago, meanwhile it does not.

Simoultaneous, I can see a message on the iphone (DTTG): “NSNetServicesErrorDomain-72000”.

You should not have Bonjour enabled in DEVONthink To Go unless it was serving it’s own databases. Disable it, then quit and relaunch both DEVONthink and DEVONthink To Go.

2 Likes

My plan is to use the MacBook as “Server” and the iPhone as “Client”. All data are save on the MacBook and synced via iCloud.

The iPhone should be used as my toy to access documents or to scan and add invoices, for instance, out of the office.

Those invoices should be added to the MacBook (synced via Bonjour) if I am back in the office.

How to continue? I disabled Bonjour on DEVONthink To Go, quit both DEVONthin and DEVONthink To Go. How can data by synchronised if Bonjour is not enabled in DEVONthink TO GO.

I am sorry to ask stupid questions but you see me slightly confused.

Thanks in advance.

Stephan

You only turn on Bonjour in the device you want to be the server (macOS or iOS), so in your case your MacBook Pro. You can then connect to the server from any client (macOS or iOS), but not by turning on Bonjour on those devices. For every device you turn on Bonjour, you are creating an additional server device. Disable on ios and restart as Jim mentioned above and it will work.

Thank you, Greg. That’s what I did.

At which Moment the documents (or names of documents) will be shared between both gadgets? Inbox and database do not appear on my iPhone. On the other hand, the test file on my iPhone has not been transferred to the MacBook.

Did I miss something?

Yes, now go into Preferences>Sync>Locations on your iPhone and select your MacBook Pro which shows as the Local Network option. It’s unchecked in my screen cap below. You will be prompted for the password you assigned in Bonjour on the MBP, and then you are all set, once you check your download preferences for the databases.

All of a sudden it works like magic. Thank you so much. You made my weekend.

Stephan

2 Likes

I have two macs and an iphone and a ipad. If i have some databases on one mac and some on the other and in addtion some on the iOS devices, all must be server? Given the discussion above, it seems, you would suggest to move all data base to one mac, and make the other mac and iOS devices clients only?
I have a similar errror in my log and iOS says Server Busy.

Kind regards

If i have some databases on one mac and some on the other and in addtion some on the iOS devices, all must be server?

If you are using a Bonjour sync, then you can enable Bonjour on each device and sync the databases specific to the individual devices. The other devices would connect as a client and import the databases.

However, once one device has all the databases, you could disable Bonjour on the other devices, and let it act as the Bonjour server.

Given the discussion above, it seems, you would suggest to move all data base to one mac, and make the other mac and iOS devices clients only?

This would certainly be ideal.

How would this apply to global inbox?
Is it preferred not to sync it then?
My main goal would be to have the same content on all devices, i hope my databases will not grow that large that i do not have enough space on all devices …

Kind regards

How would this apply to global inbox?

Just choose a device to be the server for the Inbox. Let the others sync as clients.

Is it preferred not to sync it then?

That’s a personal decision.
All syncing is optional.

Hi, I’m receiving the same error message but thanks to the above replies may finally be on the way to solving my issues. Here’s what I’m trying to do:

I have a massive DevonThink database of saved news articles on my Mac. It’s my archive where I store all articles I collect. I mostly read and save articles to DTTG on an iPhone or on DevonThink on an iPad. I only use the inboxes as temporary storage space there. I want the iPhone and iPad inboxes to be the servers of newly saved articles that are delivered to the DevonThink global inbox on the Mac, from where I manually sort the new articles and put them into different subfolders in the database stored on the Mac, sorted by category of news topic. So I sync with Bonjour, having turned on the Bonjour options on the iPhone and iPad and having turned off that option on the Mac. Synching seems to work now but I still get that error message. Am I missing something and is this setup generally sound in your opinion? Thanks

Welcome @thefriendlyghost

You should not have Bonjour enabled on multiple devices unless they’re syncing independent databases.
If you’re syncing one set of databases, you should only have one Bonjour server active with clients connected.

Thanks for your fast reply. Can you suggest another setup that would work in order to sync several “servers” that supply data for only one unified global inbox?

You’re welcome/

There is only a need for one server. Sync is bidrectional by design so changes made on one syncing device - whether client or server - propagate to the other devices.

Decide which device is the server and which are the clients. Clean and simple.

PS: There is a forum post I wrote specifically about Bonjour: Bonjour Simplified